7.0.10RC1
This commit is contained in:
parent
9ded977176
commit
169d34b351
74
.gitignore
vendored
74
.gitignore
vendored
@ -2,78 +2,8 @@ clog
|
||||
php-5.3.*.bz2
|
||||
php-5.4.*.bz2
|
||||
php-5.5.*.xz
|
||||
/php-5.5.0beta1.tar.xz
|
||||
/php-5.5.0beta2.tar.xz
|
||||
/php-5.5.0beta3.tar.xz
|
||||
/php-5.5.0beta4.tar.xz
|
||||
/php-5.5.0RC1.tar.xz
|
||||
/php-5.5.0RC2.tar.xz
|
||||
/php-5.5.0RC3.tar.xz
|
||||
/php-5.5.0RC3-strip.tar.xz
|
||||
/php-5.5.0-strip.tar.xz
|
||||
/php-5.5.1-strip.tar.xz
|
||||
/php-5.5.2-strip.tar.xz
|
||||
/php-5.5.3.tar.xz
|
||||
/php-5.5.3-strip.tar.xz
|
||||
/php-5.5.4-strip.tar.xz
|
||||
/php-5.5.5-strip.tar.xz
|
||||
/php-5.5.6-strip.tar.xz
|
||||
/php-5.5.7-strip.tar.xz
|
||||
/php-5.5.8-strip.tar.xz
|
||||
/php-5.5.9-strip.tar.xz
|
||||
/php-5.5.10-strip.tar.xz
|
||||
/php-5.5.11-strip.tar.xz
|
||||
/php-5.5.12-strip.tar.xz
|
||||
/php-5.5.13-strip.tar.xz
|
||||
/php-5.6.0RC1-strip.tar.xz
|
||||
/php-5.6.0RC2-strip.tar.xz
|
||||
/php-5.6.0RC3-strip.tar.xz
|
||||
/php-5.6.0RC4-strip.tar.xz
|
||||
/php-5.6.0-strip.tar.xz
|
||||
/php-5.6.1RC1-strip.tar.xz
|
||||
/php-5.6.1-strip.tar.xz
|
||||
/php-5.6.2-strip.tar.xz
|
||||
/php-5.6.3RC1-strip.tar.xz
|
||||
/php-5.6.3-strip.tar.xz
|
||||
/php-5.6.4RC1-strip.tar.xz
|
||||
/php-5.6.4-strip.tar.xz
|
||||
/php-5.6.5RC1-strip.tar.xz
|
||||
/php-5.6.5-strip.tar.xz
|
||||
/php-5.6.6RC1-strip.tar.xz
|
||||
/php-5.6.6-strip.tar.xz
|
||||
/php-5.6.7RC1-strip.tar.xz
|
||||
/php-5.6.7-strip.tar.xz
|
||||
/php-5.6.8RC1-strip.tar.xz
|
||||
/php-5.6.8-strip.tar.xz
|
||||
/php-5.6.9RC1-strip.tar.xz
|
||||
/php-5.6.9-strip.tar.xz
|
||||
/php-5.6.10RC1-strip.tar.xz
|
||||
/php-5.6.10-strip.tar.xz
|
||||
/php-5.6.11RC1-strip.tar.xz
|
||||
/php-5.6.11-strip.tar.xz
|
||||
/php-5.6.12RC1-strip.tar.xz
|
||||
/php-5.6.12-strip.tar.xz
|
||||
/php-5.6.13-strip.tar.xz
|
||||
/php-5.6.14RC1-strip.tar.xz
|
||||
/php-5.6.14-strip.tar.xz
|
||||
/php-5.6.15RC1-strip.tar.xz
|
||||
/php-5.6.15-strip.tar.xz
|
||||
/php-5.6.16RC1-strip.tar.xz
|
||||
/php-5.6.16-strip.tar.xz
|
||||
/php-5.6.17RC1-strip.tar.xz
|
||||
/php-5.6.17-strip.tar.xz
|
||||
/php-5.6.18RC1-strip.tar.xz
|
||||
/php-5.6.18-strip.tar.xz
|
||||
/php-5.6.19RC1-strip.tar.xz
|
||||
/php-5.6.19-strip.tar.xz
|
||||
/php-5.6.20RC1-strip.tar.xz
|
||||
/php-5.6.20-strip.tar.xz
|
||||
/php-5.6.21RC1-strip.tar.xz
|
||||
/php-5.6.21-strip.tar.xz
|
||||
/php-5.6.22RC1-strip.tar.xz
|
||||
/php-5.6.22-strip.tar.xz
|
||||
/php-5.6.23RC1-strip.tar.xz
|
||||
/php-5.6.23-strip.tar.xz
|
||||
php-5.6.*.xz
|
||||
/php-7.0.8.tar.xz
|
||||
/php-7.0.9RC1.tar.xz
|
||||
/php-7.0.9.tar.xz
|
||||
/php-7.0.10RC1.tar.xz
|
||||
|
@ -1,67 +0,0 @@
|
||||
From 99d6e09c3d6679bb522836c833d0cfd4f79c6014 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Fri, 8 Jul 2016 10:46:33 +0200
|
||||
Subject: [PATCH] Fixed Bug #72564 boolean always deserialized as "true"
|
||||
|
||||
---
|
||||
ext/wddx/wddx.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ext/wddx/wddx.c b/ext/wddx/wddx.c
|
||||
index 2cc3c8b..cb0c01e 100644
|
||||
--- a/ext/wddx/wddx.c
|
||||
+++ b/ext/wddx/wddx.c
|
||||
@@ -1013,9 +1013,9 @@ static void php_wddx_process_data(void *user_data, const XML_Char *s, int len)
|
||||
|
||||
case ST_BOOLEAN:
|
||||
if (!strcmp((char *)s, "true")) {
|
||||
- Z_LVAL(ent->data) = 1;
|
||||
+ ZVAL_TRUE(&ent->data);
|
||||
} else if (!strcmp((char *)s, "false")) {
|
||||
- Z_LVAL(ent->data) = 0;
|
||||
+ ZVAL_FALSE(&ent->data);
|
||||
} else {
|
||||
zval_ptr_dtor(&ent->data);
|
||||
if (ent->varname) {
|
||||
--
|
||||
2.1.4
|
||||
|
||||
From bfc42211d3cc5aa6cd2bdb10ef5004ce22099acb Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Fri, 8 Jul 2016 10:45:13 +0200
|
||||
Subject: [PATCH] add test for bug #72564 (7.x regression)
|
||||
|
||||
---
|
||||
ext/wddx/tests/bug72564.phpt | 20 ++++++++++++++++++++
|
||||
1 file changed, 20 insertions(+)
|
||||
create mode 100644 ext/wddx/tests/bug72564.phpt
|
||||
|
||||
diff --git a/ext/wddx/tests/bug72564.phpt b/ext/wddx/tests/bug72564.phpt
|
||||
new file mode 100644
|
||||
index 0000000..4711ef8
|
||||
--- /dev/null
|
||||
+++ b/ext/wddx/tests/bug72564.phpt
|
||||
@@ -0,0 +1,20 @@
|
||||
+--TEST--
|
||||
+Bug #72564: wddx deserialization of boolean
|
||||
+--SKIPIF--
|
||||
+<?php if (!extension_loaded("wddx")) print "skip"; ?>
|
||||
+--FILE--
|
||||
+<?php
|
||||
+ foreach([true, false, NULL] as $v) {
|
||||
+ $x = wddx_serialize_value($v);
|
||||
+ var_dump($x, wddx_deserialize($x));
|
||||
+ }
|
||||
+?>
|
||||
+Done
|
||||
+--EXPECT--
|
||||
+string(84) "<wddxPacket version='1.0'><header/><data><boolean value='true'/></data></wddxPacket>"
|
||||
+bool(true)
|
||||
+string(85) "<wddxPacket version='1.0'><header/><data><boolean value='false'/></data></wddxPacket>"
|
||||
+bool(false)
|
||||
+string(68) "<wddxPacket version='1.0'><header/><data><null/></data></wddxPacket>"
|
||||
+NULL
|
||||
+Done
|
||||
--
|
||||
2.1.4
|
||||
|
9
php.spec
9
php.spec
@ -58,12 +58,12 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
#global rcver RC1
|
||||
%global rcver RC1
|
||||
%global rpmrel 1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 7.0.9
|
||||
Version: 7.0.10
|
||||
%if 0%{?rcver:1}
|
||||
Release: 0.%{rpmrel}.%{rcver}%{?dist}
|
||||
%else
|
||||
@ -111,7 +111,6 @@ Patch46: php-7.0.0-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: bug72564.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -724,7 +723,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .bug72564
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1498,6 +1496,9 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Aug 3 2016 Remi Collet <remi@fedoraproject.org> 7.0.10-0.1.RC1
|
||||
- Update to 7.0.10RC1
|
||||
|
||||
* Wed Jul 20 2016 Remi Collet <remi@fedoraproject.org> 7.0.9-1
|
||||
- Update to 7.0.9 - http://www.php.net/releases/7_0_9.php
|
||||
- wddx: add upstream patch for https://bugs.php.net/72564
|
||||
|
Loading…
Reference in New Issue
Block a user