parent
906277d5f8
commit
24eb87bbbd
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ php-pecl-http.spec~
|
||||
/pecl_http-2.0.1.tgz
|
||||
/pecl_http-2.0.3.tgz
|
||||
/pecl_http-2.0.4.tgz
|
||||
/pecl_http-2.0.5.tgz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From d6975fac1d5c88362e9ce625e9b5248e23b3cfb1 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Thu, 2 Jan 2014 17:19:18 +0100
|
||||
Subject: [PATCH] Fix build with -Werror=format-security
|
||||
|
||||
---
|
||||
php_http_client_curl.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/php_http_client_curl.c b/php_http_client_curl.c
|
||||
index cc5e810..4033b9f 100644
|
||||
--- a/php_http_client_curl.c
|
||||
+++ b/php_http_client_curl.c
|
||||
@@ -1807,7 +1807,7 @@ static STATUS php_http_client_curl_exec(php_http_client_t *h)
|
||||
/* see http://msdn.microsoft.com/library/en-us/winsock/winsock/windows_sockets_error_codes_2.asp */
|
||||
php_error_docref(NULL TSRMLS_CC, E_WARNING, "WinSock error: %d", WSAGetLastError());
|
||||
#else
|
||||
- php_error_docref(NULL TSRMLS_CC, E_WARNING, strerror(errno));
|
||||
+ php_error_docref(NULL TSRMLS_CC, E_WARNING, "%s", strerror(errno));
|
||||
#endif
|
||||
return FAILURE;
|
||||
}
|
||||
--
|
||||
1.8.4.3
|
||||
|
@ -6,10 +6,10 @@
|
||||
#
|
||||
# Please, preserve the changelog entries
|
||||
#
|
||||
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
|
||||
%{!?php_incldir: %global php_incldir %{_includedir}/php}
|
||||
%{!?__pecl: %global __pecl %{_bindir}/pecl}
|
||||
%{!?__php: %global __php %{_bindir}/php}
|
||||
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
|
||||
%{!?php_incldir: %global php_incldir %{_includedir}/php}
|
||||
%{!?__pecl: %global __pecl %{_bindir}/pecl}
|
||||
%{!?__php: %global __php %{_bindir}/php}
|
||||
|
||||
# The project is pecl_http but the extension is only http
|
||||
%global proj_name pecl_http
|
||||
@ -17,7 +17,7 @@
|
||||
%global with_zts 0%{?__ztsphp:1}
|
||||
|
||||
Name: php-pecl-http
|
||||
Version: 2.0.4
|
||||
Version: 2.0.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Extended HTTP support
|
||||
|
||||
@ -26,8 +26,6 @@ Group: Development/Languages
|
||||
URL: http://pecl.php.net/package/pecl_http
|
||||
Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
|
||||
|
||||
Patch0: %{proj_name}-build.patch
|
||||
|
||||
# From http://www.php.net/manual/en/http.configuration.php
|
||||
Source1: %{proj_name}.ini
|
||||
|
||||
@ -39,10 +37,10 @@ BuildRequires: php-spl
|
||||
BuildRequires: php-pear
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: zlib-devel >= 1.2.0.4
|
||||
BuildRequires: libevent-devel >= 1.4
|
||||
BuildRequires: curl-devel >= 7.18.2
|
||||
BuildRequires: php-pecl-propro-devel
|
||||
BuildRequires: php-pecl-raphf-devel
|
||||
BuildRequires: libevent-devel >= 1.4
|
||||
|
||||
Requires(post): %{__pecl}
|
||||
Requires(postun): %{__pecl}
|
||||
@ -70,11 +68,11 @@ Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}%{?prever}
|
||||
Provides: php-%{pecl_name} = %{version}%{?prever}
|
||||
Provides: php-%{pecl_name}%{?_isa} = %{version}%{?prever}
|
||||
|
||||
%if 0%{?fedora} < 20
|
||||
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
|
||||
# Filter shared private
|
||||
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
|
||||
%{?filter_setup}
|
||||
%endif
|
||||
%{?filter_setup}
|
||||
|
||||
|
||||
%description
|
||||
@ -113,9 +111,6 @@ These are the files needed to compile programs using HTTP extension.
|
||||
|
||||
mv %{proj_name}-%{version}%{?prever} NTS
|
||||
cd NTS
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
|
||||
if test "x${extver}" != "x%{version}%{?prever}"; then
|
||||
: Error: Upstream HTTP version is now ${extver}, expecting %{version}%{?prever}.
|
||||
@ -133,15 +128,24 @@ cp -pr NTS ZTS
|
||||
|
||||
|
||||
%build
|
||||
peclconf() {
|
||||
%configure \
|
||||
--with-http \
|
||||
--with-http-zlib-dir=%{_prefix} \
|
||||
--with-http-libcurl-dir=%{_prefix} \
|
||||
--with-http-libevent-dir=%{_prefix} \
|
||||
--with-libdir=%{_lib} \
|
||||
--with-php-config=$1
|
||||
}
|
||||
cd NTS
|
||||
%{_bindir}/phpize
|
||||
%configure --with-php-config=%{_bindir}/php-config
|
||||
peclconf %{_bindir}/php-config
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%if %{with_zts}
|
||||
cd ../ZTS
|
||||
%{_bindir}/zts-phpize
|
||||
%configure --with-php-config=%{_bindir}/zts-php-config
|
||||
peclconf %{_bindir}/zts-php-config
|
||||
make %{?_smp_mflags}
|
||||
%endif
|
||||
|
||||
@ -225,6 +229,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Apr 04 2014 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
|
||||
- Update to 2.0.5
|
||||
|
||||
* Thu Jan 02 2014 Remi Collet <remi@fedoraproject.org> - 2.0.4-1
|
||||
- Update to 2.0.4
|
||||
- fix link to documentation
|
||||
|
Loading…
Reference in New Issue
Block a user