- Add patch to fix building with GCC 4.4
This commit is contained in:
parent
a83eed9265
commit
a720b1cd0c
11
pfstools-1.7.0-gcc44.patch
Normal file
11
pfstools-1.7.0-gcc44.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- pfstools-1.7.0/src/filter/pfspanoramic.cpp.orig 2009-03-23 17:23:39.000000000 -0700
|
||||
+++ pfstools-1.7.0/src/filter/pfspanoramic.cpp 2009-03-23 17:27:34.000000000 -0700
|
||||
@@ -195,7 +195,7 @@
|
||||
{
|
||||
char *opts;
|
||||
|
||||
- if(opts = strchr(name, '/'))
|
||||
+ if(opts = strchr((char *)name, '/'))
|
||||
{
|
||||
*opts++ = '\0';
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
Name: pfstools
|
||||
Version: 1.7.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Programs for handling high-dynamic range images
|
||||
|
||||
Group: Applications/Multimedia
|
||||
@ -9,6 +9,7 @@ URL: http://pfstools.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Patch1: pfstools-mDATA.patch
|
||||
Patch2: pfstools-1.7.0-bf1.patch
|
||||
Patch3: pfstools-1.7.0-gcc44.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: automake
|
||||
@ -117,6 +118,7 @@ etc., for developing programs which can handle HDR graphics files.
|
||||
%setup -q
|
||||
%patch1 -p1 -b .mDATA
|
||||
%patch2 -p1 -b .bf1
|
||||
%patch3 -p1 -b .gcc44
|
||||
# Remove the following once the patch for the Makefile.am file
|
||||
# is not necessary anymore.
|
||||
aclocal
|
||||
@ -269,6 +271,8 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/pfs-1.2/pfs.h
|
||||
|
||||
%changelog
|
||||
* Mon Mar 23 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 1.7.0-5
|
||||
- Add patch to fix building with GCC 4.4
|
||||
|
||||
* Wed Feb 25 2009 Ulrich Drepper <drepper@redhat.com> - 1.7.0-4
|
||||
- recompile for hdf5 ABI change
|
||||
|
Loading…
Reference in New Issue
Block a user