Patch for the #1037243 (-Werror=format-security) non-bug

This commit is contained in:
Tomas Smetana 2013-12-09 14:05:15 +01:00
parent 7656da6988
commit 4212a1cc99
2 changed files with 18 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up pfstools-1.8.5/src/pfs/pfs.cpp.wformat pfstools-1.8.5/src/pfs/pfs.cpp
--- pfstools-1.8.5/src/pfs/pfs.cpp.wformat 2013-12-06 12:46:04.196939099 +0100
+++ pfstools-1.8.5/src/pfs/pfs.cpp 2013-12-06 12:47:58.167480681 +0100
@@ -525,7 +525,7 @@ static void writeTags( const TagContaine
TagList::const_iterator it;
fprintf( out, "%d" PFSEOL, tags->getSize() );
for( it = tags->tagsBegin(); it != tags->tagsEnd(); it++ ) {
- fprintf( out, (const char*)(it->c_str()) );
+ fprintf( out, "%s", (const char*)(it->c_str()) );
fprintf( out, PFSEOL );
}
}

View File

@ -1,6 +1,6 @@
Name: pfstools
Version: 1.8.5
Release: 13%{?dist}
Release: 14%{?dist}
Summary: Programs for handling high-dynamic range images
Group: Applications/Multimedia
@ -12,6 +12,7 @@ Patch2: pfstools-1.7.0-bf1.patch
Patch3: pfstools-1.7.0-gcc44.patch
Patch4: pfstools-1.7-strcmp.patch
Patch5: pfstools-1.7.0-debuginfo.patch
Patch6: pfstools-1.8.5-wformat.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: automake
@ -124,6 +125,7 @@ etc., for developing programs which can handle HDR graphics files.
%patch3 -p1 -b .gcc44
%patch4 -p1 -b .strcmp
%patch5 -p1 -b .debuginfo
%patch6 -p1 -b .wformat
# Remove the following once the patches for configure.ac and Makefile.am
# are not necessary anymore.
autoreconf -ifv
@ -281,6 +283,9 @@ rm -rf $RPM_BUILD_ROOT
%{_includedir}/pfs-1.2
%changelog
* Fri Dec 06 2013 Tomas Smetana <tsmetana@redhat.com> - 1.8.5-14
- Patch for the #1037243 (-Werror=format-security) non-bug
* Thu Nov 28 2013 Rex Dieter <rdieter@fedoraproject.org> 1.8.5-13
- rebuild (openexr)