Update to new upstream version, drop upstreamed patches
This commit is contained in:
parent
ae2bcadb9e
commit
0c3a7e16a8
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ pfstools-1.8.1.tar.gz
|
||||
/pfstools-1.8.3.tar.gz
|
||||
/pfstools-1.8.5.tar.gz
|
||||
/pfstools-2.0.4.tgz
|
||||
/pfstools-2.0.5.tgz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up pfstools-2.0.4/src/filter/pfspanoramic.cpp.gcc44 pfstools-2.0.4/src/filter/pfspanoramic.cpp
|
||||
--- pfstools-2.0.4/src/filter/pfspanoramic.cpp.gcc44 2015-07-20 13:59:35.621829179 +0200
|
||||
+++ pfstools-2.0.4/src/filter/pfspanoramic.cpp 2015-07-20 14:00:00.891732807 +0200
|
||||
@@ -198,7 +198,7 @@ class ProjectionFactory
|
||||
{
|
||||
char *opts;
|
||||
|
||||
- if( (opts = strchr(name, '/')) )
|
||||
+ if( (opts = strchr((char *)name, '/')) )
|
||||
{
|
||||
*opts++ = '\0';
|
||||
}
|
@ -1,104 +0,0 @@
|
||||
diff -up pfstools-2.0.4/src/octave/pfsput.cpp.maptype pfstools-2.0.4/src/octave/pfsput.cpp
|
||||
--- pfstools-2.0.4/src/octave/pfsput.cpp.maptype 2015-07-15 11:58:23.000000000 +0200
|
||||
+++ pfstools-2.0.4/src/octave/pfsput.cpp 2015-07-20 11:49:05.445680473 +0200
|
||||
@@ -52,9 +52,9 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
return retval;
|
||||
}
|
||||
|
||||
- octave_scalar_map pfsStream = args(0).map_value();
|
||||
+ octave_map pfsStream = args(0).map_value();
|
||||
|
||||
- octave_scalar_map::const_iterator itFH = pfsStream.seek( "FH" );
|
||||
+ octave_map::const_iterator itFH = pfsStream.seek( "FH" );
|
||||
if( itFH == pfsStream.end() ||
|
||||
!pfsStream.contents( itFH )(0).is_real_scalar() )
|
||||
{
|
||||
@@ -65,7 +65,7 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
|
||||
// Check mode
|
||||
{
|
||||
- octave_scalar_map::const_iterator itMode = pfsStream.seek( "MODE" );
|
||||
+ octave_map::const_iterator itMode = pfsStream.seek( "MODE" );
|
||||
if( itMode == pfsStream.end() || !pfsStream.contents( itMode )(0).is_string() )
|
||||
{
|
||||
error( SCRIPT_NAME ": MODE field missing in the structure or it has wrong type");
|
||||
@@ -80,8 +80,8 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
// Get width & height
|
||||
int width, height;
|
||||
{
|
||||
- octave_scalar_map::const_iterator itCols = pfsStream.seek( "columns" );
|
||||
- octave_scalar_map::const_iterator itRows = pfsStream.seek( "rows" );
|
||||
+ octave_map::const_iterator itCols = pfsStream.seek( "columns" );
|
||||
+ octave_map::const_iterator itRows = pfsStream.seek( "rows" );
|
||||
if( itCols == pfsStream.end() || itRows == pfsStream.end() ||
|
||||
!pfsStream.contents( itCols )(0).is_real_scalar() ||
|
||||
!pfsStream.contents( itRows )(0).is_real_scalar() )
|
||||
@@ -94,9 +94,9 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
}
|
||||
|
||||
// Get channels
|
||||
- octave_scalar_map channels;
|
||||
+ octave_map channels;
|
||||
{
|
||||
- octave_scalar_map::const_iterator itChannels = pfsStream.seek( "channels" );
|
||||
+ octave_map::const_iterator itChannels = pfsStream.seek( "channels" );
|
||||
if( itChannels == pfsStream.end() ||
|
||||
!pfsStream.contents( itChannels )(0).is_map() )
|
||||
{
|
||||
@@ -111,7 +111,7 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
pfs::Frame *frame = ctx.createFrame( width, height );
|
||||
|
||||
// For each channel in the 'channels' map
|
||||
- for( octave_scalar_map::iterator itCh = channels.begin(); itCh != channels.end(); itCh++ ) {
|
||||
+ for( octave_map::iterator itCh = channels.begin(); itCh != channels.end(); itCh++ ) {
|
||||
std::string channelName = channels.key(itCh);
|
||||
|
||||
if( !channels.contents( itCh )(0).is_real_matrix() ) {
|
||||
@@ -135,15 +135,15 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
|
||||
// Copy frame tags
|
||||
{
|
||||
- octave_scalar_map::const_iterator itTags = pfsStream.seek( "tags" );
|
||||
+ octave_map::const_iterator itTags = pfsStream.seek( "tags" );
|
||||
if( itTags != pfsStream.end() ) {
|
||||
if( !pfsStream.contents( itTags )(0).is_map() )
|
||||
{
|
||||
throw pfs::Exception( "'tags' field must be a structure" );
|
||||
}
|
||||
|
||||
- octave_scalar_map_map tags = pfsStream.contents( itTags )(0).map_value();
|
||||
- for( octave_scalar_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
|
||||
+ octave_map tags = pfsStream.contents( itTags )(0).map_value();
|
||||
+ for( octave_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
|
||||
std::string tagName = tags.key(itTag);
|
||||
|
||||
if( !tags.contents( itTag )(0).is_string() )
|
||||
@@ -156,14 +156,14 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
|
||||
// Copy channel tags
|
||||
{
|
||||
- octave_scalar_map::const_iterator itChTags = pfsStream.seek( "channelTags" );
|
||||
+ octave_map::const_iterator itChTags = pfsStream.seek( "channelTags" );
|
||||
if( itChTags != pfsStream.end() ) {
|
||||
if( !pfsStream.contents( itChTags )(0).is_map() )
|
||||
{
|
||||
throw pfs::Exception( "'channelTags' field must be a structure" );
|
||||
}
|
||||
- octave_scalar_map tagChannels = pfsStream.contents( itChTags )(0).map_value();
|
||||
- for( octave_scalar_map::iterator itCh = tagChannels.begin(); itCh != tagChannels.end(); itCh++ ) {
|
||||
+ octave_map tagChannels = pfsStream.contents( itChTags )(0).map_value();
|
||||
+ for( octave_map::iterator itCh = tagChannels.begin(); itCh != tagChannels.end(); itCh++ ) {
|
||||
std::string channelName = tagChannels.key(itCh);
|
||||
if( !tagChannels.contents( itCh )(0).is_map() ) {
|
||||
throw pfs::Exception( "each channelTags file must be a structure" );
|
||||
@@ -173,8 +173,8 @@ DEFUN_DLD( pfsput, args, , helpString)
|
||||
throw pfs::Exception( "can not set channel tag if channel is missing" );
|
||||
}
|
||||
|
||||
- octave_scalar_map tags = tagChannels.contents( itCh )(0).map_value();
|
||||
- for( octave_scalar_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
|
||||
+ octave_map tags = tagChannels.contents( itCh )(0).map_value();
|
||||
+ for( octave_map::iterator itTag = tags.begin(); itTag != tags.end(); itTag++ ) {
|
||||
std::string tagName = tags.key(itTag);
|
||||
if( !tags.contents( itTag )(0).is_string() )
|
||||
throw pfs::Exception( "all channel tags must be given as strings" );
|
@ -1,39 +0,0 @@
|
||||
diff -up pfstools-2.0.4/CMakeLists.txt.octinstall pfstools-2.0.4/CMakeLists.txt
|
||||
--- pfstools-2.0.4/CMakeLists.txt.octinstall 2015-07-20 13:06:32.533996797 +0200
|
||||
+++ pfstools-2.0.4/CMakeLists.txt 2015-07-20 13:11:35.728808062 +0200
|
||||
@@ -277,8 +277,6 @@ OPTION(WITH_HDRVC "Compile HDRVC (intern
|
||||
# ======== MKOCTFILE/OCTAVE ===========
|
||||
|
||||
OPTION(WITH_Octave "Compile Octave files" ON)
|
||||
-SET (OCTAVE_DEST_DIR "${CMAKE_INSTALL_PREFIX}/share/pfstools/octave"
|
||||
-CACHE PATH "Copy octave functions to this directory")
|
||||
|
||||
if( WITH_Octave )
|
||||
|
||||
@@ -289,7 +287,8 @@ if( WITH_Octave )
|
||||
if(MKOCTFILE)
|
||||
message(STATUS "mkoctfile found.")
|
||||
endif()
|
||||
-
|
||||
+ execute_process(COMMAND octave-config --oct-site-dir OUTPUT_VARIABLE OCTAVE_OCT_DIR OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
+ execute_process(COMMAND octave-config --m-site-dir OUTPUT_VARIABLE OCTAVE_M_DIR OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
endif( WITH_Octave )
|
||||
|
||||
# ======== OpenCV ===========
|
||||
diff -up pfstools-2.0.4/src/octave/CMakeLists.txt.octinstall pfstools-2.0.4/src/octave/CMakeLists.txt
|
||||
--- pfstools-2.0.4/src/octave/CMakeLists.txt.octinstall 2015-07-20 13:03:30.448679088 +0200
|
||||
+++ pfstools-2.0.4/src/octave/CMakeLists.txt 2015-07-20 13:12:42.873544809 +0200
|
||||
@@ -40,11 +40,11 @@ endforeach(SRC)
|
||||
foreach(SRC ${SRC_OCT})
|
||||
install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${SRC}.oct
|
||||
PERMISSIONS OWNER_EXECUTE GROUP_EXECUTE WORLD_EXECUTE OWNER_WRITE WORLD_READ GROUP_READ OWNER_READ
|
||||
- DESTINATION ${OCTAVE_DEST_DIR})
|
||||
+ DESTINATION "${OCTAVE_OCT_DIR}/pfstools")
|
||||
endforeach(SRC)
|
||||
|
||||
foreach(SRC ${SRC_M})
|
||||
- install (FILES ${SRC} DESTINATION ${OCTAVE_DEST_DIR})
|
||||
+ install (FILES ${SRC} DESTINATION "${OCTAVE_M_DIR}/pfstools")
|
||||
endforeach(SRC)
|
||||
|
||||
install (FILES ${OCT_SCRIPTS}
|
@ -1,15 +1,12 @@
|
||||
Name: pfstools
|
||||
Version: 2.0.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2.0.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Programs for handling high-dynamic range images
|
||||
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
URL: http://pfstools.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tgz
|
||||
Patch1: pfstools-2.0.4-maptype.patch
|
||||
Patch2: pfstools-2.0.4-octinstall.patch
|
||||
Patch3: pfstools-2.0.4-gcc44.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: cmake
|
||||
@ -135,9 +132,6 @@ etc., for developing programs which can handle HDR graphics files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .maptype
|
||||
%patch2 -p1 -b .octinstall
|
||||
%patch3 -p1 -b .gcc44
|
||||
|
||||
%build
|
||||
%{cmake} -DBUILD_SHARED_LIBS=ON -DLIB_DIR=%{_lib} -DWITH_OpenCV=OFF
|
||||
@ -165,7 +159,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%doc README TODO doc/faq.txt
|
||||
%doc README
|
||||
%{_bindir}/pfsabsolute
|
||||
%{_bindir}/pfscat
|
||||
%{_bindir}/pfsclamp
|
||||
@ -310,6 +304,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/pfs
|
||||
|
||||
%changelog
|
||||
* Wed Jun 08 2016 Tomas Smetana <tsmetana@redhat.com> - 2.0.5-1
|
||||
- Update to new upstream version, drop upstreamed patches
|
||||
|
||||
* Mon Feb 22 2016 Orion Poplawski <orion@cora.nwra.com> - 2.0.4-3
|
||||
- Rebuild for gsl 2.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user