Release 3.18.5
This commit is contained in:
parent
91e55b95c4
commit
df7dae1230
2
.gitignore
vendored
2
.gitignore
vendored
@ -58,3 +58,5 @@
|
|||||||
/petsc4py-3.17.3.tar.gz
|
/petsc4py-3.17.3.tar.gz
|
||||||
/petsc-with-docs-3.17.4.tar.gz
|
/petsc-with-docs-3.17.4.tar.gz
|
||||||
/petsc4py-3.17.4.tar.gz
|
/petsc4py-3.17.4.tar.gz
|
||||||
|
/petsc-with-docs-3.18.5.tar.gz
|
||||||
|
/petsc4py-3.18.5.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- a/config/BuildSystem/config/packages/MUMPS.orig.py 2020-03-30 05:33:12.000000000 +0200
|
|
||||||
+++ b/config/BuildSystem/config/packages/MUMPS.py 2020-04-03 17:01:49.237255499 +0200
|
|
||||||
@@ -16,7 +16,7 @@
|
|
||||||
['libcmumps.a','libdmumps.a','libsmumps.a','libzmumps.a','libmumps_common.a','libpord.a','libmpiseq.a'],
|
|
||||||
['libcmumps.a','libdmumps.a','libsmumps.a','libzmumps.a','libmumps_common.a','libpord.a','libpthread.a','libmpiseq.a']]
|
|
||||||
self.functions = ['dmumps_c']
|
|
||||||
- self.includes = ['dmumps_c.h']
|
|
||||||
+ self.includes = ['MUMPS/dmumps_c.h']
|
|
||||||
#
|
|
||||||
self.buildLanguages = ['C','FC']
|
|
||||||
self.precisions = ['single','double']
|
|
@ -11,23 +11,12 @@
|
|||||||
self.hastests = 1
|
self.hastests = 1
|
||||||
self.useddirectly = 0
|
self.useddirectly = 0
|
||||||
return
|
return
|
||||||
@@ -50,7 +50,7 @@
|
@@ -47,7 +47,7 @@
|
||||||
config.package.Package.configureLibrary(self)
|
config.package.Package.configureLibrary(self)
|
||||||
oldFlags = self.compilers.CPPFLAGS
|
oldFlags = self.compilers.CPPFLAGS
|
||||||
self.compilers.CPPFLAGS += ' '+self.headers.toString(self.include)
|
self.compilers.CPPFLAGS += ' '+self.headers.toString(self.include)
|
||||||
- if not self.checkCompile('#include "metis.h"', '#if (IDXTYPEWIDTH != '+ str(self.getDefaultIndexSize())+')\n#error incompatible IDXTYPEWIDTH\n#endif'):
|
- if not self.checkCompile('#include "metis.h"', '#if (IDXTYPEWIDTH != '+ str(self.getDefaultIndexSize())+')\n#error incompatible IDXTYPEWIDTH\n#endif\n'):
|
||||||
+ if not self.checkCompile('#include "metis64.h"', '#if (IDXTYPEWIDTH != '+ str(self.getDefaultIndexSize())+')\n#error incompatible IDXTYPEWIDTH\n#endif'):
|
+ if not self.checkCompile('#include "metis64.h"', '#if (IDXTYPEWIDTH != '+ str(self.getDefaultIndexSize())+')\n#error incompatible IDXTYPEWIDTH\n#endif\n'):
|
||||||
if self.defaultIndexSize == 64:
|
if self.defaultIndexSize == 64:
|
||||||
msg= '--with-64-bit-indices option requires a metis build with IDXTYPEWIDTH=64.\n'
|
msg= '--with-64-bit-indices option requires a metis build with IDXTYPEWIDTH=64.\n'
|
||||||
else:
|
else:
|
||||||
--- a/src/mat/order/metisnd/metisnd.orig.c 2022-06-29 08:00:07.000000000 +0200
|
|
||||||
+++ b/src/mat/order/metisnd/metisnd.c 2023-02-23 22:35:55.373271745 +0100
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
|
|
||||||
#include <petscmat.h>
|
|
||||||
#include <petsc/private/matorderimpl.h>
|
|
||||||
-#include <metis.h>
|
|
||||||
+#include <metis64.h>
|
|
||||||
|
|
||||||
/*
|
|
||||||
MatGetOrdering_METISND - Find the nested dissection ordering of a given matrix.
|
|
11
petsc-3.18.0-fix_mumps_includes.patch
Normal file
11
petsc-3.18.0-fix_mumps_includes.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/config/BuildSystem/config/packages/MUMPS.orig.py 2020-03-30 05:33:12.000000000 +0200
|
||||||
|
+++ b/config/BuildSystem/config/packages/MUMPS.py 2020-04-03 17:01:49.237255499 +0200
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
if self.scalartypes.scalartype == 'real': l = 'd'
|
||||||
|
else: l = 'z'
|
||||||
|
self.functions = [l+'mumps_c']
|
||||||
|
- self.includes = [l+'mumps_c.h']
|
||||||
|
+ self.includes = ['MUMPS/dmumps_c.h']
|
||||||
|
liblist_common = [['libmumps_common.a','libpord.a','libpthread.a'],
|
||||||
|
['libmumps_common.a','libpord.a','libmpiseq.a'],
|
||||||
|
['libmumps_common.a','libpord.a','libpthread.a','libmpiseq.a']]
|
41
petsc.spec
41
petsc.spec
@ -8,7 +8,7 @@
|
|||||||
%global _lto_cflags %{nil}
|
%global _lto_cflags %{nil}
|
||||||
|
|
||||||
# Testing libpetsc ?
|
# Testing libpetsc ?
|
||||||
%bcond_without check
|
%bcond_with check
|
||||||
#
|
#
|
||||||
|
|
||||||
# Python binding and its testing
|
# Python binding and its testing
|
||||||
@ -72,7 +72,7 @@
|
|||||||
## SuperLUDIST needs parmetis
|
## SuperLUDIST needs parmetis
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
%bcond_without superludist >= 6.3.0
|
%bcond_without superludist >= 6.3.0
|
||||||
%bcond_without cgns
|
%bcond_with cgns
|
||||||
%bcond_without hdf5
|
%bcond_without hdf5
|
||||||
%else
|
%else
|
||||||
# Needed superludist >= 6.3.0
|
# Needed superludist >= 6.3.0
|
||||||
@ -167,9 +167,7 @@
|
|||||||
--with-hdf5-lib="-lhdf5 -lhdf5_hl" \\\
|
--with-hdf5-lib="-lhdf5 -lhdf5_hl" \\\
|
||||||
%endif \
|
%endif \
|
||||||
%if %{with cgns} \
|
%if %{with cgns} \
|
||||||
--with-cgns=1 \\\
|
--with-cgns=0 \\\
|
||||||
--with-cgns-include= \\\
|
|
||||||
--with-cgns-lib=-lcgns \\\
|
|
||||||
%endif \
|
%endif \
|
||||||
--with-x=1 \\\
|
--with-x=1 \\\
|
||||||
--with-openmp=0 \\\
|
--with-openmp=0 \\\
|
||||||
@ -239,7 +237,7 @@
|
|||||||
%endif \
|
%endif \
|
||||||
%if %{with cgns} \
|
%if %{with cgns} \
|
||||||
--with-cgns=1 \\\
|
--with-cgns=1 \\\
|
||||||
--with-cgns-include= \\\
|
--with-cgns-include=%{_includedir} \\\
|
||||||
--with-cgns-lib=-lcgns \\\
|
--with-cgns-lib=-lcgns \\\
|
||||||
%endif \
|
%endif \
|
||||||
%if %{with hdf5} \
|
%if %{with hdf5} \
|
||||||
@ -249,7 +247,7 @@
|
|||||||
%endif \
|
%endif \
|
||||||
%if %{with ptscotch} \
|
%if %{with ptscotch} \
|
||||||
--with-ptscotch=1 \\\
|
--with-ptscotch=1 \\\
|
||||||
--with-ptscotch-include= \\\
|
--with-ptscotch-include=$MPI_INCLUDE/scotch \\\
|
||||||
--with-ptscotch-lib="-L$MPI_LIB -lptscotch -lscotch -lptscotcherr -lscotcherr" \\\
|
--with-ptscotch-lib="-L$MPI_LIB -lptscotch -lscotch -lptscotcherr -lscotcherr" \\\
|
||||||
%endif \
|
%endif \
|
||||||
%if %{with mumps} \
|
%if %{with mumps} \
|
||||||
@ -285,12 +283,12 @@
|
|||||||
%global mpichversion %(rpm -qi mpich | awk -F': ' '/Version/ {print $2}')
|
%global mpichversion %(rpm -qi mpich | awk -F': ' '/Version/ {print $2}')
|
||||||
%global openmpiversion %(rpm -qi openmpi | awk -F': ' '/Version/ {print $2}')
|
%global openmpiversion %(rpm -qi openmpi | awk -F': ' '/Version/ {print $2}')
|
||||||
%global majorver 3
|
%global majorver 3
|
||||||
%global releasever 3.17
|
%global releasever 3.18
|
||||||
|
|
||||||
Name: petsc
|
Name: petsc
|
||||||
Summary: Portable Extensible Toolkit for Scientific Computation
|
Summary: Portable Extensible Toolkit for Scientific Computation
|
||||||
Version: %{releasever}.4
|
Version: %{releasever}.5
|
||||||
Release: 15%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://petsc.org/
|
URL: https://petsc.org/
|
||||||
Source0: https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-%{version}.tar.gz
|
Source0: https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-%{version}.tar.gz
|
||||||
@ -305,8 +303,8 @@ Patch1: %{name}-lib64.patch
|
|||||||
# Reverting patch for Hypre-2.11.2
|
# Reverting patch for Hypre-2.11.2
|
||||||
Patch2: %{name}-3.14-hypre_2.11.2_reverting.patch
|
Patch2: %{name}-3.14-hypre_2.11.2_reverting.patch
|
||||||
|
|
||||||
Patch3: %{name}-3.17.0-fix_mumps_includes.patch
|
Patch3: %{name}-3.18.0-fix_mumps_includes.patch
|
||||||
Patch4: %{name}-3.13.0-fix_metis64.patch
|
Patch4: %{name}-3.18.0-fix_metis64.patch
|
||||||
Patch5: %{name}-3.15.0-fix_sundials_version.patch
|
Patch5: %{name}-3.15.0-fix_sundials_version.patch
|
||||||
Patch6: %{name}-3.14.1-fix_pkgconfig_file.patch
|
Patch6: %{name}-3.14.1-fix_pkgconfig_file.patch
|
||||||
Patch7: %{name}-3.17.0-avoid_fake_MKL_detection.patch
|
Patch7: %{name}-3.17.0-avoid_fake_MKL_detection.patch
|
||||||
@ -571,7 +569,7 @@ rm -rf petsc4py-%{version}
|
|||||||
|
|
||||||
pushd %{name}-%{version}
|
pushd %{name}-%{version}
|
||||||
|
|
||||||
%patch7 -p1 -b .backup
|
%patch 7 -p1 -b .backup
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
find . -name 'setup.py' | xargs %{__python3} %{_rpmconfigdir}/redhat/pathfix.py -pn -i "%{__python3}"
|
find . -name 'setup.py' | xargs %{__python3} %{_rpmconfigdir}/redhat/pathfix.py -pn -i "%{__python3}"
|
||||||
@ -589,19 +587,19 @@ popd
|
|||||||
%if %{with arch64}
|
%if %{with arch64}
|
||||||
cp -a %{name}-%{version} build64
|
cp -a %{name}-%{version} build64
|
||||||
pushd build64
|
pushd build64
|
||||||
%patch1 -p0
|
%patch 1 -p0
|
||||||
%if %{with metis64}
|
%if %{with metis64}
|
||||||
%patch4 -p1 -b .metis64
|
%patch 4 -p1 -b .metis64
|
||||||
%endif
|
%endif
|
||||||
popd
|
popd
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
pushd %{name}-%{version}
|
pushd %{name}-%{version}
|
||||||
%patch0 -p0 -b .backup
|
%patch 0 -p0 -b .backup
|
||||||
%patch5 -p1 -b .backup
|
%patch 5 -p1 -b .backup
|
||||||
%patch6 -p1 -b .backup
|
%patch 6 -p1 -b .backup
|
||||||
%if 0%{?python3_version_nodots} >= 311
|
%if 0%{?python3_version_nodots} >= 311
|
||||||
#%%patch8 -p1 -b .backup
|
#%%patch 8 -p1 -b .backup
|
||||||
%endif
|
%endif
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -614,7 +612,7 @@ cp -a %{name}-%{version} buildmpich_dir
|
|||||||
|
|
||||||
# Do NOT move up this patch
|
# Do NOT move up this patch
|
||||||
pushd %{name}-%{version}
|
pushd %{name}-%{version}
|
||||||
%patch3 -p1
|
%patch 3 -p1 -b .backup
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -1168,6 +1166,9 @@ xvfb-run -a make MAKE_NP=$RPM_BUILD_NCPUS all test -C build64 V=1 MPIEXEC='%{_bu
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 13 2023 Antonio Trande <sagitter@fedoraproject.org> - 3.18.5-1
|
||||||
|
- Release 3.18.5
|
||||||
|
|
||||||
* Fri Mar 03 2023 Orion Poplawski <orion@nwra.com> - 3.17.4-15
|
* Fri Mar 03 2023 Orion Poplawski <orion@nwra.com> - 3.17.4-15
|
||||||
- Rebuild for mpich 4.0.3
|
- Rebuild for mpich 4.0.3
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (petsc-with-docs-3.17.4.tar.gz) = 23773368dd0ffb77d12de1609f79c53e9a1e35d89f2696a3b2fdf02bf96adfde16e27feb1977159188f765a7697eb1f1a7947104aacf6c94471b5a23e1ff2936
|
SHA512 (petsc-with-docs-3.18.5.tar.gz) = bc201ada4f90ab9ddbcd52c7c16892bc1f5d75396904da4810fcf41cc65b98906c4e0252e39c3c6c17381daf967e7475d5d4a79ef48ffdee0f9d8c9ee00bbe52
|
||||||
SHA512 (petsc4py-3.17.4.tar.gz) = ba80e2ef5fe489fc107f96b3e24272aaabc371468e0099bd732579175f75554139df2f7470d4064209f3ef793af95aa2a6f073b5c44cf43af32f362862be9f09
|
SHA512 (petsc4py-3.18.5.tar.gz) = 1043f6d3de5fc023c83ab5cc0d8bb877f612afb27cd11759d95af58f98dd8a4f4ab75ce454f69447d75cf4c7071e1fa7626b3995e3c00c15d5baa794ffc2edbf
|
||||||
|
Loading…
Reference in New Issue
Block a user