Release 3.16.3| Fix rhbz#2039365
This commit is contained in:
parent
e253d58202
commit
c3687f5e2c
2
.gitignore
vendored
2
.gitignore
vendored
@ -42,3 +42,5 @@
|
||||
/petsc4py-3.15.4.tar.gz
|
||||
/petsc-with-docs-3.16.0.tar.gz
|
||||
/petsc4py-3.16.0.tar.gz
|
||||
/petsc-with-docs-3.16.3.tar.gz
|
||||
/petsc4py-3.16.3.tar.gz
|
||||
|
11
petsc-porting_to_python311.patch
Normal file
11
petsc-porting_to_python311.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/petsc4py.PETSc.origin.c 2022-01-06 03:57:32.000000000 +0100
|
||||
+++ b/src/petsc4py.PETSc.c 2022-01-12 20:44:44.434469854 +0100
|
||||
@@ -193,7 +193,7 @@
|
||||
#define CYTHON_FAST_PYCCALL (CYTHON_FAST_PYCALL && PY_VERSION_HEX >= 0x030600B1)
|
||||
#endif
|
||||
#if CYTHON_USE_PYLONG_INTERNALS
|
||||
- #include "longintrepr.h"
|
||||
+ #include "cpython/longintrepr.h"
|
||||
#undef SHIFT
|
||||
#undef BASE
|
||||
#undef MASK
|
22
petsc.spec
22
petsc.spec
@ -33,7 +33,7 @@
|
||||
%bcond_without blas64
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
%global blaslib flexiblas
|
||||
%global blasvar %{nil}
|
||||
%else
|
||||
@ -278,8 +278,8 @@
|
||||
|
||||
Name: petsc
|
||||
Summary: Portable Extensible Toolkit for Scientific Computation
|
||||
Version: %{releasever}.0
|
||||
Release: 5%{?dist}
|
||||
Version: %{releasever}.3
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: https://petsc.org/
|
||||
Source0: https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-with-docs-%{version}.tar.gz
|
||||
@ -299,6 +299,7 @@ Patch4: %{name}-3.13.0-fix_metis64.patch
|
||||
Patch5: %{name}-3.15.0-fix_sundials_version.patch
|
||||
Patch6: %{name}-3.14.1-fix_pkgconfig_file.patch
|
||||
Patch7: %{name}-3.4.1-avoid_fake_MKL_detection.patch
|
||||
Patch8: %{name}-porting_to_python311.patch
|
||||
|
||||
%if %{with superlu}
|
||||
BuildRequires: SuperLU-devel >= 5.2.0
|
||||
@ -602,6 +603,9 @@ pushd %{name}-%{version}
|
||||
%patch0 -p0 -b .backup
|
||||
%patch5 -p1 -b .backup
|
||||
%patch6 -p1 -b .backup
|
||||
%if 0%{?python3_version_nodots} >= 311
|
||||
%patch8 -p1 -b .backup
|
||||
%endif
|
||||
popd
|
||||
|
||||
%if %{with openmpi}
|
||||
@ -626,7 +630,7 @@ pushd %{name}-%{version}
|
||||
%{petsc_build_options} \
|
||||
--with-64-bit-indices=0 \
|
||||
%if %{with blas}
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
--with-blaslapack=1 --with-blaslapack-lib=-l%{blaslib}%{blasvar} --with-blaslapack-include=%{_includedir}/%{blaslib} \
|
||||
%else
|
||||
--with-openblas=1 --with-openblas-lib=-l%{blaslib}%{blasvar} --with-openblas-include=%{_includedir}/%{blaslib} \
|
||||
@ -666,7 +670,7 @@ pushd build64
|
||||
--with-metis=1 \
|
||||
%endif
|
||||
%if %{with blas64}
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
--with-blaslapack=1 --with-blaslapack-lib=-l%{blaslib}%{blasvar}64 --with-blaslapack-include=%{_includedir}/%{blaslib} \
|
||||
%else
|
||||
--with-openblas=1 --with-openblas-lib=-l%{blaslib}%{blasvar}64 --with-openblas-include=%{_includedir}/%{blaslib} \
|
||||
@ -698,7 +702,7 @@ pushd buildopenmpi_dir
|
||||
%endif
|
||||
--with-64-bit-indices=0 \
|
||||
%if %{with blas}
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
--with-blaslapack=1 --with-blaslapack-lib=-l%{blaslib}%{blasvar} --with-blaslapack-include=%{_includedir}/%{blaslib} \
|
||||
%else
|
||||
--with-openblas=1 --with-openblas-lib=-l%{blaslib}%{blasvar} --with-openblas-include=%{_includedir}/%{blaslib} \
|
||||
@ -736,7 +740,7 @@ pushd buildmpich_dir
|
||||
%endif
|
||||
--with-64-bit-indices=0 \
|
||||
%if %{with blas}
|
||||
%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
--with-blaslapack=1 --with-blaslapack-lib=-l%{blaslib}%{blasvar} --with-blaslapack-include=%{_includedir}/%{blaslib} \
|
||||
%else
|
||||
--with-openblas=1 --with-openblas-lib=-l%{blaslib}%{blasvar} --with-openblas-include=%{_includedir}/%{blaslib} \
|
||||
@ -1160,6 +1164,10 @@ xvfb-run -a make MAKE_NP=$RPM_BUILD_NCPUS all test -C build64 V=1 MPIEXEC='%{_bu
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 12 2022 Antonio Trande <sagitter@fedoraproject.org> - 3.16.3-1
|
||||
- Release 3.16.3
|
||||
- Fix rhbz#2039365
|
||||
|
||||
* Sun Nov 21 2021 Orion Poplawski <orion@nwra.com> - 3.16.0-5
|
||||
- Rebuild for hdf5 1.12.1
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (petsc-with-docs-3.16.0.tar.gz) = ed58dd2f479b4177176f12aea55c8fd48a39e1f5105194896509d5e469095eb04c48405d4c062cc500b19e0b140a6984b482aa2a211b5fefc5be18d7071ec45a
|
||||
SHA512 (petsc4py-3.16.0.tar.gz) = e20bcb297bce84eb02b5f24fbd914e916e49c64e1588266f832f2b3bbda2b0fb848f00f000f02e11d127cf3ea220a1d13e86d4f06eb7818c00f526663b1db695
|
||||
SHA512 (petsc-with-docs-3.16.3.tar.gz) = 13afe0b5b72d63b564cfd30072bad22a066555d47374a25a3da19f4729a0e29d352316e7fc8e937f5cf10ef367a9dbee99964905a167a96577f24e01037f2b19
|
||||
SHA512 (petsc4py-3.16.3.tar.gz) = d996347ba1a9bf397267d40d54c377d2c59a4d4337d0ad58ceb740a7f0e81ac1972454055401a651172e575d83045a90cb241adaaf9b3ea5b5d1a28bff3c2b6c
|
||||
|
Loading…
Reference in New Issue
Block a user