Update to 3.9.0
This commit is contained in:
parent
b4a5b382ef
commit
55bd336aca
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/petsc-3.8.1.tar.gz
|
||||
/petsc-3.8.3.tar.gz
|
||||
/petsc-3.8.4.tar.gz
|
||||
/petsc-3.9.0.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
diff --git a/config/BuildSystem/config/packages/hypre.py b/config/BuildSystem/config/packages/hypre.py
|
||||
index 1249b39374..620e51602a 100644
|
||||
--- a/config/BuildSystem/config/packages/hypre.py
|
||||
+++ b/config/BuildSystem/config/packages/hypre.py
|
||||
@@ -4,7 +4,7 @@ import os
|
||||
class Configure(config.package.GNUPackage):
|
||||
def __init__(self, framework):
|
||||
config.package.GNUPackage.__init__(self, framework)
|
||||
- self.gitcommit = 'v2.12.0'
|
||||
+ self.gitcommit = 'v2.14.0'
|
||||
self.download = ['git://https://github.com/LLNL/hypre','https://github.com/LLNL/hypre/archive/'+self.gitcommit+'.tar.gz']
|
||||
self.functions = ['HYPRE_IJMatrixCreate']
|
||||
self.includes = ['HYPRE.h']
|
||||
diff --git a/src/mat/impls/hypre/mhypre.c b/src/mat/impls/hypre/mhypre.c
|
||||
index 8a51581a09..65595f2af4 100644
|
||||
--- a/src/mat/impls/hypre/mhypre.c
|
||||
+++ b/src/mat/impls/hypre/mhypre.c
|
||||
@@ -1450,6 +1450,6 @@ PETSC_EXTERN PetscErrorCode MatCreate_HYPRE(Mat B)
|
||||
static PetscErrorCode hypre_array_destroy(void *ptr)
|
||||
{
|
||||
PetscFunctionBegin;
|
||||
- hypre_TFree(ptr);
|
||||
+ hypre_TFree(ptr,HYPRE_MEMORY_HOST);
|
||||
PetscFunctionReturn(0);
|
||||
}
|
@ -4,7 +4,7 @@
|
||||
|
||||
--- config/BuildSystem/config/setCompilers.py
|
||||
+++ config/BuildSystem/config/setCompilers.py
|
||||
@@ -1387,7 +1387,7 @@
|
||||
@@ -1411,7 +1411,7 @@
|
||||
self.pushLanguage(language)
|
||||
# test '-R' before '-rpath' as sun compilers [c,fortran] don't give proper errors with wrong options.
|
||||
if not Configure.isDarwin(self.log):
|
@ -2,7 +2,7 @@ diff --git a/lib/petsc/conf/rules b/lib/petsc/conf/rules
|
||||
index c6cfba4..7491faf 100644
|
||||
--- lib/petsc/conf/rules
|
||||
+++ lib/petsc/conf/rules
|
||||
@@ -60,9 +60,10 @@ chklib_dir: chk_makej
|
||||
@@ -37,9 +37,10 @@ chklib_dir: chk_makej
|
||||
@if [ ! -d "${INSTALL_LIB_DIR}" ]; then \
|
||||
echo Making directory ${INSTALL_LIB_DIR} for library; ${MKDIR} ${INSTALL_LIB_DIR} ; fi
|
||||
|
||||
|
@ -4,7 +4,7 @@
|
||||
|
||||
--- config/BuildSystem/config/setCompilers.py
|
||||
+++ config/BuildSystem/config/setCompilers.py
|
||||
@@ -1387,7 +1387,7 @@
|
||||
@@ -1411,7 +1411,7 @@
|
||||
self.pushLanguage(language)
|
||||
# test '-R' before '-rpath' as sun compilers [c,fortran] don't give proper errors with wrong options.
|
||||
if not Configure.isDarwin(self.log):
|
||||
@ -15,9 +15,9 @@
|
||||
# test '-R' before '-Wl,-rpath' for SUN compilers [as cc on linux accepts -Wl,-rpath, but f90 & CC do not.
|
||||
--- gmakefile.orig 2016-05-16 04:57:35.000000000 +0200
|
||||
+++ gmakefile 2016-06-22 13:59:47.905111833 +0200
|
||||
@@ -29,10 +30,10 @@
|
||||
basename_all = $(basename $(basename $(basename $(basename $(1)))))
|
||||
sl_linker_args = $(call SL_LINKER_FUNCTION,$(call basename_all,$@),$(libpetsc_abi_version),$(libpetsc_lib_version))
|
||||
@@ -26,10 +26,10 @@
|
||||
absbasename_all = $(basename $(basename $(basename $(basename $(abspath $(1))))))# arch/lib/libpetsc.so.3.8.0 -> /path/to/arch/lib/libpetsc
|
||||
sl_linker_args = $(call SL_LINKER_FUNCTION,$(call absbasename_all,$@),$(libpetsc_abi_version),$(libpetsc_lib_version))
|
||||
|
||||
-libpetsc_shared := $(LIBDIR)/libpetsc.$(SL_LINKER_SUFFIX)
|
||||
-libpetsc_soname := $(call soname_function,$(LIBDIR)/libpetsc)
|
||||
|
21
petsc.spec
21
petsc.spec
@ -40,6 +40,11 @@
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%bcond_without mpich
|
||||
%bcond_without openmpi
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} >= 7
|
||||
%bcond_without mpich
|
||||
%bcond_without openmpi
|
||||
@ -125,11 +130,11 @@
|
||||
%bcond_without blas64
|
||||
%endif
|
||||
|
||||
%global releasever 3.8
|
||||
%global releasever 3.9
|
||||
|
||||
Name: petsc
|
||||
Summary: Portable Extensible Toolkit for Scientific Computation
|
||||
Version: %{releasever}.4
|
||||
Version: %{releasever}.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: https://www.mcs.anl.gov/petsc
|
||||
@ -144,9 +149,6 @@ Patch1: %{name}-lib64.patch
|
||||
# Disable checkopts and petscnagupgrade.py
|
||||
Patch3: %{name}-disable_petscnagupgrade.patch
|
||||
|
||||
# Patch for using Hypre-2.14.0
|
||||
Patch4: %{name}-%{version}_hypre_2.14.0.patch
|
||||
|
||||
%if %{with superlu}
|
||||
BuildRequires: SuperLU-devel >= 5.2.0
|
||||
%endif
|
||||
@ -170,7 +172,7 @@ BuildRequires: blas-devel
|
||||
BuildRequires: lapack-devel
|
||||
%endif
|
||||
%endif
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc, gcc-c++
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: python2-devel
|
||||
@ -369,10 +371,6 @@ Portable Extensible Toolkit for Scientific Computation (developer files).
|
||||
|
||||
pushd %{name}-%{version}
|
||||
%patch3 -p0
|
||||
|
||||
%if 0%{?fedora} > 28
|
||||
%patch4 -p1
|
||||
%endif
|
||||
popd
|
||||
|
||||
%if %{with arch64}
|
||||
@ -1072,6 +1070,9 @@ make -C buildmpich_dir test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Apr 11 2018 Antonio Trande <sagitter@fedoraproject.org> - 3.9.0-1
|
||||
- Update to 3.9.0
|
||||
|
||||
* Fri Mar 30 2018 Antonio Trande <sagitter@fedoraproject.org> - 3.8.4-1
|
||||
- Update to 3.8.4
|
||||
- Exclude MPI builds on s390 archirectures if fedora < 28 only
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (petsc-3.8.4.tar.gz) = c186e143619c12d2175d01046c26221c462091706af0b68515ba1d2c93f97738ec375df7aa0551c5a14c240e80ca744f9d796778f4937a8c8021d64abe1f3b2c
|
||||
SHA512 (petsc-3.9.0.tar.gz) = 3bb85282b86d3fc3117a8b6641ebce0957a925b0207b8ab190e1cee9b195487e866f73aa88fa7fcb51deb9656d7722166a104f60cf65cdc62a9e92b44be18940
|
||||
|
Loading…
Reference in New Issue
Block a user