Update to 3.8.0
This commit is contained in:
parent
ec327e9163
commit
34b30a0773
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/petsc-3.7.5.tar.gz
|
||||
/petsc-3.7.6.tar.gz
|
||||
/petsc-3.7.7.tar.gz
|
||||
/petsc-3.8.0.tar.gz
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- src/dm/impls/plex/plexcgns.c~ 2015-06-09 22:24:49.000000000 +0100
|
||||
+++ src/dm/impls/plex/plexcgns.c 2015-07-04 23:16:15.861601437 +0100
|
||||
@@ -1,6 +1,7 @@
|
||||
#define PETSCDM_DLL
|
||||
#include <petsc/private/dmpleximpl.h> /*I "petscdmplex.h" I*/
|
||||
|
||||
+#undef I
|
||||
#if defined(PETSC_HAVE_CGNS)
|
||||
#include <cgnslib.h>
|
||||
#include <cgns_io.h>
|
23
petsc.spec
23
petsc.spec
@ -109,8 +109,8 @@
|
||||
|
||||
Name: petsc
|
||||
Summary: Portable Extensible Toolkit for Scientific Computation
|
||||
Version: 3.7.7
|
||||
Release: 5%{?dist}
|
||||
Version: 3.8.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: https://www.mcs.anl.gov/petsc
|
||||
Source0: http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-%{version}.tar.gz
|
||||
@ -121,9 +121,6 @@ Patch0: %{name}-3.7-no-rpath.patch
|
||||
## Rename library name for 64-bit integer package
|
||||
Patch1: %{name}-lib64.patch
|
||||
|
||||
# Avoid a clash with complex.h
|
||||
Patch2: %{name}-avoid_clash_with_complex.h.patch
|
||||
|
||||
# Diable checkopts and petscnagupgrade.py
|
||||
Patch3: %{name}-disable_petscnagupgrade.patch
|
||||
|
||||
@ -352,9 +349,6 @@ popd
|
||||
cp -a %{name}-%{version} build64
|
||||
pushd build64
|
||||
%patch1 -p0
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||
%patch2 -p0
|
||||
%endif
|
||||
popd
|
||||
%endif
|
||||
|
||||
@ -364,10 +358,6 @@ find . -name 'configure' | xargs sed -i '1s|^#!/usr/bin/env python|#!%{__python2
|
||||
find config -name '*.py' | xargs sed -i '1s|^#!/usr/bin/env python|#!%{__python2}|'
|
||||
find src/benchmarks/streams -name '*.py' | xargs sed -i '1s|^#!/usr/bin/env python|#!%{__python2}|'
|
||||
%patch0 -p0
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||
%patch2 -p0
|
||||
%endif
|
||||
popd
|
||||
|
||||
%if %{with openmpi}
|
||||
@ -427,7 +417,6 @@ CFLAGS="$CFLAGS -O3 -Wl,-z,now" CXXFLAGS="$CXXFLAGS -O3" FFLAGS="$FFLAGS -O3 -Wl
|
||||
--with-superlu-include=%{_includedir}/SuperLU \
|
||||
--with-superlu-lib=-lsuperlu \
|
||||
%endif
|
||||
--with-mpiuni-fortran-binding=1 \
|
||||
%if %{with mumps_serial}
|
||||
--with-mumps-serial=1 \
|
||||
--with-mumps-include=%{_includedir}/MUMPS \
|
||||
@ -487,7 +476,6 @@ CFLAGS="$CFLAGS -O3 -Wl,-z,now" CXXFLAGS="$CXXFLAGS -O3" FFLAGS="$FFLAGS -O3 -Wl
|
||||
--with-cxxlib-autodetect=0 \
|
||||
%endif
|
||||
--with-mpi=0 \
|
||||
--with-mpiuni-fortran-binding=1 \
|
||||
--with-threadsafety=0 --with-log=1 \
|
||||
%if %{with debug}
|
||||
--with-debugging=1 \
|
||||
@ -573,7 +561,6 @@ CFLAGS="$CFLAGS -O3 -Wl,-z,now" CXXFLAGS="$CXXFLAGS -O3" FFLAGS="$FFLAGS -O3 -Wl
|
||||
--with-mpi=1 \
|
||||
--with-mpi-compilers=$MPI_BIN/mpicc \
|
||||
--with-mpiexec=$MPI_BIN/mpiexec \
|
||||
--with-mpiuni-fortran-binding=1 \
|
||||
%endif
|
||||
%if %{with cgns}
|
||||
--with-cgns=1 \
|
||||
@ -685,7 +672,6 @@ CFLAGS="$CFLAGS -O3 -Wl,-z,now" CXXFLAGS="$CXXFLAGS -O3" FFLAGS="$FFLAGS -O3 -Wl
|
||||
--with-mpi=1 \
|
||||
--with-mpi-compilers=$MPI_BIN/mpicc \
|
||||
--with-mpiexec=$MPI_BIN/mpiexec \
|
||||
--with-mpiuni-fortran-binding=1 \
|
||||
%endif
|
||||
%if %{with cgns}
|
||||
--with-cgns=1 \
|
||||
@ -1023,6 +1009,11 @@ make -C buildmpich_dir test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 03 2017 Antonio Trande <sagitter@fedoraproject.org> - 3.8.0-1
|
||||
- Update to 3.8.0
|
||||
- with-mpiuni-fortran-binding option deprecated
|
||||
- Remove obsolete patch2
|
||||
|
||||
* Mon Oct 02 2017 Antonio Trande <sagitter@fedoraproject.org> - 3.7.7-5
|
||||
- Disable debugging
|
||||
- Unset default compiler flags when tests are built
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (petsc-3.7.7.tar.gz) = 408b176536c66b24ceebcc09ba94682d776b157a3eb841fe976b576fd4dc6073e65e76814f95d40a48f8c49dce3f4132dde0249ace64335ad37d2b347f0ed46d
|
||||
SHA512 (petsc-3.8.0.tar.gz) = 66d186e8facb17d29c0b690646c29903d0afe3d2f7ef89a94f406ebceeb11e265b07ab605dd8ac4bd98929b3a48475ed3179733a1117187318e50bc64473fba1
|
||||
|
Loading…
Reference in New Issue
Block a user