Add a patch to drop -mt from one Boost DSO

This commit is contained in:
Petr Machata 2013-07-30 19:58:10 +02:00
parent 5ced69257c
commit 5eeedf0f80
2 changed files with 16 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -up permlib-0.2.8/test/CMakeLists.txt\~ permlib-0.2.8/test/CMakeLists.txt
--- permlib-0.2.8/test/CMakeLists.txt~ 2012-09-27 12:56:49.000000000 +0200
+++ permlib-0.2.8/test/CMakeLists.txt 2013-07-30 19:52:41.803357920 +0200
@@ -9,5 +9,5 @@ set(executables test-base test-trans tes
foreach(_exec ${executables})
add_executable (${_exec} "${_exec}.cpp")
add_test(${_exec} ${_exec})
- target_link_libraries(${_exec} boost_unit_test_framework-mt)
+ target_link_libraries(${_exec} boost_unit_test_framework)
endforeach(_exec)
Diff finished. Tue Jul 30 19:52:44 2013

View File

@ -8,6 +8,7 @@ URL: http://www.math.uni-rostock.de/~rehn/software/%{name}.html
Source0: http://www.math.uni-rostock.de/~rehn/software/%{name}-%{version}.tar.gz
# Doxygen config file written by Jerry James <loganjerry@gmail.com>
Source1: %{name}-Doxyfile
Patch0: %{name}-0.2.8-boost_mt.patch
BuildArch: noarch
BuildRequires: boost-devel
@ -41,6 +42,7 @@ PermLib.
%prep
%setup -q
%patch0 -p1
sed "s/@VERSION@/%{version}/" %{SOURCE1} > Doxyfile
%build
@ -71,6 +73,8 @@ ctest
%changelog
* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 0.2.8-5
- Rebuild for boost 1.54.0
- Remove -mt suffix from boost_unit_testing_framework DSO
(permlib-0.2.8-boost_mt.patch)
* Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 0.2.8-4
- Rebuild for Boost-1.53.0