Remove rpath-make patch
The patch does the same as upstream. Also we use --enable-new-dtags linker option for some time, so it's not needed. Build log is free of `could not LD_PRELOAD' nonexisting library messages now.
This commit is contained in:
parent
724ab9627b
commit
d6a27c21eb
@ -1,32 +0,0 @@
|
|||||||
--- perl-5.8.8-RC1/Makefile.SH.makerpath 2006-01-20 16:41:26.000000000 -0500
|
|
||||||
+++ perl-5.8.8-RC1/Makefile.SH 2006-01-20 16:41:57.000000000 -0500
|
|
||||||
@@ -125,26 +125,10 @@
|
|
||||||
esac
|
|
||||||
|
|
||||||
case "$osname" in
|
|
||||||
- linux)
|
|
||||||
- # If there is a pre-existing $libperl from a previous
|
|
||||||
- # installation, Linux needs to use LD_PRELOAD to
|
|
||||||
- # override the LD_LIBRARY_PATH setting. See the
|
|
||||||
- # INSTALL file, under "Building a shared perl library".
|
|
||||||
- # If there is no pre-existing $libperl, we don't need
|
|
||||||
- # to do anything further.
|
|
||||||
- if test -f $archlib/CORE/$libperl; then
|
|
||||||
- rm -f preload
|
|
||||||
- cat <<'EOT' > preload
|
|
||||||
-#! /bin/sh
|
|
||||||
-lib=$1
|
|
||||||
-shift
|
|
||||||
-test -r $lib && export LD_PRELOAD="$lib $LD_PRELOAD"
|
|
||||||
-exec "$@"
|
|
||||||
-EOT
|
|
||||||
- chmod 755 preload
|
|
||||||
- ldlibpth="$ldlibpth `pwd`/preload `pwd`/$libperl"
|
|
||||||
- fi
|
|
||||||
+ linux*)
|
|
||||||
+ ldlibpth="LD_PRELOAD=`pwd`/libperl.so $ldlibpth"
|
|
||||||
;;
|
|
||||||
+
|
|
||||||
os390) test -f /bin/env && ldlibpth="/bin/env $ldlibpth"
|
|
||||||
;;
|
|
||||||
esac
|
|
18
perl.spec
18
perl.spec
@ -21,7 +21,7 @@
|
|||||||
Name: perl
|
Name: perl
|
||||||
Version: %{perl_version}
|
Version: %{perl_version}
|
||||||
# release number must be even higher, becase dual-lived modules will be broken otherwise
|
# release number must be even higher, becase dual-lived modules will be broken otherwise
|
||||||
Release: 158%{?dist}
|
Release: 159%{?dist}
|
||||||
Epoch: %{perl_epoch}
|
Epoch: %{perl_epoch}
|
||||||
Summary: Practical Extraction and Report Language
|
Summary: Practical Extraction and Report Language
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -44,11 +44,6 @@ Source5: perl-example.stp
|
|||||||
# Removes date check, Fedora/RHEL specific
|
# Removes date check, Fedora/RHEL specific
|
||||||
Patch1: perl-perlbug-tag.patch
|
Patch1: perl-perlbug-tag.patch
|
||||||
|
|
||||||
# work around annoying rpath issue
|
|
||||||
# This is only relevant for Fedora, as it is unlikely
|
|
||||||
# that upstream will assume the existence of a libperl.so
|
|
||||||
Patch2: perl-5.8.8-rpath-make.patch
|
|
||||||
|
|
||||||
# Fedora/RHEL only (64bit only)
|
# Fedora/RHEL only (64bit only)
|
||||||
Patch3: perl-5.8.0-libdir64.patch
|
Patch3: perl-5.8.0-libdir64.patch
|
||||||
|
|
||||||
@ -941,11 +936,6 @@ tarball from perl.org.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n perl-%{perl_version}
|
%setup -q -n perl-%{perl_version}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
# This patch breaks sparc64 compilation
|
|
||||||
# We should probably consider removing it for all arches.
|
|
||||||
%ifnarch sparc64
|
|
||||||
%patch2 -p1
|
|
||||||
%endif
|
|
||||||
%ifarch %{multilib_64_archs}
|
%ifarch %{multilib_64_archs}
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%endif
|
%endif
|
||||||
@ -1157,9 +1147,6 @@ popd
|
|||||||
pushd %{build_archlib}/CORE/
|
pushd %{build_archlib}/CORE/
|
||||||
%{new_perl} -x patchlevel.h \
|
%{new_perl} -x patchlevel.h \
|
||||||
'Fedora Patch1: Removes date check, Fedora/RHEL specific' \
|
'Fedora Patch1: Removes date check, Fedora/RHEL specific' \
|
||||||
%ifnarch sparc64 \
|
|
||||||
'Fedora Patch2: Work around annoying rpath issue' \
|
|
||||||
%endif \
|
|
||||||
%ifarch %{multilib_64_archs} \
|
%ifarch %{multilib_64_archs} \
|
||||||
'Fedora Patch3: support for libdir64' \
|
'Fedora Patch3: support for libdir64' \
|
||||||
%endif \
|
%endif \
|
||||||
@ -1971,6 +1958,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
# Old changelog entries are preserved in CVS.
|
# Old changelog entries are preserved in CVS.
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 07 2011 Petr Pisar <ppisar@redhat.com> - 4:5.12.3-159
|
||||||
|
- Remove rpath-make patch because we use --enable-new-dtags linker option
|
||||||
|
|
||||||
* Fri Apr 1 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.12.3-158
|
* Fri Apr 1 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4:5.12.3-158
|
||||||
- 692900 - lc launders tainted flag, RT #87336
|
- 692900 - lc launders tainted flag, RT #87336
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user