perl-Unicode-Collate/Unicode-Collate-1.19-Fixes-...

25 lines
971 B
Diff

diff -up Unicode-Collate-1.19/mklocale.orig Unicode-Collate-1.19/mklocale
--- Unicode-Collate-1.19/mklocale.orig 2017-05-11 14:46:13.491501304 +0200
+++ Unicode-Collate-1.19/mklocale 2017-05-11 14:48:21.829764058 +0200
@@ -546,7 +546,7 @@ for my $txt (@txts) {
s/\s*\z/.pm/;
my $f = File::Spec->catfile($CUR_DIR, split /::/, $_);
$f = 'Korean.pm' if /::Korean\.pm/; # using the newer one
- require $f;
+ require "./$f";
next;
}
if (/^(alternate)\s+(\S+)/) {
diff -up Unicode-Collate-1.19/Makefile.PL.orig Unicode-Collate-1.19/Makefile.PL
--- Unicode-Collate-1.19/Makefile.PL.orig 2017-05-11 14:57:57.113506081 +0200
+++ Unicode-Collate-1.19/Makefile.PL 2017-05-11 14:57:25.895682439 +0200
@@ -6,7 +6,7 @@ my $clean = {};
if (-f "Collate.xs") {
print "Making header files for XS...\n";
- do 'mkheader' or die $@ || "mkheader: $!";
+ do './mkheader' or die $@ || "mkheader: $!";
$clean = { FILES => 'ucatbl.h' };
}