This commit is contained in:
Petr Písař 2015-07-10 13:34:14 +02:00
parent 14cc16e8de
commit d5fe49a487
4 changed files with 109 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/Unicode-Collate-1.12.tar.gz

View File

@ -0,0 +1,40 @@
From 444b828e15fd7e507c283120e6bd88a264ae5b91 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 2 Jul 2015 16:06:11 +0200
Subject: [PATCH] Create Locale directory with default mask
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
mklocale | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/mklocale b/mklocale
index fc3f269..53b8a1c 100644
--- a/mklocale
+++ b/mklocale
@@ -511,7 +511,7 @@ my @txts = grep /^[a-zA-Z]/, readdir DIR;
closedir DIR;
my $target = 'Locale';
-mkdir $target, 0666;
+mkdir $target;
for my $txt (@txts) {
my %locale_keys;
my $txtfile = File::Spec->catfile($source, $txt);
@@ -519,8 +519,8 @@ for my $txt (@txts) {
$pl =~ s/\.txt\z/.pl/ or croak "$PACKAGE: $source/$txt is not .txt";
my $plfile = File::Spec->catfile($target, $pl);
- open my $fh, $txtfile or croak "$PACKAGE: $source/$txt is not found";
- open my $ph, ">$plfile" or croak "$PACKAGE: $target/$pl can't be made";
+ open my $fh, $txtfile or croak "$PACKAGE: $source/$txt is not found: $!";
+ open my $ph, ">$plfile" or croak "$PACKAGE: $target/$pl can't be made: $!";
binmode $ph;
my $ptxt = '';
--
2.4.3

67
perl-Unicode-Collate.spec Normal file
View File

@ -0,0 +1,67 @@
Name: perl-Unicode-Collate
Version: 1.12
Release: 348%{?dist}
Summary: Unicode Collation Algorithm
License: (GPL+ or Artistic) and UCD
Group: Development/Libraries
URL: http://search.cpan.org/dist/Unicode-Collate/
Source0: http://www.cpan.org/authors/id/S/SA/SADAHIRO/Unicode-Collate-%{version}.tar.gz
# Fix mklocale script, CPAN RT#105621
Patch0: Unicode-Collate-1.12-Create-Locale-directory-with-default-mask.patch
BuildRequires: coreutils
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl
BuildRequires: perl(Carp)
BuildRequires: perl(constant)
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(File::Spec)
BuildRequires: perl(strict)
BuildRequires: perl(warnings)
# Run-time:
BuildRequires: perl(base)
BuildRequires: perl(DynaLoader)
BuildRequires: perl(Unicode::Normalize)
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(Unicode::Normalize)
Conflicts: perl < 4:5.22.0-347
%description
This package is Perl implementation of Unicode Technical Standard #10 (Unicode
Collation Algorithm).
%prep
%setup -q -n Unicode-Collate-%{version}
%patch0 -p1
# Remove pregenerated files
rm Collate/Locale/*
# Collate/CJK/Korean.pm is input for mklocale script, do not remove it here
%build
# Regenerate code from Collate/allkeys.txt whose authority is
# <http://www.unicode.org/Public/UCA/latest/allkeys.txt>
perl mklocale
mv Locale/*.pl Collate/Locale
mv Korean.pm Collate/CJK
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
make %{?_smp_mflags}
%install
make pure_install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
%{_fixperms} $RPM_BUILD_ROOT/*
%check
make test
%files
%doc Changes README
%{perl_vendorarch}/auto/*
%{perl_vendorarch}/Unicode*
%{_mandir}/man3/*
%changelog
* Thu Jul 02 2015 Petr Pisar <ppisar@redhat.com> 1.12-348
- Specfile autogenerated by cpanspec 1.78.

View File

@ -0,0 +1 @@
9eb22e6d7745d4d29b6753c79cbe5014 Unicode-Collate-1.12.tar.gz