Upgrade to 3.26 as provided in perl-5.35.11

This commit is contained in:
Jitka Plesnikova 2022-05-30 13:46:35 +02:00
parent 93d4369890
commit f7fb4bd96b
2 changed files with 70 additions and 2 deletions

View File

@ -0,0 +1,62 @@
From f987887d23adbbc950435921d0585c005cb03258 Mon Sep 17 00:00:00 2001
From: Jitka Plesnikova <jplesnik@redhat.com>
Date: Thu, 12 May 2022 12:34:06 +0200
Subject: [PATCH] Upgrade to 3.26
---
Makefile.PL | 2 +-
Storable.pm | 2 +-
Storable.xs | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile.PL b/Makefile.PL
index e03e141..b705654 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -29,7 +29,7 @@ WriteMakefile(
'ExtUtils::MakeMaker' => '6.31',
},
TEST_REQUIRES => {
- 'Test::More' => '0.41',
+ 'Test::More' => '0.82',
},
)
: () ),
diff --git a/Storable.pm b/Storable.pm
index 8e6ab25..ef417c6 100644
--- a/Storable.pm
+++ b/Storable.pm
@@ -28,7 +28,7 @@ our @EXPORT_OK = qw(
our ($canonical, $forgive_me);
BEGIN {
- our $VERSION = '3.25';
+ our $VERSION = '3.26';
}
our $recursion_limit;
diff --git a/Storable.xs b/Storable.xs
index 6944b76..53c838c 100644
--- a/Storable.xs
+++ b/Storable.xs
@@ -2187,7 +2187,7 @@ static AV *array_call(pTHX_
XPUSHs(sv_2mortal(newSViv(cloning))); /* Cloning flag */
PUTBACK;
- count = call_sv(hook, G_ARRAY); /* Go back to Perl code */
+ count = call_sv(hook, G_LIST); /* Go back to Perl code */
SPAGAIN;
@@ -3318,7 +3318,7 @@ static int get_regexp(pTHX_ stcxt_t *cxt, SV* sv, SV **re, SV **flags) {
XPUSHs(rv);
PUTBACK;
/* optimize to call the XS directly later */
- count = call_sv((SV*)cv, G_ARRAY);
+ count = call_sv((SV*)cv, G_LIST);
SPAGAIN;
if (count < 2)
CROAK(("re::regexp_pattern returned only %d results", (int)count));
--
2.34.3

View File

@ -1,13 +1,15 @@
%global base_version 3.25
Name: perl-Storable
Epoch: 1
Version: %{base_version}
Release: 2%{?dist}
Version: 3.26
Release: 488%{?dist}
Summary: Persistence for Perl data structures
# Storable.pm: GPL+ or Artistic
License: GPL+ or Artistic
URL: https://metacpan.org/release/Storable
Source0: https://cpan.metacpan.org/authors/id/N/NW/NWCLARK/Storable-%{base_version}.tar.gz
# Unbundled from perl 5.35.11
Patch0: Storable-3.25-Upgrade-to-3.26.patch
BuildRequires: coreutils
BuildRequires: gcc
BuildRequires: make
@ -85,6 +87,7 @@ with "%{_libexecdir}/%{name}/test".
%prep
%setup -q -n Storable-%{base_version}
%patch0 -p1
# Help generators to recognize Perl scripts
for F in t/*.t t/*.pl; do
@ -134,6 +137,9 @@ make test
%{_libexecdir}/%{name}
%changelog
* Mon May 30 2022 Jitka Plesnikova <jplesnik@redhat.com> - 1:3.26-488
- Upgrade to 3.26 as provided in perl-5.35.11
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1:3.25-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild