8bf2f74a74
Modules that provide OS-specific behaviors often need to know if the current operating system matches a more generic type of operating systems. For example, 'linux' is a type of 'Unix' operating system and so is 'freebsd'. This module provides a mapping between an operating system name as given by $^O and a more generic type. The initial version is based on the OS type mappings provided in Module::Build and ExtUtils::CBuilder (thus, Microsoft operating systems are given the type 'Windows' rather than 'Win32').
31 lines
711 B
Diff
31 lines
711 B
Diff
--- Perl-OSType-1.002/Makefile.PL 2010-11-16 14:02:55.000000000 +0000
|
|
+++ Perl-OSType-1.002/Makefile.PL 2011-01-25 11:03:37.350523574 +0000
|
|
@@ -4,7 +4,7 @@
|
|
|
|
BEGIN { require 5.006; }
|
|
|
|
-use ExtUtils::MakeMaker 6.31;
|
|
+use ExtUtils::MakeMaker;
|
|
|
|
|
|
|
|
@@ -18,7 +18,7 @@
|
|
'constant' => '0'
|
|
},
|
|
'CONFIGURE_REQUIRES' => {
|
|
- 'ExtUtils::MakeMaker' => '6.31'
|
|
+ 'ExtUtils::MakeMaker' => '0'
|
|
},
|
|
'DISTNAME' => 'Perl-OSType',
|
|
'EXE_FILES' => [],
|
|
@@ -50,6 +50,9 @@
|
|
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
|
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
|
|
|
+delete $WriteMakefileArgs{LICENSE}
|
|
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
|
+
|
|
WriteMakefile(%WriteMakefileArgs);
|
|
|
|
|