Update to 1.003

- New upstream release 1.003
  - Fixed detection of VOS; $^O reports 'vos', not 'VOS'
  - Additional release tests
- BR: perl(File::Spec::Functions), perl(List::Util),
  perl(Perl::Critic::Policy::Lax::ProhibitStringyEval::ExceptForRequire),
  perl(Pod::Wordlist::hanekomu), perl(Test::MinimumVersion),
  perl(Test::Perl::Critic), perl(Test::Spelling) and perl(Test::Version)
- Identify purpose of each build requirement
- Update patches for building on old distributions
- Don't run extra tests for EPEL-5/6 builds
This commit is contained in:
Paul Howarth 2013-03-21 11:15:00 +00:00
parent 9d551cb2ed
commit 1410c09cb7
7 changed files with 113 additions and 64 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/Perl-OSType-1.002.tar.gz
/Perl-OSType-[0-9.]*.tar.gz

View File

@ -1,30 +0,0 @@
--- Perl-OSType-1.002/Makefile.PL 2010-11-16 14:02:55.000000000 +0000
+++ Perl-OSType-1.002/Makefile.PL 2011-01-25 11:03:37.350523574 +0000
@@ -4,7 +4,7 @@
BEGIN { require 5.006; }
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker;
@@ -18,7 +18,7 @@
'constant' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'Perl-OSType',
'EXE_FILES' => [],
@@ -50,6 +50,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

View File

@ -1,18 +0,0 @@
--- Perl-OSType-1.002/t/OSType.t 2010-11-16 14:02:55.000000000 +0000
+++ Perl-OSType-1.002/t/OSType.t 2011-01-25 11:09:41.278401763 +0000
@@ -1,7 +1,7 @@
use strict;
use warnings;
-use Test::More 0.88;
+use Test::More tests => 19;
use constant NON_EXISTENT_OS => 'titanix'; #the system they said could not go down...
@@ -66,6 +66,3 @@
ok( is_os_type( 'VOS' ), "$fcn: true" );
ok( ! is_os_type(), "$fcn: false if no type provided" );
}
-
-done_testing;
-

View File

@ -0,0 +1,30 @@
--- Makefile.PL
+++ Makefile.PL
@@ -4,7 +4,7 @@ use warnings;
use 5.006;
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;
@@ -21,7 +21,7 @@ my %WriteMakefileArgs = (
"constant" => 0
},
"CONFIGURE_REQUIRES" => {
- "ExtUtils::MakeMaker" => "6.30"
+ "ExtUtils::MakeMaker" => "0"
},
"DISTNAME" => "Perl-OSType",
"EXE_FILES" => [],
@@ -55,6 +55,9 @@ unless ( eval { ExtUtils::MakeMaker->VER
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

View File

@ -0,0 +1,35 @@
--- t/OSType.t
+++ t/OSType.t
@@ -1,7 +1,7 @@
use strict;
use warnings;
-use Test::More 0.88;
+use Test::More tests => 19;
use constant NON_EXISTENT_OS => 'titanix'; #the system they said could not go down...
@@ -66,6 +66,3 @@ can_ok( $test_pkg, @functions );
ok( is_os_type( 'VOS' ), "$fcn: true" );
ok( ! is_os_type(), "$fcn: false if no type provided" );
}
-
-done_testing;
-
--- xt/release/test-version.t
+++ xt/release/test-version.t
@@ -1,6 +1,6 @@
use strict;
use warnings;
-use Test::More;
+use Test::More tests => 2;
# generated by Dist::Zilla::Plugin::Test::Version 0.002004
BEGIN { eval "use Test::Version; 1;" or die $@; }
@@ -18,5 +18,4 @@ push @imports, $params
Test::Version->import(@imports);
-version_all_ok;
-done_testing;
+version_all_ok();

View File

@ -1,34 +1,54 @@
# We don't really need ExtUtils::MakeMaker ≥ 6.31
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'print (($ExtUtils::MakeMaker::VERSION < 6.31) ? 1 : 0);' 2>/dev/null || echo 0)
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'print (($ExtUtils::MakeMaker::VERSION < 6.30) ? 1 : 0);' 2>/dev/null || echo 0)
# Test suite needs patching if we have Test::More < 0.88
%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
# Select the appropriate system speller
%if %(perl -e 'print (($] >= 5.010000) ? 1 : 0);')
%global speller hunspell
%else
%global speller aspell
%endif
Name: perl-Perl-OSType
Version: 1.002
Release: 242%{?dist}
Version: 1.003
Release: 1%{?dist}
Summary: Map Perl operating system names to generic types
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Perl-OSType/
Source0: http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Perl-OSType-%{version}.tar.gz
Patch0: Perl-OSType-1.002-old-EU::MM.patch
Patch1: Perl-OSType-1.002-old-Test::More.patch
Patch0: Perl-OSType-1.003-old-EU::MM.patch
Patch1: Perl-OSType-1.003-old-Test::More.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch
BuildRequires: perl(constant)
BuildRequires: perl(Exporter)
# Build
BuildRequires: perl(ExtUtils::MakeMaker)
# Module
BuildRequires: perl(Exporter)
# Test Suite
BuildRequires: perl(constant)
BuildRequires: perl(File::Spec::Functions)
BuildRequires: perl(File::Temp)
BuildRequires: perl(List::Util)
BuildRequires: perl(Test::More)
# Optional tests, not run for this dual-lived module when bootstrapping
%if !%{defined perl_bootstrap}
# Also not run for EPEL-5/6 builds due to package unavailability
%if !%{defined perl_bootstrap} && ( 0%{?fedora} || 0%{?rhel} > 6 )
BuildRequires: perl(Perl::Critic::Policy::Lax::ProhibitStringyEval::ExceptForRequire)
BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Pod::Wordlist::hanekomu)
BuildRequires: perl(Test::CPAN::Meta)
BuildRequires: perl(Test::MinimumVersion)
BuildRequires: perl(Test::Perl::Critic)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Test::Pod::Coverage)
BuildRequires: perl(Test::Portability::Files)
BuildRequires: perl(Test::Spelling), %{speller}-en
BuildRequires: perl(Test::Version)
%endif
# Runtime
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
%description
@ -44,14 +64,14 @@ systems are given the type 'Windows' rather than 'Win32').
%prep
%setup -q -n Perl-OSType-%{version}
# We don't really need ExtUtils::MakeMaker ≥ 6.31
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%if %{old_eumm}
%patch0 -p1
%patch0
%endif
# Fix test suite for Test::More < 0.88
%if %{old_test_more}
%patch1 -p1
%patch1
%endif
%build
@ -66,7 +86,7 @@ find %{buildroot} -type f -name .packlist -exec rm -f {} \;
%check
make test
%if !%{defined perl_bootstrap}
%if !%{defined perl_bootstrap} && ( 0%{?fedora} || 0%{?rhel} > 6 )
make test TEST_FILES="$(echo $(find xt/ -name '*.t'))"
%endif
@ -74,11 +94,23 @@ make test TEST_FILES="$(echo $(find xt/ -name '*.t'))"
rm -rf %{buildroot}
%files
%doc Changes LICENSE README
%doc Changes CONTRIBUTING LICENSE README
%{perl_vendorlib}/Perl/
%{_mandir}/man3/Perl::OSType.3pm*
%changelog
* Thu Mar 21 2013 Paul Howarth <paul@city-fan.org> - 1.003-1
- Update to 1.003
- Fixed detection of VOS; $^O reports 'vos', not 'VOS'
- Additional release tests
- BR: perl(File::Spec::Functions), perl(List::Util),
perl(Perl::Critic::Policy::Lax::ProhibitStringyEval::ExceptForRequire),
perl(Pod::Wordlist::hanekomu), perl(Test::MinimumVersion),
perl(Test::Perl::Critic), perl(Test::Spelling) and perl(Test::Version)
- Identify purpose of each build requirement
- Update patches for building on old distributions
- Don't run extra tests for EPEL-5/6 builds
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.002-242
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

View File

@ -1 +1 @@
73be06de32cd51cf5e6de37b5725e0ac Perl-OSType-1.002.tar.gz
1d559772093dd50d88c932417c0cb657 Perl-OSType-1.003.tar.gz