Fix tests with Parse::CPAN::Meta >= 1.4413

This commit is contained in:
Petr Písař 2014-04-01 13:11:00 +02:00
parent b5da13cc5e
commit b1dfb332af
2 changed files with 64 additions and 1 deletions

View File

@ -0,0 +1,59 @@
From 1d3e5acc95f7f273939d9d57f388b0d972450804 Mon Sep 17 00:00:00 2001
From: Chris 'BinGOs' Williams <chris@bingosnet.co.uk>
Date: Wed, 5 Mar 2014 00:40:46 +0000
Subject: [PATCH] Resolve RT#93293 test failure
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 2 +-
t/20_authors_with_special_characters.t | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile.PL b/Makefile.PL
index d31fd4d..2cc1bf8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -20,7 +20,7 @@ name 'Module-Install';
author 'Adam Kennedy <adamk@cpan.org>';
perl_version '5.005';
all_from 'lib/Module/Install.pm';
-requires 'Parse::CPAN::Meta' => '1.39';
+requires 'Parse::CPAN::Meta' => '1.4413';
requires 'File::Spec' => '3.28';
requires 'Devel::PPPort' => '3.16';
requires 'File::Remove' => '1.42';
diff --git a/t/20_authors_with_special_characters.t b/t/20_authors_with_special_characters.t
index 12eeb86..78787e5 100644
--- a/t/20_authors_with_special_characters.t
+++ b/t/20_authors_with_special_characters.t
@@ -94,7 +94,7 @@ END
my $metafile = file('META.yml');
ok(-f $metafile);
my $meta = Parse::CPAN::Meta::LoadFile($metafile);
- is_deeply($meta->{author}, [qq(Olivier Mengu\xE9)]);
+ is_deeply($meta->{author}, [q(Olivier Mengu\xE9)]);
ok( kill_dist(), 'kill_dist' );
}
@@ -119,7 +119,7 @@ END_DSL
my $metafile = file('META.yml');
ok(-f $metafile);
my $meta = Parse::CPAN::Meta::LoadFile($metafile);
- is_deeply($meta->{author}, [qq(Olivier Mengu\xE9)]);
+ is_deeply($meta->{author}, [q(Olivier Mengu\xE9)]);
ok( kill_dist(), 'kill_dist' );
}
}
@@ -127,4 +127,4 @@ else {
SKIP: {
skip "this test requires perl 5.8", 17;
}
-}
\ No newline at end of file
+}
--
1.9.0

View File

@ -6,6 +6,8 @@ License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Module-Install/
Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/Module-Install-%{version}.tar.gz
# Fix tests with Parse::CPAN::Meta >= 1.4413, in 1.08, CPAN RT#93293
Patch0: Module-Install-1.06-Resolve-RT-93293-test-failure.patch
BuildArch: noarch
BuildRequires: perl(Archive::Tar) >= 1.44
BuildRequires: perl(Carp)
@ -29,7 +31,7 @@ BuildRequires: perl(Module::Build) >= 0.29
BuildRequires: perl(Module::CoreList) >= 2.17
BuildRequires: perl(Module::ScanDeps) >= 0.89
BuildRequires: perl(PAR::Dist) >= 0.29
BuildRequires: perl(Parse::CPAN::Meta) >= 1.39
BuildRequires: perl(Parse::CPAN::Meta) >= 1.4413
BuildRequires: perl(Test::CPAN::Meta) >= 0.07
BuildRequires: perl(Test::Harness) >= 3.13
BuildRequires: perl(Test::More)
@ -52,6 +54,7 @@ version 5.005 or newer.
%prep
%setup -q -n Module-Install-%{version}
%patch0 -p1
%build
perl Makefile.PL INSTALLDIRS=vendor
@ -74,6 +77,7 @@ make test AUTOMATED_TESTING=1
%changelog
* Tue Apr 01 2014 Petr Pisar <ppisar@redhat.com> - 1.06-6
- Do not build-require Test::MinimumVersion, xt tests are not performed
- Fix tests with Parse::CPAN::Meta >= 1.4413 (CPAN RT#93293)
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.06-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild