155 lines
4.5 KiB
RPMSpec
155 lines
4.5 KiB
RPMSpec
Name: perl-Math-BigInt
|
|
%global cpan_version 1.999808
|
|
# Keep 4-digit version to compete with perl.spec
|
|
Version: %(echo %{cpan_version} | sed 's/\(\.....\)/\1./')
|
|
Release: 1%{?dist}
|
|
Summary: Arbitrary-size integer and float mathematics
|
|
License: GPL+ or Artistic
|
|
Group: Development/Libraries
|
|
URL: http://search.cpan.org/dist/Math-BigInt/
|
|
Source0: http://www.cpan.org/authors/id/P/PJ/PJACKLAM/Math-BigInt-%{cpan_version}.tar.gz
|
|
BuildArch: noarch
|
|
BuildRequires: findutils
|
|
BuildRequires: make
|
|
BuildRequires: perl
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(warnings)
|
|
BuildRequires: sed
|
|
# Run-time:
|
|
BuildRequires: perl(Carp)
|
|
BuildRequires: perl(constant)
|
|
BuildRequires: perl(Exporter)
|
|
# File::Spec not used on recent perl
|
|
BuildRequires: perl(integer)
|
|
BuildRequires: perl(Math::Complex) >= 1.39
|
|
BuildRequires: perl(overload)
|
|
# Tests:
|
|
BuildRequires: perl(base)
|
|
BuildRequires: perl(Config)
|
|
# Config::Tiny not used
|
|
BuildRequires: perl(lib)
|
|
# Module::Signature not used
|
|
# Scalar::Util not used
|
|
# Socket not used
|
|
BuildRequires: perl(Test::More) >= 0.94
|
|
# Optional tests:
|
|
# This core module must be buildable without non-core modules at bootstrap.
|
|
%if !%{defined perl_bootstrap}
|
|
BuildRequires: perl(Test::Pod) >= 1.22
|
|
BuildRequires: perl(Test::Pod::Coverage) >= 1.08
|
|
BuildRequires: perl(Pod::Coverage) >= 0.18
|
|
%endif
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
Requires: perl(Math::Complex) >= 1.39
|
|
Conflicts: perl < 4:5.22.0-347
|
|
|
|
# Do not export unversioned module
|
|
%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Math::BigInt\\)\\s*$
|
|
|
|
%description
|
|
This provides Perl modules for arbitrary-size integer and float mathematics.
|
|
|
|
%prep
|
|
%setup -q -n Math-BigInt-%{cpan_version}
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -delete
|
|
%{_fixperms} $RPM_BUILD_ROOT/*
|
|
|
|
%check
|
|
make test
|
|
|
|
%files
|
|
%license LICENSE
|
|
# NEW file is useless
|
|
%doc BUGS CHANGES CREDITS examples GOALS HISTORY README TODO
|
|
%{perl_vendorlib}/*
|
|
%{_mandir}/man3/*
|
|
|
|
%changelog
|
|
* Thu Jan 12 2017 Paul Howarth <paul@city-fan.org> - 1.9998.08-1
|
|
- 1.999808 bump
|
|
|
|
* Mon Jan 02 2017 Petr Pisar <ppisar@redhat.com> - 1.9998.07-1
|
|
- 1.999807 bump
|
|
|
|
* Wed Dec 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9998.06-1
|
|
- 1.999806 bump
|
|
|
|
* Mon Dec 12 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.05-1
|
|
- 1.999805 bump
|
|
|
|
* Fri Dec 09 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.04-1
|
|
- 1.999804 bump
|
|
|
|
* Mon Dec 05 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.03-1
|
|
- 1.999803 bump
|
|
|
|
* Thu Dec 01 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.02-1
|
|
- 1.999802 bump
|
|
|
|
* Fri Nov 25 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.01-1
|
|
- 1.999801 bump
|
|
|
|
* Fri Nov 18 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.00-1
|
|
- 1.999800 bump
|
|
|
|
* Tue Nov 08 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.27-1
|
|
- 1.999727 bump
|
|
|
|
* Mon Jul 18 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.26-1
|
|
- 1.999726 bump
|
|
|
|
* Mon Jun 20 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.24-1
|
|
- 1.999724 bump
|
|
|
|
* Wed Jun 15 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.23-1
|
|
- 1.999723 bump
|
|
|
|
* Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9997.22-3
|
|
- Perl 5.24 re-rebuild of bootstrapped packages
|
|
|
|
* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9997.22-2
|
|
- Perl 5.24 rebuild
|
|
|
|
* Wed Apr 27 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.22-1
|
|
- 1.999722 bump
|
|
|
|
* Tue Apr 26 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.20-1
|
|
- 1.999720 bump
|
|
|
|
* Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.17-1
|
|
- 1.999717 bump
|
|
|
|
* Tue Apr 05 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.16-1
|
|
- 1.999716 bump
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.9997.15-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Wed Jan 06 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.15-1
|
|
- 1.999715 bump
|
|
|
|
* Mon Jan 04 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.14-1
|
|
- 1.999714 bump
|
|
|
|
* Mon Nov 16 2015 Petr Pisar <ppisar@redhat.com> - 1.9997.10-1
|
|
- 1.999710 bump
|
|
|
|
* Tue Nov 10 2015 Petr Pisar <ppisar@redhat.com> - 1.9997.09-1
|
|
- 1.999709 bump
|
|
|
|
* Thu Nov 05 2015 Petr Pisar <ppisar@redhat.com> - 1.9997.08-1
|
|
- 1.999708 bump
|
|
|
|
* Mon Nov 02 2015 Petr Pisar <ppisar@redhat.com> 1.9997.07-354
|
|
- Specfile autogenerated by cpanspec 1.78.
|
|
- Use bundled modules when bootstrapping
|