0.280223 bump

This commit is contained in:
Petr Písař 2015-06-04 09:09:58 +02:00
parent a4d55a438b
commit 0ee9aae144
4 changed files with 12 additions and 232 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
ExtUtils-CBuilder-0.21.tar.gz
/ExtUtils-CBuilder-0.280219.tar.gz
/ExtUtils-CBuilder-0.280220.tar.gz
/ExtUtils-CBuilder-0.280223.tar.gz

View File

@ -1,222 +0,0 @@
From 8b35f9b918bbab075900b04c8e271f12f4f1a44a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Wed, 6 May 2015 11:17:05 +0200
Subject: [PATCH] Upgrade to 0.280221
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Changes | 2 +-
Makefile.PL | 2 +-
lib/ExtUtils/CBuilder.pm | 2 +-
lib/ExtUtils/CBuilder/Base.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/Unix.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/VMS.pm | 7 ++-----
lib/ExtUtils/CBuilder/Platform/Windows.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/aix.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/android.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/cygwin.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/darwin.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/dec_osf.pm | 2 +-
lib/ExtUtils/CBuilder/Platform/os2.pm | 2 +-
t/04-base.t | 16 +++++++++++++++-
14 files changed, 29 insertions(+), 18 deletions(-)
diff --git a/Changes b/Changes
index fab9a9d..89301c6 100644
--- a/Changes
+++ b/Changes
@@ -381,7 +381,7 @@ Revision history for Perl extension ExtUtils::CBuilder.
somehow never got into this copy. [Steve Hay]
- Added a new 'defines' parameter to compile(), which gives a
- platform-independant way to specify various -Dfoo=bar (or the
+ platform-independent way to specify various -Dfoo=bar (or the
equivalent) compiler defines. [Randy W. Sims]
0.14 Mon Sep 19 13:40:37 CDT 2005
diff --git a/Makefile.PL b/Makefile.PL
index bbef2b7..f96bda9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -33,7 +33,7 @@ my %WriteMakefileArgs = (
"TEST_REQUIRES" => {
"Test::More" => "0.47"
},
- "VERSION" => "0.280220",
+ "VERSION" => "0.280221",
"test" => {
"TESTS" => "t/*.t"
}
diff --git a/lib/ExtUtils/CBuilder.pm b/lib/ExtUtils/CBuilder.pm
index 7ebb399..17a4963 100644
--- a/lib/ExtUtils/CBuilder.pm
+++ b/lib/ExtUtils/CBuilder.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder;
-$ExtUtils::CBuilder::VERSION = '0.280220';
+$ExtUtils::CBuilder::VERSION = '0.280221';
use File::Spec ();
use File::Path ();
use File::Basename ();
diff --git a/lib/ExtUtils/CBuilder/Base.pm b/lib/ExtUtils/CBuilder/Base.pm
index 86ee886..7df61e4 100644
--- a/lib/ExtUtils/CBuilder/Base.pm
+++ b/lib/ExtUtils/CBuilder/Base.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Base;
-$ExtUtils::CBuilder::Base::VERSION = '0.280220';
+$ExtUtils::CBuilder::Base::VERSION = '0.280221';
use strict;
use File::Spec;
use File::Basename;
diff --git a/lib/ExtUtils/CBuilder/Platform/Unix.pm b/lib/ExtUtils/CBuilder/Platform/Unix.pm
index 7c08e5a..a05ae4b 100644
--- a/lib/ExtUtils/CBuilder/Platform/Unix.pm
+++ b/lib/ExtUtils/CBuilder/Platform/Unix.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::Unix;
-$ExtUtils::CBuilder::Platform::Unix::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::Unix::VERSION = '0.280221';
use strict;
use ExtUtils::CBuilder::Base;
diff --git a/lib/ExtUtils/CBuilder/Platform/VMS.pm b/lib/ExtUtils/CBuilder/Platform/VMS.pm
index e12d998..6285e33 100644
--- a/lib/ExtUtils/CBuilder/Platform/VMS.pm
+++ b/lib/ExtUtils/CBuilder/Platform/VMS.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::VMS;
-$ExtUtils::CBuilder::Platform::VMS::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::VMS::VERSION = '0.280221';
use strict;
use ExtUtils::CBuilder::Base;
@@ -165,7 +165,6 @@ sub _liblist_ext {
'socket' => '', 'X11' => 'DECW$XLIBSHR',
'Xt' => 'DECW$XTSHR', 'Xm' => 'DECW$XMLIBSHR',
'Xmu' => 'DECW$XMULIBSHR');
- if ($self->{'config'}{'vms_cc_type'} ne 'decc') { $libmap{'curses'} = 'VAXCCURSE'; }
warn "Potential libraries are '$potential_libs'\n" if $verbose;
@@ -266,9 +265,7 @@ sub _liblist_ext {
}
}
if ($ctype) {
- # This has to precede any other CRTLs, so just make it first
- if ($cand eq 'VAXCCURSE') { unshift @{$found{$ctype}}, $cand; }
- else { push @{$found{$ctype}}, $cand; }
+ push @{$found{$ctype}}, $cand;
warn "\tFound as $cand (really $fullname), type $ctype\n"
if $verbose > 1;
push @flibs, $name unless $libs_seen{$fullname}++;
diff --git a/lib/ExtUtils/CBuilder/Platform/Windows.pm b/lib/ExtUtils/CBuilder/Platform/Windows.pm
index 962ada9..472c801 100644
--- a/lib/ExtUtils/CBuilder/Platform/Windows.pm
+++ b/lib/ExtUtils/CBuilder/Platform/Windows.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::Windows;
-$ExtUtils::CBuilder::Platform::Windows::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::Windows::VERSION = '0.280221';
use strict;
use warnings;
diff --git a/lib/ExtUtils/CBuilder/Platform/aix.pm b/lib/ExtUtils/CBuilder/Platform/aix.pm
index f918699..c40dfaa 100644
--- a/lib/ExtUtils/CBuilder/Platform/aix.pm
+++ b/lib/ExtUtils/CBuilder/Platform/aix.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::aix;
-$ExtUtils::CBuilder::Platform::aix::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::aix::VERSION = '0.280221';
use strict;
use ExtUtils::CBuilder::Platform::Unix;
use File::Spec;
diff --git a/lib/ExtUtils/CBuilder/Platform/android.pm b/lib/ExtUtils/CBuilder/Platform/android.pm
index 5b1c8f1..8ceb145 100644
--- a/lib/ExtUtils/CBuilder/Platform/android.pm
+++ b/lib/ExtUtils/CBuilder/Platform/android.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::android;
-$ExtUtils::CBuilder::Platform::android::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::android::VERSION = '0.280221';
use strict;
use File::Spec;
use ExtUtils::CBuilder::Platform::Unix;
diff --git a/lib/ExtUtils/CBuilder/Platform/cygwin.pm b/lib/ExtUtils/CBuilder/Platform/cygwin.pm
index d8c3c35..9f1e7fe 100644
--- a/lib/ExtUtils/CBuilder/Platform/cygwin.pm
+++ b/lib/ExtUtils/CBuilder/Platform/cygwin.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::cygwin;
-$ExtUtils::CBuilder::Platform::cygwin::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::cygwin::VERSION = '0.280221';
use strict;
use File::Spec;
use ExtUtils::CBuilder::Platform::Unix;
diff --git a/lib/ExtUtils/CBuilder/Platform/darwin.pm b/lib/ExtUtils/CBuilder/Platform/darwin.pm
index 63a77a0..391040b 100644
--- a/lib/ExtUtils/CBuilder/Platform/darwin.pm
+++ b/lib/ExtUtils/CBuilder/Platform/darwin.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::darwin;
-$ExtUtils::CBuilder::Platform::darwin::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::darwin::VERSION = '0.280221';
use strict;
use ExtUtils::CBuilder::Platform::Unix;
diff --git a/lib/ExtUtils/CBuilder/Platform/dec_osf.pm b/lib/ExtUtils/CBuilder/Platform/dec_osf.pm
index afa3c7a..5d4bdf7 100644
--- a/lib/ExtUtils/CBuilder/Platform/dec_osf.pm
+++ b/lib/ExtUtils/CBuilder/Platform/dec_osf.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::dec_osf;
-$ExtUtils::CBuilder::Platform::dec_osf::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::dec_osf::VERSION = '0.280221';
use strict;
use ExtUtils::CBuilder::Platform::Unix;
use File::Spec;
diff --git a/lib/ExtUtils/CBuilder/Platform/os2.pm b/lib/ExtUtils/CBuilder/Platform/os2.pm
index e19db90..a5d81ca 100644
--- a/lib/ExtUtils/CBuilder/Platform/os2.pm
+++ b/lib/ExtUtils/CBuilder/Platform/os2.pm
@@ -1,5 +1,5 @@
package ExtUtils::CBuilder::Platform::os2;
-$ExtUtils::CBuilder::Platform::os2::VERSION = '0.280220';
+$ExtUtils::CBuilder::Platform::os2::VERSION = '0.280221';
use strict;
use ExtUtils::CBuilder::Platform::Unix;
diff --git a/t/04-base.t b/t/04-base.t
index beffe7f..3b525b7 100644
--- a/t/04-base.t
+++ b/t/04-base.t
@@ -264,7 +264,21 @@ is_deeply( \%split_seen, \%exp,
touch_file($exporter);
$rv = $base->perl_src();
ok( -d $rv, "perl_src(): returned a directory" );
- is( uc($rv), uc(Cwd::realpath($subdir)), "perl_src(): identified directory" );
+ my $rp = Cwd::realpath($subdir);
+ SKIP: {
+ if ($^O eq 'dec_osf' && $rp =~ m[^/cluster/members/]) {
+ skip "Tru64 cluster filesystem", 1;
+ } # SKIP
+ elsif ($^O eq 'os390') {
+ # os390 also has cluster-like things called 'sysplexed'. So far, the
+ # tail end of the path matches what we passed it (with some prepended
+ # directories). So test for that.
+ like( uc($rp), qr/\U\Q$rp\E$/, "perl_src(): identified directory" );
+ }
+ else {
+ is( uc($rv), uc($rp), "perl_src(): identified directory" );
+ }
+ }
is( $capture, q{}, "perl_src(): no warning, as expected" );
chdir $cwd
--
2.1.0

View File

@ -1,20 +1,19 @@
%global base_version 0.280220
Name: perl-ExtUtils-CBuilder
# Compete with perl.spec
Epoch: 1
# Mimic perl.spec
Version: 0.280221
Release: 2%{?dist}
Version: 0.280223
Release: 1%{?dist}
Summary: Compile and link C code for Perl modules
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/ExtUtils-CBuilder/
Source0: http://www.cpan.org/authors/id/A/AM/AMBS/ExtUtils-CBuilder-%{base_version}.tar.gz
# Unbundled from perl 5.21.11
Patch0: ExtUtils-CBuilder-0.280220-Upgrade-to-0.280221.patch
Source0: http://www.cpan.org/authors/id/A/AM/AMBS/ExtUtils-CBuilder-%{version}.tar.gz
# Link XS modules to libperl.so with EU::CBuilder on Linux, bug #960048
Patch1: ExtUtils-CBuilder-0.280219-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
Patch0: ExtUtils-CBuilder-0.280219-Link-XS-modules-to-libperl.so-with-EU-CBuilder-on-Li.patch
BuildArch: noarch
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(strict)
@ -55,9 +54,8 @@ appropriate compilers and linkers in a cross-platform manner. It was motivated
by the Module::Build project, but may be useful for other purposes as well.
%prep
%setup -q -n ExtUtils-CBuilder-%{base_version}
%setup -q -n ExtUtils-CBuilder-%{version}
%patch0 -p1
%patch1 -p1
%build
perl Makefile.PL INSTALLDIRS=vendor
@ -78,6 +76,9 @@ make test
%{_mandir}/man3/*
%changelog
* Thu Jun 04 2015 Petr Pisar <ppisar@redhat.com> - 1:0.280223-1
- 0.280223 bump
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:0.280221-2
- Perl 5.22 rebuild

View File

@ -1 +1 @@
fbb2bb98efbff061f5482a1d062ed9e3 ExtUtils-CBuilder-0.280220.tar.gz
54269e7cb7a5d995d28fc46933c6e045 ExtUtils-CBuilder-0.280223.tar.gz