Update to 0.004

- New upstream release 0.004
  - Generated from ADAMK/YAML-Tiny-1.50.tar.gz
- BR: perl(Test::Version) for additional test coverage
- Update patch for building with ExtUtils::MakeMaker < 6.30
- Add patch to support building with Test::More < 0.88
- Add patch to fix operation with Scalar::Util < 1.18
This commit is contained in:
Paul Howarth 2011-09-07 14:26:44 +01:00
parent 570b4ad611
commit 24eecf45cf
7 changed files with 67 additions and 37 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/CPAN-Meta-YAML-0.003.tar.gz
/CPAN-Meta-YAML-0.004.tar.gz

View File

@ -1,30 +0,0 @@
--- CPAN-Meta-YAML-0.003/Makefile.PL 2011-01-02 22:32:12.000000000 +0000
+++ CPAN-Meta-YAML-0.003/Makefile.PL 2011-01-25 10:24:19.048578140 +0000
@@ -4,7 +4,7 @@
BEGIN { require 5.004; }
-use ExtUtils::MakeMaker 6.31;
+use ExtUtils::MakeMaker;
@@ -18,7 +18,7 @@
'vars' => '0'
},
'CONFIGURE_REQUIRES' => {
- 'ExtUtils::MakeMaker' => '6.31'
+ 'ExtUtils::MakeMaker' => '0'
},
'DISTNAME' => 'CPAN-Meta-YAML',
'EXE_FILES' => [],
@@ -52,6 +52,9 @@
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+delete $WriteMakefileArgs{LICENSE}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
+
WriteMakefile(%WriteMakefileArgs);

View File

@ -0,0 +1,11 @@
--- CPAN-Meta-YAML/Makefile.PL
+++ CPAN-Meta-YAML/Makefile.PL
@@ -4,7 +4,7 @@
use 5.004;
-use ExtUtils::MakeMaker 6.30;
+use ExtUtils::MakeMaker;

View File

@ -0,0 +1,13 @@
This bug inherited from YAML::Tiny 1.50, which I'd forgotten to report upstream.
--- CPAN-Meta-YAML-0.004/lib/CPAN/Meta/YAML.pm
+++ CPAN-Meta-YAML-0.004/lib/CPAN/Meta/YAML.pm
@@ -615,7 +615,7 @@
require Scalar::Util;
};
if ( $@ or $Scalar::Util::VERSION < 1.18 ) {
- eval <<'END_PERL' if $@;
+ eval <<'END_PERL';
# Scalar::Util failed to load or too old
sub refaddr {
my $pkg = ref($_[0]) or return undef;

View File

@ -0,0 +1,10 @@
--- CPAN-Meta-YAML-0.004/xt/release/test-version.t.orig 2011-09-06 14:42:59.000000000 +0100
+++ CPAN-Meta-YAML-0.004/xt/release/test-version.t 2011-09-07 13:22:05.882101877 +0100
@@ -8,5 +8,6 @@
plan skip_all => "Test::Version 0.04 required for testing versions"
if $@;
+plan tests => 1;
+
version_all_ok();
-done_testing;

View File

@ -1,15 +1,20 @@
# We don't really need ExtUtils::MakeMaker ≥ 6.31
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%global old_eumm %(perl -MExtUtils::MakeMaker -e 'print (($ExtUtils::MakeMaker::VERSION < 6.30) ? 1 : 0);' 2>/dev/null || echo 0)
# We need to patch the test suite if we have Test::More < 0.88
%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
Name: perl-CPAN-Meta-YAML
Version: 0.003
Release: 7%{?dist}
Version: 0.004
Release: 1%{?dist}
Summary: Read and write a subset of YAML for CPAN Meta files
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/CPAN-Meta-YAML/
Source0: http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/CPAN-Meta-YAML-%{version}.tar.gz
Patch0: CPAN-Meta-YAML-0.003-old-EU::MM.patch
Patch0: CPAN-Meta-YAML-0.004-old-EU::MM.patch
Patch1: CPAN-Meta-YAML-0.004-old-Test::More.patch
Patch2: CPAN-Meta-YAML-0.004-old-Scalar::Util.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
BuildArch: noarch
BuildRequires: perl(ExtUtils::MakeMaker)
@ -17,6 +22,10 @@ BuildRequires: perl(File::Spec)
BuildRequires: perl(Test::CPAN::Meta)
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod)
# RHEL <= 6 doesn't have a recent enough perl(version) for perl(Test::Version)
%if 0%{?fedora} || 0%{?rhel} > 6
BuildRequires: perl(Test::Version)
%endif
BuildRequires: perl(YAML)
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
@ -28,11 +37,19 @@ used for any other general YAML parsing or generation task.
%prep
%setup -q -n CPAN-Meta-YAML-%{version}
# We don't really need ExtUtils::MakeMaker ≥ 6.31
# We don't really need ExtUtils::MakeMaker ≥ 6.30
%if %{old_eumm}
%patch0 -p1
%endif
# We need to patch the test suite if we have Test::More < 0.88
%if %{old_test_more}
%patch1 -p1
%endif
# Fix operation with Scalar::Util < 1.18 properly (CPAN RT#53490)
%patch2 -p1
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
@ -57,6 +74,14 @@ rm -rf %{buildroot}
%{_mandir}/man3/CPAN::Meta::YAML.3pm*
%changelog
* Wed Sep 7 2011 Paul Howarth <paul@city-fan.org> - 0.004-1
- Update to 0.004:
- Generated from ADAMK/YAML-Tiny-1.50.tar.gz
- BR: perl(Test::Version) for additional test coverage
- Update patch for building with ExtUtils::MakeMaker < 6.30
- Add patch to support building with Test::More < 0.88
- Add patch to fix operation with Scalar::Util < 1.18
* Tue Aug 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.003-7
- Install to vendor perl directories to avoid potential debuginfo conflicts
with the main perl package if this module ever becomes arch-specific

View File

@ -1 +1 @@
62d0f9726a2b91971b2f3f4ac770de5d CPAN-Meta-YAML-0.003.tar.gz
120025b9fd39b9dbfeb6ffc5f4a2dd8d CPAN-Meta-YAML-0.004.tar.gz