1.83 bump
This commit is contained in:
parent
c6af2486af
commit
cd276bcf2f
1
.gitignore
vendored
1
.gitignore
vendored
@ -31,3 +31,4 @@
|
||||
/Alien-Build-1.76.tar.gz
|
||||
/Alien-Build-1.78.tar.gz
|
||||
/Alien-Build-1.79.tar.gz
|
||||
/Alien-Build-1.83.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From e7fb2ecb0352b058ac6c19aabaa25bdaa14de521 Mon Sep 17 00:00:00 2001
|
||||
From f4f038fea8c62b6a6d86daf1fe07bb11a8c24c46 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Fri, 8 Sep 2017 11:31:02 +0200
|
||||
Subject: [PATCH] Remove redundant pkgconfig implementations
|
||||
@ -21,10 +21,10 @@ Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
6 files changed, 11 insertions(+), 209 deletions(-)
|
||||
|
||||
diff --git a/MANIFEST b/MANIFEST
|
||||
index b6b2d71..212ae9d 100644
|
||||
index 10efe75..afb43c8 100644
|
||||
--- a/MANIFEST
|
||||
+++ b/MANIFEST
|
||||
@@ -170,11 +170,9 @@ lib/Alien/Build/Plugin/Fetch/LocalDir.pm
|
||||
@@ -177,11 +177,9 @@ lib/Alien/Build/Plugin/Fetch/LocalDir.pm
|
||||
lib/Alien/Build/Plugin/Fetch/NetFTP.pm
|
||||
lib/Alien/Build/Plugin/Fetch/Wget.pm
|
||||
lib/Alien/Build/Plugin/Gather/IsolateDynamic.pm
|
||||
@ -36,7 +36,7 @@ index b6b2d71..212ae9d 100644
|
||||
lib/Alien/Build/Plugin/Prefer.pod
|
||||
lib/Alien/Build/Plugin/Prefer/BadVersion.pm
|
||||
lib/Alien/Build/Plugin/Prefer/GoodVersion.pm
|
||||
@@ -247,12 +245,10 @@ t/alien_build_plugin_fetch_netftp.t
|
||||
@@ -263,12 +261,10 @@ t/alien_build_plugin_fetch_netftp.t
|
||||
t/alien_build_plugin_fetch_wget.t
|
||||
t/alien_build_plugin_gather_isolatedynamic.t
|
||||
t/alien_build_plugin_meta.t
|
||||
@ -50,10 +50,10 @@ index b6b2d71..212ae9d 100644
|
||||
t/alien_build_plugin_prefer_goodversion.t
|
||||
t/alien_build_plugin_prefer_sortversions.t
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 1e9e43b..d2da9be 100644
|
||||
index 565bb3d..167cde9 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -80,11 +80,9 @@ my %WriteMakefileArgs = (
|
||||
@@ -86,11 +86,9 @@ my %WriteMakefileArgs = (
|
||||
"lib/Alien/Build/Plugin/Fetch/NetFTP.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Fetch/NetFTP.pm",
|
||||
"lib/Alien/Build/Plugin/Fetch/Wget.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Fetch/Wget.pm",
|
||||
"lib/Alien/Build/Plugin/Gather/IsolateDynamic.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Gather/IsolateDynamic.pm",
|
||||
@ -65,7 +65,7 @@ index 1e9e43b..d2da9be 100644
|
||||
"lib/Alien/Build/Plugin/Prefer.pod" => "\$(INST_LIB)/Alien/Build/Plugin/Prefer.pod",
|
||||
"lib/Alien/Build/Plugin/Prefer/BadVersion.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Prefer/BadVersion.pm",
|
||||
"lib/Alien/Build/Plugin/Prefer/GoodVersion.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Prefer/GoodVersion.pm",
|
||||
@@ -190,4 +188,4 @@ sub requires { goto &runtime_requires }
|
||||
@@ -199,4 +197,4 @@ sub requires { goto &runtime_requires }
|
||||
sub runtime_requires {
|
||||
my ( $module, $version_or_range ) = @_;
|
||||
_add_prereq( PREREQ_PM => $module, $version_or_range );
|
||||
@ -73,7 +73,7 @@ index 1e9e43b..d2da9be 100644
|
||||
\ No newline at end of file
|
||||
+}
|
||||
diff --git a/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm b/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm
|
||||
index 1008914..47630c9 100644
|
||||
index 9a31441..1687619 100644
|
||||
--- a/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm
|
||||
+++ b/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm
|
||||
@@ -3,9 +3,7 @@ package Alien::Build::Plugin::PkgConfig::Negotiate;
|
||||
@ -124,10 +124,10 @@ index 1008914..47630c9 100644
|
||||
}
|
||||
|
||||
diff --git a/t/01_use.t b/t/01_use.t
|
||||
index 3dfc1f3..a9d7389 100644
|
||||
index dba2600..a874761 100644
|
||||
--- a/t/01_use.t
|
||||
+++ b/t/01_use.t
|
||||
@@ -40,11 +40,9 @@ require_ok 'Alien::Build::Plugin::Fetch::LocalDir';
|
||||
@@ -45,11 +45,9 @@ require_ok 'Alien::Build::Plugin::Fetch::LocalDir';
|
||||
require_ok 'Alien::Build::Plugin::Fetch::NetFTP';
|
||||
require_ok 'Alien::Build::Plugin::Fetch::Wget';
|
||||
require_ok 'Alien::Build::Plugin::Gather::IsolateDynamic';
|
||||
@ -139,7 +139,7 @@ index 3dfc1f3..a9d7389 100644
|
||||
require_ok 'Alien::Build::Plugin::Prefer::BadVersion';
|
||||
require_ok 'Alien::Build::Plugin::Prefer::GoodVersion';
|
||||
require_ok 'Alien::Build::Plugin::Prefer::SortVersions';
|
||||
@@ -99,11 +97,9 @@ ok -f 't/alien_build_plugin_fetch_localdir.t', 'test for Alien::B
|
||||
@@ -110,11 +108,9 @@ ok -f 't/alien_build_plugin_fetch_localdir.t', 'test for Alien::B
|
||||
ok -f 't/alien_build_plugin_fetch_netftp.t', 'test for Alien::Build::Plugin::Fetch::NetFTP';
|
||||
ok -f 't/alien_build_plugin_fetch_wget.t', 'test for Alien::Build::Plugin::Fetch::Wget';
|
||||
ok -f 't/alien_build_plugin_gather_isolatedynamic.t', 'test for Alien::Build::Plugin::Gather::IsolateDynamic';
|
||||
@ -165,11 +165,11 @@ index b9b8d65..3575697 100644
|
||||
local $ENV{ALIEN_BUILD_PKG_CONFIG} = "PkgConfig::$name";
|
||||
subtest $ENV{ALIEN_BUILD_PKG_CONFIG} => sub {
|
||||
diff --git a/t/alien_build_plugin_pkgconfig_negotiate__pick.t b/t/alien_build_plugin_pkgconfig_negotiate__pick.t
|
||||
index fc636a2..db886f8 100644
|
||||
index 1d53259..e242728 100644
|
||||
--- a/t/alien_build_plugin_pkgconfig_negotiate__pick.t
|
||||
+++ b/t/alien_build_plugin_pkgconfig_negotiate__pick.t
|
||||
@@ -25,9 +25,10 @@ subtest 'LibPkgConf' => sub {
|
||||
|
||||
|
||||
local $PkgConfig::LibPkgConf::VERSION = '0.01';
|
||||
|
||||
- isnt(
|
||||
@ -185,7 +185,7 @@ index fc636a2..db886f8 100644
|
||||
@@ -40,9 +41,10 @@ subtest 'LibPkgConf' => sub {
|
||||
# cannot be loaded for the rest of this .t file
|
||||
note scalar capture_merged { Devel::Hide->import(qw( PkgConfig::LibPkgConf )) };
|
||||
|
||||
|
||||
- isnt(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::LibPkgConf',
|
||||
@ -231,11 +231,11 @@ index fc636a2..db886f8 100644
|
||||
- },
|
||||
- ],
|
||||
- );
|
||||
-
|
||||
-
|
||||
- my $mock2 = Test2::Mock->new(
|
||||
- class => 'Alien::Build::Plugin::PkgConfig::Negotiate',
|
||||
- );
|
||||
-
|
||||
-
|
||||
- if($^O =~ /^(solaris|MSWin32)$/) {
|
||||
- $mock2->override(
|
||||
- _perl_config => sub {
|
||||
@ -256,13 +256,13 @@ index fc636a2..db886f8 100644
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::PP',
|
||||
- );
|
||||
-
|
||||
-
|
||||
- };
|
||||
-
|
||||
- subtest 'pkg-config' => sub {
|
||||
-
|
||||
-
|
||||
- %which = ( 'pkg-config' => '/usr/bin/pkg-config' );
|
||||
-
|
||||
-
|
||||
- is(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::CommandLine',
|
||||
@ -271,9 +271,9 @@ index fc636a2..db886f8 100644
|
||||
- };
|
||||
-
|
||||
- subtest 'pkgconf' => sub {
|
||||
-
|
||||
-
|
||||
- %which = ( 'pkgconf' => '/usr/bin/pkgconf' );
|
||||
-
|
||||
-
|
||||
- is(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::CommandLine',
|
||||
@ -282,26 +282,26 @@ index fc636a2..db886f8 100644
|
||||
- };
|
||||
-
|
||||
- subtest 'PKG_CONFIG' => sub {
|
||||
-
|
||||
-
|
||||
- local $ENV{PKG_CONFIG} = 'foo-pkg-config';
|
||||
- %which = ( 'foo-pkg-config' => '/usr/bin/foo-pkg-config' );
|
||||
-
|
||||
-
|
||||
- is(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::CommandLine',
|
||||
- );
|
||||
-
|
||||
- );
|
||||
-
|
||||
- };
|
||||
-
|
||||
- subtest 'PP' => sub {
|
||||
-
|
||||
- subtest '64 bit solaris' => sub {
|
||||
-
|
||||
-
|
||||
- %which = ( 'pkg-config' => '/usr/bin/pkg-config' );
|
||||
-
|
||||
- # From the old AB::MB days we prefer PkgConfig.pm
|
||||
- # for 64 bit solaris over the command line pkg-config
|
||||
-
|
||||
-
|
||||
- my $mock2 = Test2::Mock->new(
|
||||
- class => 'Alien::Build::Plugin::PkgConfig::Negotiate',
|
||||
- override => [
|
||||
@ -316,7 +316,7 @@ index fc636a2..db886f8 100644
|
||||
- },
|
||||
- ],
|
||||
- );
|
||||
-
|
||||
-
|
||||
- is(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::PP',
|
||||
@ -326,12 +326,12 @@ index fc636a2..db886f8 100644
|
||||
-
|
||||
-
|
||||
- subtest 'Windows' => sub {
|
||||
-
|
||||
-
|
||||
- %which = ( 'pkg-config' => '/usr/bin/pkg-config' );
|
||||
-
|
||||
- # From the old AB::MB days we prefer PkgConfig.pm
|
||||
- # for 64 bit solaris over the command line pkg-config
|
||||
-
|
||||
-
|
||||
- my $mock2 = Test2::Mock->new(
|
||||
- class => 'Alien::Build::Plugin::PkgConfig::Negotiate',
|
||||
- override => [
|
||||
@ -344,7 +344,7 @@ index fc636a2..db886f8 100644
|
||||
- },
|
||||
- ],
|
||||
- );
|
||||
-
|
||||
-
|
||||
- is(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::PP',
|
||||
@ -370,5 +370,5 @@ index fc636a2..db886f8 100644
|
||||
done_testing;
|
||||
|
||||
--
|
||||
2.20.1
|
||||
2.21.0
|
||||
|
@ -7,7 +7,7 @@
|
||||
%endif
|
||||
|
||||
Name: perl-Alien-Build
|
||||
Version: 1.79
|
||||
Version: 1.83
|
||||
Release: 1%{?dist}
|
||||
Summary: Build external dependencies for use in CPAN
|
||||
# lib/Alien/Build/Plugin/Test/Mock.pm contains Base64-encoded files for tests
|
||||
@ -18,7 +18,7 @@ URL: https://metacpan.org/release/Alien-Build
|
||||
Source0: https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Alien-Build-%{version}.tar.gz
|
||||
# Support only the most advanced pkgconfig implementation,
|
||||
# the files are deleted in prep section
|
||||
Patch0: Alien-Build-1.55-Remove-redundant-pkgconfig-implementations.patch
|
||||
Patch0: Alien-Build-1.83-Remove-redundant-pkgconfig-implementations.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: make
|
||||
# Makefile.PL executes ./inc/probebad.pl that executes XS checks
|
||||
@ -63,6 +63,7 @@ BuildRequires: perl(File::chdir)
|
||||
BuildRequires: perl(File::Copy)
|
||||
BuildRequires: perl(File::Find)
|
||||
BuildRequires: perl(JSON::PP)
|
||||
# List::Util 1.33 not used at tests
|
||||
BuildRequires: perl(Module::Load)
|
||||
BuildRequires: perl(overload)
|
||||
BuildRequires: perl(Path::Tiny) >= 0.077
|
||||
@ -75,6 +76,7 @@ BuildRequires: perl(PkgConfig::LibPkgConf::Client) >= 0.04
|
||||
BuildRequires: perl(PkgConfig::LibPkgConf::Util) >= 0.04
|
||||
BuildRequires: perl(Scalar::Util)
|
||||
BuildRequires: perl(Storable)
|
||||
BuildRequires: perl(Term::ANSIColor)
|
||||
BuildRequires: perl(Test2::API) >= 1.302015
|
||||
BuildRequires: perl(Text::ParseWords) >= 3.26
|
||||
# YAML or Data::Dumper
|
||||
@ -179,7 +181,7 @@ Conflicts: perl-Alien-Base-ModuleBuild < 1.00
|
||||
# Remove underspecified dependencies
|
||||
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\((Capture::Tiny|Path::Tiny|Test2::API|Text::ParseWords)\\)$
|
||||
# Remove private redefinitions
|
||||
%global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(MY\\)
|
||||
%global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\((MY|Alien::Build::rc)\\)$
|
||||
|
||||
%description
|
||||
This package provides tools for building external (non-CPAN) dependencies
|
||||
@ -225,6 +227,7 @@ rm lib/Alien/Build/Plugin/PkgConfig/{CommandLine,PP}.pm
|
||||
rm t/alien_build_plugin_pkgconfig_{commandline,pp}.t
|
||||
|
||||
%build
|
||||
unset PKG_CONFIG
|
||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
|
||||
%{make_build}
|
||||
|
||||
@ -233,7 +236,11 @@ perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
unset ALIEN_BUILD_LIVE_TEST
|
||||
unset ACLOCAL_PATH ALIEN_BASE_WRAPPER_QUIET ALIEN_BUILD_LIVE_TEST \
|
||||
ALIEN_BUILD_LOG ALIEN_BUILD_PKG_CONFIG ALIEN_BUILD_POSTLOAD \
|
||||
ALIEN_BUILD_PRELOAD ALIEN_BUILD_RC ALIEN_BUILD_SITE_CONFIG ALIEN_FORCE \
|
||||
ALIEN_INSTALL_NETWORK ALIEN_INSTALL_TYPE CONFIG_SITE CURL DESTDIR \
|
||||
FOO1 FOO2 FOO3 VERBOSE WGET
|
||||
make test
|
||||
|
||||
%files
|
||||
@ -257,6 +264,9 @@ make test
|
||||
%{_mandir}/man3/Alien::Build::Plugin::Decode::Mojo.3pm.*
|
||||
|
||||
%changelog
|
||||
* Tue Aug 20 2019 Petr Pisar <ppisar@redhat.com> - 1.83-1
|
||||
- 1.83 bump
|
||||
|
||||
* Mon Aug 19 2019 Petr Pisar <ppisar@redhat.com> - 1.79-1
|
||||
- 1.79 bump
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Alien-Build-1.79.tar.gz) = 8b270ec1b914aead651c81d2c513496e31bfa6086c0e5731e6ada17079ede868d65a7c70e29a0762f65ba8c120fd605662122de7f9d715b726be4a503b552808
|
||||
SHA512 (Alien-Build-1.83.tar.gz) = 52d521180537646fcc99988d3a5c7dbd4437b9281c75394449c130f165defb996840e4c46b791cde696e41f5f77df38c89892b9330300bc1124f6391865ad010
|
||||
|
Loading…
Reference in New Issue
Block a user