1.55 bump
This commit is contained in:
parent
61e1f61983
commit
beef9618aa
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
||||
/Alien-Build-1.50.tar.gz
|
||||
/Alien-Build-1.51.tar.gz
|
||||
/Alien-Build-1.52.tar.gz
|
||||
/Alien-Build-1.55.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 7bb7b62e83a3ec43a411859670a65e7df96f643c Mon Sep 17 00:00:00 2001
|
||||
From e7fb2ecb0352b058ac6c19aabaa25bdaa14de521 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Fri, 8 Sep 2017 11:31:02 +0200
|
||||
Subject: [PATCH] Remove redundant pkgconfig implementations
|
||||
@ -12,19 +12,19 @@ ones to decrease number of dependencies.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
MANIFEST | 4 -
|
||||
Makefile.PL | 4 +-
|
||||
lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm | 20 +--
|
||||
t/01_use.t | 4 -
|
||||
t/alien_build_plugin_pkgconfig_negotiate.t | 2 +-
|
||||
t/alien_build_plugin_pkgconfig_negotiate__pick.t | 153 ++---------------------
|
||||
6 files changed, 11 insertions(+), 176 deletions(-)
|
||||
MANIFEST | 4 -
|
||||
Makefile.PL | 4 +-
|
||||
lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm | 25 +--
|
||||
t/01_use.t | 4 -
|
||||
t/alien_build_plugin_pkgconfig_negotiate.t | 2 +-
|
||||
...n_build_plugin_pkgconfig_negotiate__pick.t | 181 +-----------------
|
||||
6 files changed, 11 insertions(+), 209 deletions(-)
|
||||
|
||||
diff --git a/MANIFEST b/MANIFEST
|
||||
index 3f50f9e..5f67c30 100644
|
||||
index b6b2d71..212ae9d 100644
|
||||
--- a/MANIFEST
|
||||
+++ b/MANIFEST
|
||||
@@ -168,11 +168,9 @@ lib/Alien/Build/Plugin/Fetch/LocalDir.pm
|
||||
@@ -170,11 +170,9 @@ lib/Alien/Build/Plugin/Fetch/LocalDir.pm
|
||||
lib/Alien/Build/Plugin/Fetch/NetFTP.pm
|
||||
lib/Alien/Build/Plugin/Fetch/Wget.pm
|
||||
lib/Alien/Build/Plugin/Gather/IsolateDynamic.pm
|
||||
@ -36,7 +36,7 @@ index 3f50f9e..5f67c30 100644
|
||||
lib/Alien/Build/Plugin/Prefer.pod
|
||||
lib/Alien/Build/Plugin/Prefer/BadVersion.pm
|
||||
lib/Alien/Build/Plugin/Prefer/GoodVersion.pm
|
||||
@@ -242,12 +240,10 @@ t/alien_build_plugin_fetch_netftp.t
|
||||
@@ -247,12 +245,10 @@ t/alien_build_plugin_fetch_netftp.t
|
||||
t/alien_build_plugin_fetch_wget.t
|
||||
t/alien_build_plugin_gather_isolatedynamic.t
|
||||
t/alien_build_plugin_meta.t
|
||||
@ -50,10 +50,10 @@ index 3f50f9e..5f67c30 100644
|
||||
t/alien_build_plugin_prefer_goodversion.t
|
||||
t/alien_build_plugin_prefer_sortversions.t
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index 994f006..ae7e457 100644
|
||||
index 1e9e43b..d2da9be 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -74,11 +74,9 @@ my %WriteMakefileArgs = (
|
||||
@@ -80,11 +80,9 @@ my %WriteMakefileArgs = (
|
||||
"lib/Alien/Build/Plugin/Fetch/NetFTP.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Fetch/NetFTP.pm",
|
||||
"lib/Alien/Build/Plugin/Fetch/Wget.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Fetch/Wget.pm",
|
||||
"lib/Alien/Build/Plugin/Gather/IsolateDynamic.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Gather/IsolateDynamic.pm",
|
||||
@ -65,7 +65,7 @@ index 994f006..ae7e457 100644
|
||||
"lib/Alien/Build/Plugin/Prefer.pod" => "\$(INST_LIB)/Alien/Build/Plugin/Prefer.pod",
|
||||
"lib/Alien/Build/Plugin/Prefer/BadVersion.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Prefer/BadVersion.pm",
|
||||
"lib/Alien/Build/Plugin/Prefer/GoodVersion.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Prefer/GoodVersion.pm",
|
||||
@@ -181,4 +179,4 @@ sub requires { goto &runtime_requires }
|
||||
@@ -190,4 +188,4 @@ sub requires { goto &runtime_requires }
|
||||
sub runtime_requires {
|
||||
my ( $module, $version_or_range ) = @_;
|
||||
_add_prereq( PREREQ_PM => $module, $version_or_range );
|
||||
@ -73,7 +73,7 @@ index 994f006..ae7e457 100644
|
||||
\ No newline at end of file
|
||||
+}
|
||||
diff --git a/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm b/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm
|
||||
index 230ad2b..6cda126 100644
|
||||
index 1008914..47630c9 100644
|
||||
--- a/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm
|
||||
+++ b/lib/Alien/Build/Plugin/PkgConfig/Negotiate.pm
|
||||
@@ -3,9 +3,7 @@ package Alien::Build::Plugin::PkgConfig::Negotiate;
|
||||
@ -86,22 +86,27 @@ index 230ad2b..6cda126 100644
|
||||
use Alien::Build::Util qw( _perl_config );
|
||||
use Carp ();
|
||||
|
||||
@@ -32,22 +30,6 @@ sub pick
|
||||
@@ -41,27 +39,6 @@ sub pick
|
||||
return 'PkgConfig::LibPkgConf';
|
||||
}
|
||||
|
||||
|
||||
- if(Alien::Build::Plugin::PkgConfig::CommandLine->available)
|
||||
- {
|
||||
- # TODO: determine environment or flags necessary for using pkg-config
|
||||
- # on solaris 64 bit.
|
||||
- # Some advice on pkg-config and 64 bit Solaris
|
||||
- # https://docs.oracle.com/cd/E53394_01/html/E61689/gplhi.html
|
||||
- if(! (_perl_config('osname') eq 'solaris' && _perl_config('ptrsize') == 8))
|
||||
- my $is_solaris64 = (_perl_config('osname') eq 'solaris' && _perl_config('ptrsize') == 8);
|
||||
-
|
||||
- # PkgConfig.pm is more reliable on windows
|
||||
- my $is_windows = _perl_config('osname') eq 'MSWin32';
|
||||
-
|
||||
- if(!$is_solaris64 && !$is_windows)
|
||||
- {
|
||||
- return 'PkgConfig::CommandLine';
|
||||
- }
|
||||
- }
|
||||
-
|
||||
-
|
||||
- if(Alien::Build::Plugin::PkgConfig::PP->available)
|
||||
- {
|
||||
- return 'PkgConfig::PP';
|
||||
@ -109,7 +114,7 @@ index 230ad2b..6cda126 100644
|
||||
else
|
||||
{
|
||||
# this is a fata error. because we check for a pkg-config implementation
|
||||
@@ -55,7 +37,7 @@ sub pick
|
||||
@@ -69,7 +46,7 @@ sub pick
|
||||
# fallback on installing PkgConfig.pm as a prereq if nothing else is avail).
|
||||
# we therefore expect at least one of these to work, if not, then the configuration
|
||||
# of the system has shifted from underneath us.
|
||||
@ -119,7 +124,7 @@ index 230ad2b..6cda126 100644
|
||||
}
|
||||
|
||||
diff --git a/t/01_use.t b/t/01_use.t
|
||||
index 642c773..12214cd 100644
|
||||
index 3dfc1f3..a9d7389 100644
|
||||
--- a/t/01_use.t
|
||||
+++ b/t/01_use.t
|
||||
@@ -40,11 +40,9 @@ require_ok 'Alien::Build::Plugin::Fetch::LocalDir';
|
||||
@ -134,7 +139,7 @@ index 642c773..12214cd 100644
|
||||
require_ok 'Alien::Build::Plugin::Prefer::BadVersion';
|
||||
require_ok 'Alien::Build::Plugin::Prefer::GoodVersion';
|
||||
require_ok 'Alien::Build::Plugin::Prefer::SortVersions';
|
||||
@@ -98,11 +96,9 @@ ok -f 't/alien_build_plugin_fetch_localdir.t', 'test for Alien::B
|
||||
@@ -99,11 +97,9 @@ ok -f 't/alien_build_plugin_fetch_localdir.t', 'test for Alien::B
|
||||
ok -f 't/alien_build_plugin_fetch_netftp.t', 'test for Alien::Build::Plugin::Fetch::NetFTP';
|
||||
ok -f 't/alien_build_plugin_fetch_wget.t', 'test for Alien::Build::Plugin::Fetch::Wget';
|
||||
ok -f 't/alien_build_plugin_gather_isolatedynamic.t', 'test for Alien::Build::Plugin::Gather::IsolateDynamic';
|
||||
@ -147,7 +152,7 @@ index 642c773..12214cd 100644
|
||||
ok -f 't/alien_build_plugin_prefer_goodversion.t', 'test for Alien::Build::Plugin::Prefer::GoodVersion';
|
||||
ok -f 't/alien_build_plugin_prefer_sortversions.t', 'test for Alien::Build::Plugin::Prefer::SortVersions';
|
||||
diff --git a/t/alien_build_plugin_pkgconfig_negotiate.t b/t/alien_build_plugin_pkgconfig_negotiate.t
|
||||
index 1233b9a..9492ea1 100644
|
||||
index b9b8d65..3575697 100644
|
||||
--- a/t/alien_build_plugin_pkgconfig_negotiate.t
|
||||
+++ b/t/alien_build_plugin_pkgconfig_negotiate.t
|
||||
@@ -16,7 +16,7 @@ subtest 'pick' => sub {
|
||||
@ -160,7 +165,7 @@ index 1233b9a..9492ea1 100644
|
||||
local $ENV{ALIEN_BUILD_PKG_CONFIG} = "PkgConfig::$name";
|
||||
subtest $ENV{ALIEN_BUILD_PKG_CONFIG} => sub {
|
||||
diff --git a/t/alien_build_plugin_pkgconfig_negotiate__pick.t b/t/alien_build_plugin_pkgconfig_negotiate__pick.t
|
||||
index 105c6b6..db886f8 100644
|
||||
index fc636a2..db886f8 100644
|
||||
--- a/t/alien_build_plugin_pkgconfig_negotiate__pick.t
|
||||
+++ b/t/alien_build_plugin_pkgconfig_negotiate__pick.t
|
||||
@@ -25,9 +25,10 @@ subtest 'LibPkgConf' => sub {
|
||||
@ -191,7 +196,7 @@ index 105c6b6..db886f8 100644
|
||||
);
|
||||
|
||||
};
|
||||
@@ -56,144 +58,5 @@ my $make_pkgconfig_libpkgconf_unavailable = Test2::Mock->new(
|
||||
@@ -56,172 +58,5 @@ my $make_pkgconfig_libpkgconf_unavailable = Test2::Mock->new(
|
||||
],
|
||||
);
|
||||
|
||||
@ -231,7 +236,7 @@ index 105c6b6..db886f8 100644
|
||||
- class => 'Alien::Build::Plugin::PkgConfig::Negotiate',
|
||||
- );
|
||||
-
|
||||
- if($^O eq 'solaris') {
|
||||
- if($^O =~ /^(solaris|MSWin32)$/) {
|
||||
- $mock2->override(
|
||||
- _perl_config => sub {
|
||||
- my($key) = @_;
|
||||
@ -318,7 +323,35 @@ index 105c6b6..db886f8 100644
|
||||
- );
|
||||
-
|
||||
- };
|
||||
-
|
||||
-
|
||||
-
|
||||
- subtest 'Windows' => sub {
|
||||
-
|
||||
- %which = ( 'pkg-config' => '/usr/bin/pkg-config' );
|
||||
-
|
||||
- # From the old AB::MB days we prefer PkgConfig.pm
|
||||
- # for 64 bit solaris over the command line pkg-config
|
||||
-
|
||||
- my $mock2 = Test2::Mock->new(
|
||||
- class => 'Alien::Build::Plugin::PkgConfig::Negotiate',
|
||||
- override => [
|
||||
- _perl_config => sub {
|
||||
- my($key) = @_;
|
||||
- if($key eq 'osname')
|
||||
- { return 'MSWin32' }
|
||||
- else
|
||||
- { return $Config{$key} }
|
||||
- },
|
||||
- ],
|
||||
- );
|
||||
-
|
||||
- is(
|
||||
- Alien::Build::Plugin::PkgConfig::Negotiate->pick,
|
||||
- 'PkgConfig::PP',
|
||||
- );
|
||||
-
|
||||
- };
|
||||
-
|
||||
- subtest 'PP is fallback' => sub {
|
||||
-
|
||||
- %which = ();
|
||||
@ -337,5 +370,5 @@ index 105c6b6..db886f8 100644
|
||||
done_testing;
|
||||
|
||||
--
|
||||
2.14.4
|
||||
2.20.1
|
||||
|
@ -2,7 +2,7 @@
|
||||
%{bcond_without perl_Alien_Build_enables_optional_test}
|
||||
|
||||
Name: perl-Alien-Build
|
||||
Version: 1.52
|
||||
Version: 1.55
|
||||
Release: 1%{?dist}
|
||||
Summary: Build external dependencies for use in CPAN
|
||||
# lib/Alien/Build/Plugin/Test/Mock.pm contains Base64-encoded files for tests
|
||||
@ -15,7 +15,7 @@ URL: https://metacpan.org/release/Alien-Build
|
||||
Source0: https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Alien-Build-%{version}.tar.gz
|
||||
# Support only the most advanced pkgconfig implementation,
|
||||
# the files are deleted in prep section
|
||||
Patch0: Alien-Build-1.46-Remove-redundant-pkgconfig-implementations.patch
|
||||
Patch0: Alien-Build-1.55-Remove-redundant-pkgconfig-implementations.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: make
|
||||
# Makefile.PL executes ./inc/probebad.pl that executes XS checks
|
||||
@ -65,7 +65,7 @@ BuildRequires: perl(overload)
|
||||
BuildRequires: perl(Path::Tiny) >= 0.077
|
||||
# Alien::Build::Plugin::PkgConfig::Negotiate finds a pkgconfig implementation
|
||||
# in this order:
|
||||
# PkgConfig::LibPkgConf 0.04, pkgconf, pkg-config, PkgConfig 0.14026
|
||||
# PkgConfig::LibPkgConf 0.04, pkgconf, pkg-config, PkgConfig 0.14026.
|
||||
# We selected the most advanced PkgConfig::LibPkgConf and removed the other
|
||||
# plugins.
|
||||
BuildRequires: perl(PkgConfig::LibPkgConf::Client) >= 0.04
|
||||
@ -189,6 +189,9 @@ make test
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 25 2019 Petr Pisar <ppisar@redhat.com> - 1.55-1
|
||||
- 1.55 bump
|
||||
|
||||
* Mon Feb 11 2019 Petr Pisar <ppisar@redhat.com> - 1.52-1
|
||||
- 1.52 bump
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Alien-Build-1.52.tar.gz) = ada057d19d6a6fd47065ab905d59180584ed73f662a2480f753ce8f587ad5339acfd9342262d64e71d2f0caf247f2ec5b02bc6545ac19c2eec2b71598ab0b329
|
||||
SHA512 (Alien-Build-1.55.tar.gz) = 5db2f4b0260c89e08cf30392a0dd09822881da6e4fd104ecd5a668911c3c5b191e35b741d02320c82731ea8176e67605d6a013616aa1b8139c5d06fcd58f1871
|
||||
|
Loading…
Reference in New Issue
Block a user