2.59 bump

This commit is contained in:
Petr Písař 2022-08-17 10:30:05 +02:00
parent 469bfe42f3
commit 8b7af6d9cb
4 changed files with 91 additions and 7 deletions

1
.gitignore vendored
View File

@ -70,3 +70,4 @@
/Alien-Build-2.48.tar.gz
/Alien-Build-2.50.tar.gz
/Alien-Build-2.51.tar.gz
/Alien-Build-2.59.tar.gz

View File

@ -0,0 +1,71 @@
From d4b7cdb9e22f81fae2a3734a2898501528d2c74e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Wed, 17 Aug 2022 10:18:36 +0200
Subject: [PATCH] Remove redundant SHA implementations
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
We keep Alien::Build::Plugin::Digest::SHA as it is based on
Digest::SHA.
Alien::Build::Plugin::Digest::SHAPP is removed because it
requires Digest::SHA::PurePerl which is not packaged.
Files are moved externally because of ever changing VERSION variables.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
MANIFEST | 2 --
Makefile.PL | 1 -
lib/Alien/Build/Plugin/Digest.pod | 2 --
3 files changed, 5 deletions(-)
diff --git a/MANIFEST b/MANIFEST
index cff43e0..85977a0 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -222,7 +222,6 @@ lib/Alien/Build/Plugin/Decode/Mojo.pm
lib/Alien/Build/Plugin/Digest.pod
lib/Alien/Build/Plugin/Digest/Negotiate.pm
lib/Alien/Build/Plugin/Digest/SHA.pm
-lib/Alien/Build/Plugin/Digest/SHAPP.pm
lib/Alien/Build/Plugin/Download.pod
lib/Alien/Build/Plugin/Download/Negotiate.pm
lib/Alien/Build/Plugin/Extract.pod
@@ -312,7 +311,6 @@ t/alien_build_plugin_decode_html.t
t/alien_build_plugin_decode_mojo.t
t/alien_build_plugin_digest_negotiate.t
t/alien_build_plugin_digest_sha.t
-t/alien_build_plugin_digest_shapp.t
t/alien_build_plugin_download_negotiate.t
t/alien_build_plugin_extract_archivetar.t
t/alien_build_plugin_extract_archivezip.t
diff --git a/Makefile.PL b/Makefile.PL
index 3b9aa53..7931c53 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -73,7 +73,6 @@ my %WriteMakefileArgs = (
"lib/Alien/Build/Plugin/Digest.pod" => "\$(INST_LIB)/Alien/Build/Plugin/Digest.pod",
"lib/Alien/Build/Plugin/Digest/Negotiate.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Digest/Negotiate.pm",
"lib/Alien/Build/Plugin/Digest/SHA.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Digest/SHA.pm",
- "lib/Alien/Build/Plugin/Digest/SHAPP.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Digest/SHAPP.pm",
"lib/Alien/Build/Plugin/Download.pod" => "\$(INST_LIB)/Alien/Build/Plugin/Download.pod",
"lib/Alien/Build/Plugin/Download/Negotiate.pm" => "\$(INST_LIB)/Alien/Build/Plugin/Download/Negotiate.pm",
"lib/Alien/Build/Plugin/Extract.pod" => "\$(INST_LIB)/Alien/Build/Plugin/Extract.pod",
diff --git a/lib/Alien/Build/Plugin/Digest.pod b/lib/Alien/Build/Plugin/Digest.pod
index 4f02619..389f099 100644
--- a/lib/Alien/Build/Plugin/Digest.pod
+++ b/lib/Alien/Build/Plugin/Digest.pod
@@ -37,8 +37,6 @@ L<Digest Negotiator plugin|Alien::Build::Plugin::Digest::Negotiator>.
=item L<Alien::Build::Plugin::Digest::SHA>
-=item L<Alien::Build::Plugin::Digest::SHAPP>
-
=back
=head1 SEE ALSO
--
2.37.2

View File

@ -7,7 +7,7 @@
%endif
Name: perl-Alien-Build
Version: 2.51
Version: 2.59
Release: 1%{?dist}
Summary: Build external dependencies for use in CPAN
# lib/Alien/Build/Plugin/Test/Mock.pm contains Base64-encoded files for tests
@ -19,6 +19,9 @@ Source0: https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Alien-Build-%
# Support only the most advanced pkgconfig implementation,
# the files are deleted in prep section
Patch0: Alien-Build-2.28-Remove-redundant-pkgconfig-implementations.patch
# Support only the most commog SHA implementation,
# the files are deleted in prep section
Patch1: Alien-Build-2.59-Remove-redundant-SHA-implementations.patch
BuildArch: noarch
BuildRequires: coreutils
BuildRequires: make
@ -188,8 +191,8 @@ Provides: perl-Test-Alien = %{version}-%{release}
# Remove private redefinitions
%global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Alien::Build::rc\\)$
# Remove private modules
%global __provides_exclude %{__provides_exclude}|^perl\\(MyTest::.*\\)$
%global __requires_exclude %{__requires_exclude}|^perl\\(Alien::Build::Plugin::RogerRamjet|Alien::Foo|Alien::libfoo1|Alien::libfoo2|MyTest::.*\\)$
%global __provides_exclude %{__provides_exclude}|^perl\\(Alien::Build::Plugin::NesAdvantage::HelperTest|Alien::perlhelp|MyTest::.*\\)$
%global __requires_exclude %{__requires_exclude}|^perl\\(Alien::Build::Plugin::RogerRamjet|Alien::Foo|Alien::libfoo1|Alien::libfoo2|Alien::perlhelp|MyTest::.*\\)$
# Some tests, e.g. t/alien_build_plugin_extract_negotiate.t, compare a script file
# content against an archived one. Do not rewrite their shebangs.
@ -287,10 +290,16 @@ with "%{_libexecdir}/%{name}/test".
%setup -q -n Alien-Build-%{version}
# Remove redundant pkgconfig implementations, keep
# Alien::Build::Plugin::PkgConfig::LibPkgConf,
# MANIFEST is updated by Remove-redundant-pkgconfig-implementations.patch
# MANIFEST is updated by Remove-redundant-pkgconfig-implementations.patch.
%patch0 -p1
rm lib/Alien/Build/Plugin/PkgConfig/{CommandLine,PP}.pm
rm t/alien_build_plugin_pkgconfig_{commandline,pp}.t
# Remove redundant SHA digest imlementations, keep
# Alien::Build::Plugin::Digest::SHA, MANIFEST is updated by
# Alien-Build-2.59-Remove-redundant-SHA-implementations.patch.
%patch1 -p1
rm lib/Alien/Build/Plugin/Digest/SHAPP.pm
rm t/alien_build_plugin_digest_shapp.t
# Remove unused tests
for F in \
t/bin/ftpd \
@ -360,7 +369,7 @@ unset ACLOCAL_PATH ALIEN_BASE_WRAPPER_QUIET ALIEN_BUILD_LIVE_TEST \
ALIEN_BUILD_LOG ALIEN_BUILD_PKG_CONFIG ALIEN_BUILD_POSTLOAD \
ALIEN_BUILD_PRELOAD ALIEN_BUILD_RC ALIEN_BUILD_SITE_CONFIG ALIEN_FORCE \
ALIEN_INSTALL_NETWORK ALIEN_INSTALL_TYPE CIPDIST CONFIG_SITE CURL DESTDIR \
FOO1 FOO2 FOO3 VERBOSE WGET
FOO1 FOO2 FOO3 TEST_ALIEN_ALIENS_MISSING TEST_ALIEN_ALWAYS_KEEP VERBOSE WGET
prove -I . -j "$(getconf _NPROCESSORS_ONLN)"
popd
rm -r "$DIR"
@ -372,7 +381,7 @@ unset ACLOCAL_PATH ALIEN_BASE_WRAPPER_QUIET ALIEN_BUILD_LIVE_TEST \
ALIEN_BUILD_LOG ALIEN_BUILD_PKG_CONFIG ALIEN_BUILD_POSTLOAD \
ALIEN_BUILD_PRELOAD ALIEN_BUILD_RC ALIEN_BUILD_SITE_CONFIG ALIEN_FORCE \
ALIEN_INSTALL_NETWORK ALIEN_INSTALL_TYPE CIPDIST CONFIG_SITE CURL DESTDIR \
FOO1 FOO2 FOO3 VERBOSE WGET
FOO1 FOO2 FOO3 TEST_ALIEN_ALIENS_MISSING TEST_ALIEN_ALWAYS_KEEP VERBOSE WGET
export HARNESS_OPTIONS=j$(perl -e 'if ($ARGV[0] =~ /.*-j([0-9][0-9]*).*/) {print $1} else {print 1}' -- '%{?_smp_mflags}')
make test
@ -420,6 +429,9 @@ make test
%{_libexecdir}/%{name}
%changelog
* Tue Aug 16 2022 Petr Pisar <ppisar@redhat.com> - 2.59-1
- 2.59 bump
* Thu Aug 04 2022 Petr Pisar <ppisar@redhat.com> - 2.51-1
- 2.51 bump

View File

@ -1 +1 @@
SHA512 (Alien-Build-2.51.tar.gz) = d6519bd65bf11932700f6fdf3c4e0b92ea43b1ab814dcff152338f92e90e0147b82ab4498a95c1627285e854c07b6be9f11694d12c537bd861d0e065d57472ef
SHA512 (Alien-Build-2.59.tar.gz) = 8ed2475f5bee10fae5d7a6a717e68ed0ae1ce695c596c869b7966e64047595ac86a6c1b5f7ad7f5ca88a790725afce57001ca2ab48ebeb6fdf0cb99d2ed5607e