56 lines
2.2 KiB
Diff
56 lines
2.2 KiB
Diff
--- pdns-2.9.20/modules/ldapbackend/Makefile.in.avoid-version 2006-12-18 00:11:42.000000000 +0100
|
|
+++ pdns-2.9.20/modules/ldapbackend/Makefile.in 2006-12-18 00:13:17.000000000 +0100
|
|
@@ -205,7 +205,7 @@
|
|
EXTRA_DIST = OBJECTFILES OBJECTLIBS
|
|
libldapbackend_la_SOURCES = ldapbackend.cc ldapbackend.hh \
|
|
powerldap.hh powerldap.cc utils.hh
|
|
-
|
|
+libldapbackend_la_LDFLAGS = -avoid-version
|
|
libldapbackend_la_LIBADD = -lldap
|
|
all: all-am
|
|
|
|
--- pdns-2.9.20/modules/pipebackend/Makefile.in.avoid-version 2006-12-18 00:07:21.000000000 +0100
|
|
+++ pdns-2.9.20/modules/pipebackend/Makefile.in 2006-12-18 00:07:36.000000000 +0100
|
|
@@ -209,7 +209,7 @@
|
|
EXTRA_DIST = OBJECTFILES OBJECTLIBS backend.pl
|
|
lib_LTLIBRARIES = libpipebackend.la
|
|
libpipebackend_la_SOURCES = pipebackend.cc pipebackend.hh coprocess.cc coprocess.hh
|
|
-libpipebackend_la_LDFLAGS = -module
|
|
+libpipebackend_la_LDFLAGS = -module -avoid-version
|
|
all: all-am
|
|
|
|
.SUFFIXES:
|
|
--- pdns-2.9.20/modules/gpgsqlbackend/Makefile.in.avoid-version 2006-12-18 00:08:23.000000000 +0100
|
|
+++ pdns-2.9.20/modules/gpgsqlbackend/Makefile.in 2006-12-18 00:13:51.000000000 +0100
|
|
@@ -208,7 +208,7 @@
|
|
spgsql.hh spgsql.cc
|
|
|
|
libgpgsqlbackend_la_LDFLAGS = @PGSQL_lib@ -Wl,-Bstatic -lpq \
|
|
- -Wl,-Bdynamic
|
|
+ -Wl,-Bdynamic -avoid-version
|
|
|
|
libgpgsqlbackend_la_LIBADD = -lssl -lcrypt -lcrypto
|
|
all: all-am
|
|
--- pdns-2.9.20/modules/gmysqlbackend/Makefile.in.avoid-version 2006-12-18 00:07:52.000000000 +0100
|
|
+++ pdns-2.9.20/modules/gmysqlbackend/Makefile.in 2006-12-18 00:08:15.000000000 +0100
|
|
@@ -207,7 +207,7 @@
|
|
libgmysqlbackend_la_SOURCES = gmysqlbackend.cc gmysqlbackend.hh \
|
|
smysql.hh smysql.cc
|
|
|
|
-libgmysqlbackend_la_LDFLAGS = -module -lmysqlclient
|
|
+libgmysqlbackend_la_LDFLAGS = -module -lmysqlclient -avoid-version
|
|
all: all-am
|
|
|
|
.SUFFIXES:
|
|
--- pdns-2.9.20/modules/geobackend/Makefile.in.avoid-version 2006-03-15 19:33:21.000000000 +0100
|
|
+++ pdns-2.9.20/modules/geobackend/Makefile.in 2006-12-17 23:58:33.000000000 +0100
|
|
@@ -204,7 +204,7 @@
|
|
EXTRA_DIST = OBJECTFILES OBJECTLIBS
|
|
lib_LTLIBRARIES = libgeobackend.la
|
|
libgeobackend_la_SOURCES = geobackend.cc geobackend.hh ippreftree.cc ippreftree.hh
|
|
-libgeobackend_la_LDFLAGS = -module
|
|
+libgeobackend_la_LDFLAGS = -module -avoid-version
|
|
all: all-am
|
|
|
|
.SUFFIXES:
|