Fix MongoDB backend

This commit is contained in:
Morten Stevens 2012-09-18 14:06:21 +02:00
parent 713d70cfcb
commit e8e01122a6
3 changed files with 29 additions and 29 deletions

View File

@ -1,12 +0,0 @@
diff -up pdns-3.0-rc3/configure.orig pdns-3.0-rc3/configure
--- pdns-3.0-rc3/configure.orig 2011-07-20 14:09:39.960000514 +0200
+++ pdns-3.0-rc3/configure 2011-07-20 14:09:46.288007162 +0200
@@ -16494,7 +16494,7 @@ $as_echo_n "checking if with lua... " >&
# Check whether --with-lua was given.
if test "${with_lua+set}" = set; then :
- withval=$with_lua; WITH_LUA=$withval]
+ withval=$with_lua; WITH_LUA=$withval
else
WITH_LUA=yes
fi

View File

@ -1,16 +0,0 @@
diff -up pdns-3.0-rc3/modules/mongodbbackend/Makefile.in.orig pdns-3.0-rc3/modules/mongodbbackend/Makefile.in
--- pdns-3.0-rc3/modules/mongodbbackend/Makefile.in.orig 2011-07-20 14:41:20.181000073 +0200
+++ pdns-3.0-rc3/modules/mongodbbackend/Makefile.in 2011-07-20 14:41:45.191996169 +0200
@@ -256,10 +256,10 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AM_CPPFLAGS = @THREADFLAGS@
EXTRA_DIST = OBJECTFILES OBJECTLIBS
-INCLUDES = -I/opt/mongo/include/mongo/
+INCLUDES = -I/usr/include/mongo/
lib_LTLIBRARIES = libmongodbbackend.la
libmongodbbackend_la_SOURCES = mongodbbackend.cc mongodbbackend.hh minimal.cc slave.cc master.cc reload.cc private.cc dnssec.cc supermaster.cc crc32.cc
-libmongodbbackend_la_LDFLAGS = -module -avoid-version -L/opt/mongo/lib64 $(BOOST_THREAD_LDFLAGS) $(BOOST_FILESYSTEM_LDFLAGS) $(BOOST_SYSTEM_LDFLAGS) -lmongoclient $(BOOST_THREAD_LIBS) $(BOOST_FILESYSTEM_LIBS) $(BOOST_SYSTEM_LIBS)
+libmongodbbackend_la_LDFLAGS = -module -avoid-version $(BOOST_THREAD_LDFLAGS) $(BOOST_FILESYSTEM_LDFLAGS) $(BOOST_SYSTEM_LDFLAGS) -lmongoclient $(BOOST_THREAD_LIBS) $(BOOST_FILESYSTEM_LIBS) $(BOOST_SYSTEM_LIBS)
all: all-am
.SUFFIXES:

View File

@ -3,13 +3,15 @@
Summary: A modern, advanced and high performance authoritative-only nameserver
Name: pdns
Version: 3.1
Release: 1%{?dist}
Release: 2%{?dist}
Group: System Environment/Daemons
License: GPLv2
URL: http://powerdns.com
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
Source1: pdns.service
Patch0: pdns-mongodb-fix1.patch
Patch1: pdns-mongodb-fix2.patch
Requires(pre): shadow-utils
Requires(post): systemd-units, systemd-sysv
@ -65,6 +67,15 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
BuildRequires: sqlite-devel
%global backends %{backends} gsqlite3
%ifarch %{ix86} x86_64
%package backend-mongodb
Summary: MongoDB backend for %{name}
Group: System Environment/Daemons
Requires: %{name}%{?_isa} = %{version}-%{release}
BuildRequires: mongodb-devel
%global backends %{backends} mongodb
%endif
%description backend-mysql
This package contains the gmysql backend for %{name}
@ -85,9 +96,16 @@ This package contains the ldap backend for %{name}
%description backend-sqlite
This package contains the SQLite backend for %{name}
%ifarch %{ix86} x86_64
%description backend-mongodb
This package contains the MongoDB backend for %{name}
%endif
%prep
%setup -q
%patch0 -p1 -b .fixmongodb1
%patch1 -p1 -b .fixmongodb2
%build
export CPPFLAGS="-DLDAP_DEPRECATED %{optflags}"
@ -211,8 +229,17 @@ fi
%defattr(-,root,root,-)
%{_libdir}/%{name}/libgsqlite3backend.so
%ifarch %{ix86} x86_64
%files backend-mongodb
%defattr(-,root,root,-)
%{_libdir}/%{name}/libmongodbbackend.so
%endif
%changelog
* Tue Sep 18 2012 Morten Stevens <mstevens@imt-systems.com> - 3.1-2
- Fix MongoDB backend
* Mon Sep 17 2012 Morten Stevens <mstevens@imt-systems.com> - 3.1-1
- Update to 3.1
- Remove MongoDB backend due build problems
@ -342,3 +369,4 @@ fi
- Initial import