Update to 4.3.0
This commit is contained in:
parent
bb838d5b06
commit
e22e54f575
@ -1,7 +1,7 @@
|
||||
--- pdns-4.1.0-rc1/pdns/common_startup.cc.orig 2017-08-31 10:52:49.000000000 +0200
|
||||
+++ pdns-4.1.0-rc1/pdns/common_startup.cc 2017-08-31 15:49:26.620570095 +0200
|
||||
@@ -190,7 +190,7 @@ void declareArguments()
|
||||
::arg().set("max-nsec3-iterations","Limit the number of NSEC3 hash iterations")="500"; // RFC5155 10.3
|
||||
--- pdns-4.3.0/pdns/common_startup.cc.orig 2020-02-25 07:57:13.000000000 +0100
|
||||
+++ pdns-4.3.0/pdns/common_startup.cc 2020-04-09 16:29:48.531409301 +0200
|
||||
@@ -214,7 +214,7 @@ void declareArguments()
|
||||
::arg().set("default-publish-cds","Default value for PUBLISH-CDS")="";
|
||||
|
||||
::arg().set("include-dir","Include *.conf files from this directory");
|
||||
- ::arg().set("security-poll-suffix","Domain name from which to query security update notifications")="secpoll.powerdns.com.";
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -Nrup a/ext/yahttp/yahttp/reqresp.cpp b/ext/yahttp/yahttp/reqresp.cpp
|
||||
--- a/ext/yahttp/yahttp/reqresp.cpp 2019-02-07 12:24:13.000000000 -0700
|
||||
+++ b/ext/yahttp/yahttp/reqresp.cpp 2019-11-06 19:40:29.039325844 -0700
|
||||
@@ -2,6 +2,8 @@
|
||||
|
||||
namespace YaHTTP {
|
||||
|
||||
+ template class AsyncLoader<Request>;
|
||||
+
|
||||
bool isspace(char c) {
|
||||
return std::isspace(c) != 0;
|
||||
}
|
23
pdns.spec
23
pdns.spec
@ -2,14 +2,13 @@
|
||||
%global backends %{nil}
|
||||
|
||||
Name: pdns
|
||||
Version: 4.2.1
|
||||
Release: 4%{?dist}
|
||||
Version: 4.3.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
License: GPLv2
|
||||
URL: http://powerdns.com
|
||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
|
||||
Patch0: pdns-disable-secpoll.patch
|
||||
Patch1: pdns-gcc10.patch
|
||||
|
||||
Requires(pre): shadow-utils
|
||||
Requires(post): systemd-units
|
||||
@ -132,9 +131,7 @@ BuildRequires: yaml-cpp-devel
|
||||
This package contains the ixfrdist program.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
@ -152,7 +149,6 @@ export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
--with-libsodium \
|
||||
--enable-unit-tests \
|
||||
--enable-lua-records \
|
||||
--enable-reproducible \
|
||||
--enable-experimental-pkcs11 \
|
||||
--enable-systemd \
|
||||
--enable-ixfrdist
|
||||
@ -165,8 +161,6 @@ export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.la
|
||||
%{__mv} %{buildroot}%{_sysconfdir}/%{name}/pdns.conf{-dist,}
|
||||
|
||||
chmod 600 %{buildroot}%{_sysconfdir}/%{name}/pdns.conf
|
||||
|
||||
# rename zone2ldap to pdns-zone2ldap (#1193116)
|
||||
%{__mv} %{buildroot}/%{_bindir}/zone2ldap %{buildroot}/%{_bindir}/pdns_zone2ldap
|
||||
%{__mv} %{buildroot}/%{_mandir}/man1/zone2ldap.1 %{buildroot}/%{_mandir}/man1/pdns_zone2ldap.1
|
||||
@ -219,8 +213,8 @@ exit 0
|
||||
%{_unitdir}/pdns@.service
|
||||
%{_libdir}/%{name}/libbindbackend.so
|
||||
%dir %{_libdir}/%{name}/
|
||||
%dir %{_sysconfdir}/%{name}/
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/pdns.conf
|
||||
%dir %attr(-,root,pdns) %{_sysconfdir}/%{name}/
|
||||
%attr(0640,root,pdns) %config(noreplace) %{_sysconfdir}/%{name}/pdns.conf
|
||||
|
||||
%files tools
|
||||
%{_bindir}/calidns
|
||||
@ -264,6 +258,8 @@ exit 0
|
||||
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.mysql.sql
|
||||
%{_pkgdocdir}/3.4.0_to_4.1.0_schema.mysql.sql
|
||||
%{_pkgdocdir}/4.1.0_to_4.2.0_schema.mysql.sql
|
||||
%{_pkgdocdir}/4.2.0_to_4.3.0_schema.mysql.sql
|
||||
%{_pkgdocdir}/enable-foreign-keys.mysql.sql
|
||||
%{_libdir}/%{name}/libgmysqlbackend.so
|
||||
|
||||
%files backend-postgresql
|
||||
@ -272,6 +268,7 @@ exit 0
|
||||
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.pgsql.sql
|
||||
%{_pkgdocdir}/3.4.0_to_4.1.0_schema.pgsql.sql
|
||||
%{_pkgdocdir}/4.1.0_to_4.2.0_schema.pgsql.sql
|
||||
%{_pkgdocdir}/4.2.0_to_4.3.0_schema.pgsql.sql
|
||||
%{_libdir}/%{name}/libgpgsqlbackend.so
|
||||
|
||||
%files backend-pipe
|
||||
@ -294,6 +291,7 @@ exit 0
|
||||
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.sqlite3.sql
|
||||
%{_pkgdocdir}/3.4.0_to_4.0.0_schema.sqlite3.sql
|
||||
%{_pkgdocdir}/4.0.0_to_4.2.0_schema.sqlite3.sql
|
||||
%{_pkgdocdir}/4.2.0_to_4.3.0_schema.sqlite3.sql
|
||||
%{_libdir}/%{name}/libgsqlite3backend.so
|
||||
|
||||
%files backend-tinydns
|
||||
@ -308,6 +306,9 @@ exit 0
|
||||
%{_unitdir}/ixfrdist@.service
|
||||
|
||||
%changelog
|
||||
* Thu Apr 09 2020 Morten Stevens <mstevens@fedoraproject.org> - 4.3.0-1
|
||||
- Update to 4.3.0
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user