Update to 4.1.0-rc2
This commit is contained in:
parent
a752f93ac5
commit
cc2cc4299e
1
.gitignore
vendored
1
.gitignore
vendored
@ -31,3 +31,4 @@ pdns-2.9.22.tar.gz
|
||||
/pdns-4.0.3.tar.bz2
|
||||
/pdns-4.0.4.tar.bz2
|
||||
/pdns-4.1.0-rc1.tar.bz2
|
||||
/pdns-4.1.0-rc2.tar.bz2
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 2be6b2dcc368ff76842b035b67f7a8170d787889 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Gacogne <remi.gacogne@powerdns.com>
|
||||
Date: Thu, 12 Oct 2017 17:32:52 +0200
|
||||
Subject: [PATCH] auth: Display the needed size when a MySQL result was
|
||||
truncated
|
||||
|
||||
---
|
||||
modules/gmysqlbackend/smysql.cc | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/modules/gmysqlbackend/smysql.cc b/modules/gmysqlbackend/smysql.cc
|
||||
index 5e9354254a..aab16daf9d 100644
|
||||
--- a/modules/gmysqlbackend/smysql.cc
|
||||
+++ b/modules/gmysqlbackend/smysql.cc
|
||||
@@ -233,8 +233,8 @@ class SMySQLStatement: public SSqlStatement
|
||||
row.reserve(d_fnum);
|
||||
|
||||
for(int i=0;i<d_fnum;i++) {
|
||||
- if (*d_res_bind[i].error) {
|
||||
- L<<Logger::Warning<<"Result field at row " << d_residx << " column " << i << " has errno " << *d_res_bind[i].error << endl;
|
||||
+ if (err == MYSQL_DATA_TRUNCATED && *d_res_bind[i].error) {
|
||||
+ L<<Logger::Warning<<"Result field at row " << d_residx << " column " << i << " has been truncated, we allocated " << d_res_bind[i].buffer_length << " bytes but at least " << *d_res_bind[i].length << " was needed" << endl;
|
||||
}
|
||||
if (*d_res_bind[i].is_null) {
|
||||
row.push_back("");
|
26
pdns.spec
26
pdns.spec
@ -1,17 +1,16 @@
|
||||
%global _hardened_build 1
|
||||
%global backends %{nil}
|
||||
%global prever rc1
|
||||
%global prever rc2
|
||||
|
||||
Name: pdns
|
||||
Version: 4.1.0
|
||||
Release: 0.4.%{?prever}%{?dist}
|
||||
Release: 0.5.%{?prever}%{?dist}
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv2
|
||||
URL: http://powerdns.com
|
||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}-%{?prever}.tar.bz2
|
||||
Patch0: pdns-disable-secpoll.patch
|
||||
Patch1: pdns-mysql.patch
|
||||
|
||||
Requires(pre): shadow-utils
|
||||
Requires(post): systemd-units
|
||||
@ -24,8 +23,6 @@ BuildRequires: boost-devel
|
||||
BuildRequires: lua-devel
|
||||
BuildRequires: libsodium-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: pandoc
|
||||
BuildRequires: zeromq-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: protobuf-devel
|
||||
BuildRequires: protobuf-compiler
|
||||
@ -113,16 +110,6 @@ BuildRequires: sqlite-devel
|
||||
%description backend-sqlite
|
||||
This package contains the SQLite backend for %{name}
|
||||
|
||||
%package backend-opendbx
|
||||
Summary: OpenDBX backend for %{name}
|
||||
Group: System Environment/Daemons
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
BuildRequires: opendbx-devel
|
||||
%global backends %{backends} opendbx
|
||||
|
||||
%description backend-opendbx
|
||||
This package contains the opendbx backend for %{name}
|
||||
|
||||
%package backend-geoip
|
||||
Summary: GeoIP backend for %{name}
|
||||
Group: System Environment/Daemons
|
||||
@ -156,7 +143,6 @@ This package contains the TinyDNS backend for %{name}
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}-%{?prever}
|
||||
%patch0 -p1 -b .disable-secpoll
|
||||
%patch1 -p1 -b .mysql
|
||||
|
||||
%build
|
||||
export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
@ -171,7 +157,6 @@ export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
--with-dynmodules='%{backends}' \
|
||||
--enable-tools \
|
||||
--enable-libsodium \
|
||||
--enable-remotebackend-zeromq \
|
||||
--enable-unit-tests \
|
||||
--enable-reproducible \
|
||||
--enable-systemd
|
||||
@ -308,9 +293,6 @@ exit 0
|
||||
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.sqlite3.sql
|
||||
%{_libdir}/%{name}/libgsqlite3backend.so
|
||||
|
||||
%files backend-opendbx
|
||||
%{_libdir}/%{name}/libopendbxbackend.so
|
||||
|
||||
%files backend-geoip
|
||||
%{_libdir}/%{name}/libgeoipbackend.so
|
||||
|
||||
@ -322,6 +304,10 @@ exit 0
|
||||
%{_libdir}/%{name}/libtinydnsbackend.so
|
||||
|
||||
%changelog
|
||||
* Mon Nov 06 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.1.0-0.5.rc2
|
||||
- Update to 4.1.0-rc2
|
||||
- Dropped support for backend opendbx and zeromq
|
||||
|
||||
* Mon Oct 23 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.1.0-0.4.rc1
|
||||
- Removed Fedora specific systemd patch
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pdns-4.1.0-rc1.tar.bz2) = 7356277126578b34587579039d4c63e9ba7822ddd39810b4a43eb06d076c2d247d8b8db7162b2aafd1cb73fd83047b0b5584d4d8bb333ec77597717bac76b450
|
||||
SHA512 (pdns-4.1.0-rc2.tar.bz2) = 01c90f071d6e95fc313a30087e6dcca5383ca1858194a32367af60759786d906c980f5c46233bffb5ce3f7926109b987653be8e5b0cebf420f31052d0df9d61b
|
||||
|
Loading…
Reference in New Issue
Block a user