Fix ppc64 build
This commit is contained in:
parent
4bfdb7d031
commit
a2a9bb18d4
@ -1,162 +0,0 @@
|
|||||||
From 7b48974d019625314e37ed80159e0e37c3bcf6f3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter van Dijk <peter.van.dijk@powerdns.com>
|
|
||||||
Date: Thu, 15 Jun 2017 09:36:57 +0200
|
|
||||||
Subject: [PATCH] unbreak quoting; fixes #5401
|
|
||||||
|
|
||||||
---
|
|
||||||
m4/pdns_check_os.m4 | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/m4/pdns_check_os.m4 b/m4/pdns_check_os.m4
|
|
||||||
index 315fef4f32..2afdbb6bd4 100644
|
|
||||||
--- a/m4/pdns_check_os.m4
|
|
||||||
+++ b/m4/pdns_check_os.m4
|
|
||||||
@@ -39,7 +39,7 @@ AC_DEFUN([PDNS_CHECK_OS],[
|
|
||||||
mips* | powerpc* )
|
|
||||||
AX_CHECK_LINK_FLAG([-latomic],
|
|
||||||
[ : ],
|
|
||||||
- AC_MSG_ERROR([Unable to link against libatomic, cannot continue])
|
|
||||||
+ [ AC_MSG_ERROR([Unable to link against libatomic, cannot continue]) ]
|
|
||||||
)
|
|
||||||
LDFLAGS="-latomic $LDFLAGS"
|
|
||||||
;;
|
|
||||||
|
|
||||||
From 03571f7ac3d5bebb4879849b094e2e03f019cd10 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Pieter Lexis <pieter.lexis@powerdns.com>
|
|
||||||
Date: Mon, 2 Jan 2017 12:23:05 +0100
|
|
||||||
Subject: [PATCH] Check if we can link against libatomic if needed
|
|
||||||
|
|
||||||
Also move the OS detection to the top
|
|
||||||
---
|
|
||||||
configure.ac | 3 +-
|
|
||||||
m4/ax_check_link_flag.m4 | 74 ++++++++++++++++++++++++++++++
|
|
||||||
m4/pdns_check_os.m4 | 9 ++--
|
|
||||||
pdns/dnsdistdist/m4/ax_check_link_flag.m4 | 1 +
|
|
||||||
pdns/recursordist/m4/ax_check_link_flag.m4 | 1 +
|
|
||||||
5 files changed, 83 insertions(+), 5 deletions(-)
|
|
||||||
create mode 100644 m4/ax_check_link_flag.m4
|
|
||||||
create mode 120000 pdns/dnsdistdist/m4/ax_check_link_flag.m4
|
|
||||||
create mode 120000 pdns/recursordist/m4/ax_check_link_flag.m4
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 14a6fa4cb8..a43086bbcf 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -41,6 +41,8 @@ AC_DEFINE([_GNU_SOURCE], [1],
|
|
||||||
# Warn when pkg.m4 is missing
|
|
||||||
m4_pattern_forbid([^_?PKG_[A-Z_]+$], [*** pkg.m4 missing, please install pkg-config])
|
|
||||||
|
|
||||||
+PDNS_CHECK_OS
|
|
||||||
+
|
|
||||||
PDNS_WITH_LUAJIT
|
|
||||||
AS_IF([test "x$with_luajit" = "xno"], [
|
|
||||||
PDNS_WITH_LUA
|
|
||||||
@@ -131,7 +133,6 @@ AS_IF([test "x$lt_cv_dlopen" = "xno"],
|
|
||||||
|
|
||||||
AC_SUBST([LIBDL], [$lt_cv_dlopen_libs])
|
|
||||||
|
|
||||||
-PDNS_CHECK_OS
|
|
||||||
PDNS_ENABLE_VERBOSE_LOGGING
|
|
||||||
PDNS_ENABLE_PKCS11
|
|
||||||
PDNS_ENABLE_GSS_TSIG
|
|
||||||
diff --git a/m4/ax_check_link_flag.m4 b/m4/ax_check_link_flag.m4
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000..eb01a6ce13
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/m4/ax_check_link_flag.m4
|
|
||||||
@@ -0,0 +1,74 @@
|
|
||||||
+# ===========================================================================
|
|
||||||
+# http://www.gnu.org/software/autoconf-archive/ax_check_link_flag.html
|
|
||||||
+# ===========================================================================
|
|
||||||
+#
|
|
||||||
+# SYNOPSIS
|
|
||||||
+#
|
|
||||||
+# AX_CHECK_LINK_FLAG(FLAG, [ACTION-SUCCESS], [ACTION-FAILURE], [EXTRA-FLAGS], [INPUT])
|
|
||||||
+#
|
|
||||||
+# DESCRIPTION
|
|
||||||
+#
|
|
||||||
+# Check whether the given FLAG works with the linker or gives an error.
|
|
||||||
+# (Warnings, however, are ignored)
|
|
||||||
+#
|
|
||||||
+# ACTION-SUCCESS/ACTION-FAILURE are shell commands to execute on
|
|
||||||
+# success/failure.
|
|
||||||
+#
|
|
||||||
+# If EXTRA-FLAGS is defined, it is added to the linker's default flags
|
|
||||||
+# when the check is done. The check is thus made with the flags: "LDFLAGS
|
|
||||||
+# EXTRA-FLAGS FLAG". This can for example be used to force the linker to
|
|
||||||
+# issue an error when a bad flag is given.
|
|
||||||
+#
|
|
||||||
+# INPUT gives an alternative input source to AC_LINK_IFELSE.
|
|
||||||
+#
|
|
||||||
+# NOTE: Implementation based on AX_CFLAGS_GCC_OPTION. Please keep this
|
|
||||||
+# macro in sync with AX_CHECK_{PREPROC,COMPILE}_FLAG.
|
|
||||||
+#
|
|
||||||
+# LICENSE
|
|
||||||
+#
|
|
||||||
+# Copyright (c) 2008 Guido U. Draheim <guidod@gmx.de>
|
|
||||||
+# Copyright (c) 2011 Maarten Bosmans <mkbosmans@gmail.com>
|
|
||||||
+#
|
|
||||||
+# This program is free software: you can redistribute it and/or modify it
|
|
||||||
+# under the terms of the GNU General Public License as published by the
|
|
||||||
+# Free Software Foundation, either version 3 of the License, or (at your
|
|
||||||
+# option) any later version.
|
|
||||||
+#
|
|
||||||
+# This program is distributed in the hope that it will be useful, but
|
|
||||||
+# WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
|
|
||||||
+# Public License for more details.
|
|
||||||
+#
|
|
||||||
+# You should have received a copy of the GNU General Public License along
|
|
||||||
+# with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
||||||
+#
|
|
||||||
+# As a special exception, the respective Autoconf Macro's copyright owner
|
|
||||||
+# gives unlimited permission to copy, distribute and modify the configure
|
|
||||||
+# scripts that are the output of Autoconf when processing the Macro. You
|
|
||||||
+# need not follow the terms of the GNU General Public License when using
|
|
||||||
+# or distributing such scripts, even though portions of the text of the
|
|
||||||
+# Macro appear in them. The GNU General Public License (GPL) does govern
|
|
||||||
+# all other use of the material that constitutes the Autoconf Macro.
|
|
||||||
+#
|
|
||||||
+# This special exception to the GPL applies to versions of the Autoconf
|
|
||||||
+# Macro released by the Autoconf Archive. When you make and distribute a
|
|
||||||
+# modified version of the Autoconf Macro, you may extend this special
|
|
||||||
+# exception to the GPL to apply to your modified version as well.
|
|
||||||
+
|
|
||||||
+#serial 4
|
|
||||||
+
|
|
||||||
+AC_DEFUN([AX_CHECK_LINK_FLAG],
|
|
||||||
+[AC_PREREQ(2.64)dnl for _AC_LANG_PREFIX and AS_VAR_IF
|
|
||||||
+AS_VAR_PUSHDEF([CACHEVAR],[ax_cv_check_ldflags_$4_$1])dnl
|
|
||||||
+AC_CACHE_CHECK([whether the linker accepts $1], CACHEVAR, [
|
|
||||||
+ ax_check_save_flags=$LDFLAGS
|
|
||||||
+ LDFLAGS="$LDFLAGS $4 $1"
|
|
||||||
+ AC_LINK_IFELSE([m4_default([$5],[AC_LANG_PROGRAM()])],
|
|
||||||
+ [AS_VAR_SET(CACHEVAR,[yes])],
|
|
||||||
+ [AS_VAR_SET(CACHEVAR,[no])])
|
|
||||||
+ LDFLAGS=$ax_check_save_flags])
|
|
||||||
+AS_VAR_IF(CACHEVAR,yes,
|
|
||||||
+ [m4_default([$2], :)],
|
|
||||||
+ [m4_default([$3], :)])
|
|
||||||
+AS_VAR_POPDEF([CACHEVAR])dnl
|
|
||||||
+])dnl AX_CHECK_LINK_FLAGS
|
|
||||||
diff --git a/m4/pdns_check_os.m4 b/m4/pdns_check_os.m4
|
|
||||||
index 883f85fb75..315fef4f32 100644
|
|
||||||
--- a/m4/pdns_check_os.m4
|
|
||||||
+++ b/m4/pdns_check_os.m4
|
|
||||||
@@ -36,10 +36,11 @@ AC_DEFUN([PDNS_CHECK_OS],[
|
|
||||||
AM_CONDITIONAL([HAVE_SOLARIS], [test "x$have_solaris" = "xyes"])
|
|
||||||
|
|
||||||
case "$host" in
|
|
||||||
- mips*)
|
|
||||||
- LDFLAGS="-latomic $LDFLAGS"
|
|
||||||
- ;;
|
|
||||||
- powerpc*)
|
|
||||||
+ mips* | powerpc* )
|
|
||||||
+ AX_CHECK_LINK_FLAG([-latomic],
|
|
||||||
+ [ : ],
|
|
||||||
+ AC_MSG_ERROR([Unable to link against libatomic, cannot continue])
|
|
||||||
+ )
|
|
||||||
LDFLAGS="-latomic $LDFLAGS"
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
|
|
23
pdns-fix-ppc64.patch
Normal file
23
pdns-fix-ppc64.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From 8e94e9744fba8c7c1e09a2a611198901c05d1e40 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Morten Stevens <mstevens@fedoraproject.org>
|
||||||
|
Date: Mon, 26 Jun 2017 16:41:24 +0200
|
||||||
|
Subject: [PATCH] Fix building on ppc64
|
||||||
|
|
||||||
|
---
|
||||||
|
m4/pdns_check_os.m4 | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/m4/pdns_check_os.m4 b/m4/pdns_check_os.m4
|
||||||
|
index 2afdbb6bd4..37bf7a8572 100644
|
||||||
|
--- a/m4/pdns_check_os.m4
|
||||||
|
+++ b/m4/pdns_check_os.m4
|
||||||
|
@@ -36,7 +36,7 @@ AC_DEFUN([PDNS_CHECK_OS],[
|
||||||
|
AM_CONDITIONAL([HAVE_SOLARIS], [test "x$have_solaris" = "xyes"])
|
||||||
|
|
||||||
|
case "$host" in
|
||||||
|
- mips* | powerpc* )
|
||||||
|
+ mips* | powerpc-* )
|
||||||
|
AX_CHECK_LINK_FLAG([-latomic],
|
||||||
|
[ : ],
|
||||||
|
[ AC_MSG_ERROR([Unable to link against libatomic, cannot continue]) ]
|
||||||
|
|
11
pdns.spec
11
pdns.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: pdns
|
Name: pdns
|
||||||
Version: 4.0.4
|
Version: 4.0.4
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
@ -11,7 +11,7 @@ URL: http://powerdns.com
|
|||||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
|
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
|
||||||
Source1: pdns.service
|
Source1: pdns.service
|
||||||
Patch0: pdns-disable-secpoll.patch
|
Patch0: pdns-disable-secpoll.patch
|
||||||
Patch1: pdns-fix-aarch64.patch
|
Patch1: pdns-fix-ppc64.patch
|
||||||
|
|
||||||
Requires(pre): shadow-utils
|
Requires(pre): shadow-utils
|
||||||
Requires(post): systemd-units
|
Requires(post): systemd-units
|
||||||
@ -156,7 +156,7 @@ This package contains the TinyDNS backend for %{name}
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .disable-secpoll
|
%patch0 -p1 -b .disable-secpoll
|
||||||
%patch1 -p1 -R -b .fix-aarch64
|
%patch1 -p1 -b .fix-ppc64
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -v -f -i
|
autoreconf -v -f -i
|
||||||
@ -319,8 +319,11 @@ exit 0
|
|||||||
%{_libdir}/%{name}/libtinydnsbackend.so
|
%{_libdir}/%{name}/libtinydnsbackend.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 26 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.0.4-3
|
||||||
|
- Updated patch to fix building on ppc64
|
||||||
|
|
||||||
* Fri Jun 23 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.0.4-2
|
* Fri Jun 23 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.0.4-2
|
||||||
- Fix building on aarch64
|
- Fix building on ppc64
|
||||||
|
|
||||||
* Fri Jun 23 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.0.4-1
|
* Fri Jun 23 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.0.4-1
|
||||||
- Update to 4.0.4
|
- Update to 4.0.4
|
||||||
|
Loading…
Reference in New Issue
Block a user