Update to 4.1.0-rc1
This commit is contained in:
parent
946cc85f21
commit
a2123013e6
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ pdns-2.9.22.tar.gz
|
|||||||
/pdns-4.0.2.tar.bz2
|
/pdns-4.0.2.tar.bz2
|
||||||
/pdns-4.0.3.tar.bz2
|
/pdns-4.0.3.tar.bz2
|
||||||
/pdns-4.0.4.tar.bz2
|
/pdns-4.0.4.tar.bz2
|
||||||
|
/pdns-4.1.0-rc1.tar.bz2
|
||||||
|
@ -1,11 +1,11 @@
|
|||||||
--- pdns-4.0.0-rc1/pdns/common_startup.cc.orig 2016-06-29 11:43:23.000000000 +0200
|
--- pdns-4.1.0-rc1/pdns/common_startup.cc.orig 2017-08-31 10:52:49.000000000 +0200
|
||||||
+++ pdns-4.0.0-rc1/pdns/common_startup.cc 2016-06-29 14:50:11.915033803 +0200
|
+++ pdns-4.1.0-rc1/pdns/common_startup.cc 2017-08-31 15:49:26.620570095 +0200
|
||||||
@@ -183,7 +183,7 @@ void declareArguments()
|
@@ -190,7 +190,7 @@ void declareArguments()
|
||||||
::arg().set("max-nsec3-iterations","Limit the number of NSEC3 hash iterations")="500"; // RFC5155 10.3
|
::arg().set("max-nsec3-iterations","Limit the number of NSEC3 hash iterations")="500"; // RFC5155 10.3
|
||||||
|
|
||||||
::arg().set("include-dir","Include *.conf files from this directory");
|
::arg().set("include-dir","Include *.conf files from this directory");
|
||||||
- ::arg().set("security-poll-suffix","Domain name from which to query security update notifications")="secpoll.powerdns.com.";
|
- ::arg().set("security-poll-suffix","Domain name from which to query security update notifications")="secpoll.powerdns.com.";
|
||||||
+ ::arg().set("security-poll-suffix","Domain name from which to query security update notifications")="";
|
+ ::arg().set("security-poll-suffix","Domain name from which to query security update notifications")="";
|
||||||
|
|
||||||
|
::arg().setSwitch("expand-alias", "Expand ALIAS records")="no";
|
||||||
::arg().setSwitch("outgoing-axfr-expand-alias", "Expand ALIAS records during outgoing AXFR")="no";
|
::arg().setSwitch("outgoing-axfr-expand-alias", "Expand ALIAS records during outgoing AXFR")="no";
|
||||||
::arg().setSwitch("8bit-dns", "Allow 8bit dns queries")="no";
|
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
From 8e94e9744fba8c7c1e09a2a611198901c05d1e40 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Morten Stevens <mstevens@fedoraproject.org>
|
|
||||||
Date: Mon, 26 Jun 2017 16:41:24 +0200
|
|
||||||
Subject: [PATCH] Fix building on ppc64
|
|
||||||
|
|
||||||
---
|
|
||||||
m4/pdns_check_os.m4 | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/m4/pdns_check_os.m4 b/m4/pdns_check_os.m4
|
|
||||||
index 2afdbb6bd4..37bf7a8572 100644
|
|
||||||
--- a/m4/pdns_check_os.m4
|
|
||||||
+++ b/m4/pdns_check_os.m4
|
|
||||||
@@ -36,7 +36,7 @@ AC_DEFUN([PDNS_CHECK_OS],[
|
|
||||||
AM_CONDITIONAL([HAVE_SOLARIS], [test "x$have_solaris" = "xyes"])
|
|
||||||
|
|
||||||
case "$host" in
|
|
||||||
- mips* | powerpc* )
|
|
||||||
+ mips* | powerpc-* )
|
|
||||||
AX_CHECK_LINK_FLAG([-latomic],
|
|
||||||
[ : ],
|
|
||||||
[ AC_MSG_ERROR([Unable to link against libatomic, cannot continue]) ]
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -up pdns-4.0.1/pdns/dns_random.cc.openssl pdns-4.0.1/pdns/dns_random.cc
|
|
||||||
--- pdns-4.0.1/pdns/dns_random.cc.openssl 2016-11-19 11:35:33.865736519 -0700
|
|
||||||
+++ pdns-4.0.1/pdns/dns_random.cc 2016-11-19 11:36:13.357295050 -0700
|
|
||||||
@@ -2,6 +2,7 @@
|
|
||||||
#include "config.h"
|
|
||||||
#endif
|
|
||||||
#include <openssl/aes.h>
|
|
||||||
+#include <openssl/opensslv.h>
|
|
||||||
#if OPENSSL_VERSION_NUMBER > 0x1000100fL
|
|
||||||
// Older OpenSSL does not have CRYPTO_ctr128_encrypt. Before 1.1.0 the header
|
|
||||||
// file did not have the necessary extern "C" wrapper. In 1.1.0, AES_ctr128_encrypt
|
|
22
pdns.spec
22
pdns.spec
@ -1,17 +1,17 @@
|
|||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
%global backends %{nil}
|
%global backends %{nil}
|
||||||
|
%global prever rc1
|
||||||
|
|
||||||
Name: pdns
|
Name: pdns
|
||||||
Version: 4.0.4
|
Version: 4.1.0
|
||||||
Release: 7%{?dist}
|
Release: 0.1.%{?prever}%{?dist}
|
||||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://powerdns.com
|
URL: http://powerdns.com
|
||||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
|
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}-%{?prever}.tar.bz2
|
||||||
Source1: pdns.service
|
Source1: pdns.service
|
||||||
Patch0: pdns-disable-secpoll.patch
|
Patch0: pdns-disable-secpoll.patch
|
||||||
Patch1: pdns-fix-ppc64.patch
|
|
||||||
|
|
||||||
Requires(pre): shadow-utils
|
Requires(pre): shadow-utils
|
||||||
Requires(post): systemd-units
|
Requires(post): systemd-units
|
||||||
@ -27,9 +27,6 @@ BuildRequires: zeromq-devel
|
|||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: protobuf-devel
|
BuildRequires: protobuf-devel
|
||||||
BuildRequires: protobuf-compiler
|
BuildRequires: protobuf-compiler
|
||||||
BuildRequires: autoconf
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: libtool
|
|
||||||
Provides: powerdns = %{version}-%{release}
|
Provides: powerdns = %{version}-%{release}
|
||||||
%global backends %{backends} bind
|
%global backends %{backends} bind
|
||||||
|
|
||||||
@ -154,12 +151,10 @@ BuildRequires: tinycdb-devel
|
|||||||
This package contains the TinyDNS backend for %{name}
|
This package contains the TinyDNS backend for %{name}
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}-%{?prever}
|
||||||
%patch0 -p1 -b .disable-secpoll
|
%patch0 -p1 -b .disable-secpoll
|
||||||
%patch1 -p1 -b .fix-ppc64
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -v -f -i
|
|
||||||
export CPPFLAGS="-DLDAP_DEPRECATED"
|
export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
@ -279,12 +274,14 @@ exit 0
|
|||||||
%{_pkgdocdir}/schema.mysql.sql
|
%{_pkgdocdir}/schema.mysql.sql
|
||||||
%{_pkgdocdir}/dnssec-3.x_to_3.4.0_schema.mysql.sql
|
%{_pkgdocdir}/dnssec-3.x_to_3.4.0_schema.mysql.sql
|
||||||
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.mysql.sql
|
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.mysql.sql
|
||||||
|
%{_pkgdocdir}/3.4.0_to_4.1.0_schema.mysql.sql
|
||||||
%{_libdir}/%{name}/libgmysqlbackend.so
|
%{_libdir}/%{name}/libgmysqlbackend.so
|
||||||
|
|
||||||
%files backend-postgresql
|
%files backend-postgresql
|
||||||
%{_pkgdocdir}/schema.pgsql.sql
|
%{_pkgdocdir}/schema.pgsql.sql
|
||||||
%{_pkgdocdir}/dnssec-3.x_to_3.4.0_schema.pgsql.sql
|
%{_pkgdocdir}/dnssec-3.x_to_3.4.0_schema.pgsql.sql
|
||||||
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.pgsql.sql
|
%{_pkgdocdir}/nodnssec-3.x_to_3.4.0_schema.pgsql.sql
|
||||||
|
%{_pkgdocdir}/3.4.0_to_4.1.0_schema.pgsql.sql
|
||||||
%{_libdir}/%{name}/libgpgsqlbackend.so
|
%{_libdir}/%{name}/libgpgsqlbackend.so
|
||||||
|
|
||||||
%files backend-pipe
|
%files backend-pipe
|
||||||
@ -295,6 +292,8 @@ exit 0
|
|||||||
|
|
||||||
%files backend-ldap
|
%files backend-ldap
|
||||||
%{_libdir}/%{name}/libldapbackend.so
|
%{_libdir}/%{name}/libldapbackend.so
|
||||||
|
%{_pkgdocdir}/dnsdomain2.schema
|
||||||
|
%{_pkgdocdir}/pdns-domaininfo.schema
|
||||||
|
|
||||||
%files backend-lua
|
%files backend-lua
|
||||||
%{_libdir}/%{name}/libluabackend.so
|
%{_libdir}/%{name}/libluabackend.so
|
||||||
@ -319,6 +318,9 @@ exit 0
|
|||||||
%{_libdir}/%{name}/libtinydnsbackend.so
|
%{_libdir}/%{name}/libtinydnsbackend.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 31 2017 Morten Stevens <mstevens@fedoraproject.org> - 4.1.0-0.1.rc1
|
||||||
|
- Update to 4.1.0-rc1
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-7
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pdns-4.0.4.tar.bz2) = 4ef4705cd990b03976775167c7c37850d45907e198549feda5f5701172e008e3f1f74a35a9bebdb24b63dec15ff63cb2cc9dfc8f92e4e1012e0539c5a88b845b
|
SHA512 (pdns-4.1.0-rc1.tar.bz2) = 7356277126578b34587579039d4c63e9ba7822ddd39810b4a43eb06d076c2d247d8b8db7162b2aafd1cb73fd83047b0b5584d4d8bb333ec77597717bac76b450
|
||||||
|
Loading…
Reference in New Issue
Block a user