- Upstream releasd new release candidate

- Drop patches which are upstreamed
This commit is contained in:
Ruben Kerkhof 2008-12-03 12:53:07 +00:00
parent 17abdeb65e
commit 853569f1f5
7 changed files with 17 additions and 169 deletions

View File

@ -1 +1 @@
pdns-2.9.21.2.tar.gz
pdns-2.9.22-rc2.tar.gz

View File

@ -1,66 +0,0 @@
--- pdns-2.9.21/modules/ldapbackend/Makefile.in.avoid-version 2007-04-24 09:02:39.000000000 +0200
+++ pdns-2.9.21/modules/ldapbackend/Makefile.in 2007-04-24 09:04:35.000000000 +0200
@@ -214,7 +214,7 @@
EXTRA_DIST = OBJECTFILES OBJECTLIBS
libldapbackend_la_SOURCES = ldapbackend.cc ldapbackend.hh \
powerldap.hh powerldap.cc utils.hh
-
+libldapbackend_la_LDFLAGS = -avoid-version
libldapbackend_la_LIBADD = -lldap
all: all-am
--- pdns-2.9.21/modules/pipebackend/Makefile.in.avoid-version 2007-04-24 09:04:56.000000000 +0200
+++ pdns-2.9.21/modules/pipebackend/Makefile.in 2007-04-24 09:05:12.000000000 +0200
@@ -217,7 +217,7 @@
EXTRA_DIST = OBJECTFILES OBJECTLIBS backend.pl
lib_LTLIBRARIES = libpipebackend.la
libpipebackend_la_SOURCES = pipebackend.cc pipebackend.hh coprocess.cc coprocess.hh
-libpipebackend_la_LDFLAGS = -module
+libpipebackend_la_LDFLAGS = -module -avoid-version
all: all-am
.SUFFIXES:
--- pdns-2.9.21/modules/gpgsqlbackend/Makefile.in.avoid-version 2007-04-24 09:00:43.000000000 +0200
+++ pdns-2.9.21/modules/gpgsqlbackend/Makefile.in 2007-04-24 09:01:19.000000000 +0200
@@ -217,7 +217,7 @@
spgsql.hh spgsql.cc
libgpgsqlbackend_la_LDFLAGS = @PGSQL_lib@ -Wl,-Bstatic -lpq \
- -Wl,-Bdynamic
+ -Wl,-Bdynamic -avoid-version
libgpgsqlbackend_la_LIBADD = -lssl -lcrypt -lcrypto
all: all-am
--- pdns-2.9.21/modules/gmysqlbackend/Makefile.in.avoid-version 2007-04-24 09:00:14.000000000 +0200
+++ pdns-2.9.21/modules/gmysqlbackend/Makefile.in 2007-04-24 09:00:34.000000000 +0200
@@ -216,7 +216,7 @@
libgmysqlbackend_la_SOURCES = gmysqlbackend.cc gmysqlbackend.hh \
smysql.hh smysql.cc
-libgmysqlbackend_la_LDFLAGS = -module -lmysqlclient
+libgmysqlbackend_la_LDFLAGS = -module -lmysqlclient -avoid-version
all: all-am
.SUFFIXES:
--- pdns-2.9.21/modules/gsqlite3backend/Makefile.in.avoid-version 2007-04-24 09:02:09.000000000 +0200
+++ pdns-2.9.21/modules/gsqlite3backend/Makefile.in 2007-04-24 09:02:24.000000000 +0200
@@ -216,7 +216,7 @@
libgsqlite3backend_la_SOURCES = gsqlite3backend.cc gsqlite3backend.hh \
ssqlite3.hh ssqlite3.cc
-libgsqlite3backend_la_LDFLAGS = -module -lsqlite3
+libgsqlite3backend_la_LDFLAGS = -module -lsqlite3 -avoid-version
all: all-am
.SUFFIXES:
--- pdns-2.9.21/modules/geobackend/Makefile.in.avoid-version 2007-04-24 08:58:20.000000000 +0200
+++ pdns-2.9.21/modules/geobackend/Makefile.in 2007-04-24 08:59:44.000000000 +0200
@@ -213,7 +213,7 @@
EXTRA_DIST = OBJECTFILES OBJECTLIBS
lib_LTLIBRARIES = libgeobackend.la
libgeobackend_la_SOURCES = geobackend.cc geobackend.hh ippreftree.cc ippreftree.hh
-libgeobackend_la_LDFLAGS = -module
+libgeobackend_la_LDFLAGS = -module -avoid-version
all: all-am
.SUFFIXES:

View File

@ -1,33 +0,0 @@
Index: /trunk/pdns/pdns/packethandler.cc
===================================================================
--- /trunk/pdns/pdns/packethandler.cc (revision 1079)
+++ /trunk/pdns/pdns/packethandler.cc (revision 1081)
@@ -399,6 +399,8 @@
}
}
- if(hits && !found && !rfound && shortcut ) // we found matching qnames but not a qtype
+ if(hits && !found && !rfound && shortcut ) { // we found matching qnames but not a qtype
+ DLOG(L<<"Found matching qname, but not the qtype"<<endl);
return 2;
+ }
if(rfound)
@@ -654,4 +656,5 @@
if(mret==2) { // there is some data, but not of the correct type
+ r->clearRecords();
DLOG(L<<"There is some data, but not of the correct type, adding SOA for NXRECORDSET"<<endl);
SOAData sd;
@@ -696,5 +699,4 @@
}
}
-
noSameLevelNS=true;
@@ -739,5 +741,5 @@
// not found yet, try wildcards (we only try here in case of recursion - we should check before we hand off)
- if(p->d.rd && d_doRecursion && d_doWildcards) {
+ if(mret != 2 && p->d.rd && d_doRecursion && d_doWildcards) {
int res=doWildcardRecords(p,r,target);
if(res) { // had a result

View File

@ -1,6 +1,7 @@
--- pdns-2.9.20/pdns/pdns.in.fixinit 2006-12-17 18:14:14.000000000 +0100
+++ pdns-2.9.20/pdns/pdns.in 2006-12-17 18:15:42.000000000 +0100
@@ -47,6 +47,7 @@
diff -up pdns-2.9.22-rc2/pdns/pdns.in.fixinit pdns-2.9.22-rc2/pdns/pdns.in
--- pdns-2.9.22-rc2/pdns/pdns.in.fixinit 2008-02-03 13:14:00.000000000 +0100
+++ pdns-2.9.22-rc2/pdns/pdns.in 2008-12-03 04:07:26.000000000 +0100
@@ -47,6 +47,7 @@ case "$1" in
if test "$NOTRUNNING" = "0"
then
doPC quit
@ -8,7 +9,7 @@
echo $ret
else
echo "not running"
@@ -57,6 +58,7 @@
@@ -57,6 +58,7 @@ case "$1" in
force-stop)
echo -n "Stopping PowerDNS authoritative nameserver: "
killall -v -9 pdns_server
@ -16,7 +17,7 @@
echo "killed"
;;
@@ -69,6 +71,7 @@
@@ -69,6 +71,7 @@ case "$1" in
$pdns_server --daemon --guardian=yes
if test "$?" = "0"
then

View File

@ -1,53 +0,0 @@
diff -up pdns-2.9.21/pdns/misc.hh.orig pdns-2.9.21/pdns/misc.hh
--- pdns-2.9.21/pdns/misc.hh.orig 2008-02-09 15:32:57.000000000 +0100
+++ pdns-2.9.21/pdns/misc.hh 2008-02-09 15:33:23.000000000 +0100
@@ -19,6 +19,7 @@
#ifndef MISC_HH
#define MISC_HH
#include <stdint.h>
+#include <cstring>
#if 0
#define RDTSC(qp) \
@@ -234,7 +235,7 @@ inline bool dns_isspace(char c)
return c==' ' || c=='\t' || c=='\r' || c=='\n';
}
-inline const char dns_tolower(char c)
+inline char dns_tolower(char c)
{
if(c>='A' && c<='Z')
c+='a'-'A';
diff -up pdns-2.9.21/pdns/dns.hh.orig pdns-2.9.21/pdns/dns.hh
--- pdns-2.9.21/pdns/dns.hh.orig 2008-02-09 15:37:26.000000000 +0100
+++ pdns-2.9.21/pdns/dns.hh 2008-02-09 15:37:43.000000000 +0100
@@ -115,7 +115,7 @@ struct EDNS0Record
#pragma pack (pop)
#endif
-typedef enum {
+enum {
ns_t_invalid = 0, /* Cookie. */
ns_t_a = 1, /* Host address. */
ns_t_ns = 2, /* Authoritative server. */
diff -up pdns-2.9.21/modules/ldapbackend/powerldap.cc.orig pdns-2.9.21/modules/ldapbackend/powerldap.cc
--- pdns-2.9.21/modules/ldapbackend/powerldap.cc.orig 2008-02-09 15:41:12.000000000 +0100
+++ pdns-2.9.21/modules/ldapbackend/powerldap.cc 2008-02-09 15:42:17.000000000 +0100
@@ -1,4 +1,6 @@
#include "powerldap.hh"
+// for timeval
+#include <sys/time.h>
diff -up pdns-2.9.21/pdns/dynmessenger.cc.orig pdns-2.9.21/pdns/dynmessenger.cc
--- pdns-2.9.21/pdns/dynmessenger.cc.orig 2008-02-09 15:47:52.000000000 +0100
+++ pdns-2.9.21/pdns/dynmessenger.cc 2008-02-09 15:48:38.000000000 +0100
@@ -18,6 +18,7 @@
*/
#include "dynmessenger.hh"
#include <cstdio>
+#include <cstdlib>
#include <cstring>
#include <cerrno>
#include <iostream>

View File

@ -1,17 +1,15 @@
%define alphatag rc2
Summary: A modern, advanced and high performance authoritative-only nameserver
Name: pdns
Version: 2.9.21.2
Release: 1%{?dist}
Version: 2.9.22
Release: 1.%{alphatag}%{?dist}
Group: System Environment/Daemons
License: GPLv2
URL: http://powerdns.com
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}-%{alphatag}.tar.gz
Patch0: %{name}-fixinit.patch
Patch1: %{name}-avoid-version.patch
Patch2: %{name}-gcc43.patch
Patch3: %{name}-bz461768.patch
Requires(post): %{_sbindir}/useradd, /sbin/chkconfig
Requires(preun): /sbin/service, /sbin/chkconfig
@ -81,11 +79,8 @@ This package contains the SQLite backend for %{name}
%prep
%setup -q
%setup -q -n %{name}-%{version}-%{alphatag}
%patch0 -p1 -b .fixinit
%patch1 -p1 -b .avoid-version
%patch2 -p1
%patch3 -p3
%build
export CPPFLAGS="-DLDAP_DEPRECATED %{optflags}"
@ -185,6 +180,10 @@ fi
%changelog
* Wed Dec 03 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> 2.9.22-1.rc2
- Upstream releasd new release candidate
- Drop patches which are upstreamed
* Mon Nov 17 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> 2.9.21.2-1
- Upstream released new version

View File

@ -1 +1 @@
2aa79c1d120a071298340ed2d4e02165 pdns-2.9.21.2.tar.gz
f9b834fb313145604f417ceff1506601 pdns-2.9.22-rc2.tar.gz