Update to 3.4.0-rc1
This commit is contained in:
parent
c6b41b91c0
commit
70f51f8b8b
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ pdns-2.9.22.tar.gz
|
||||
/pdns-3.3-rc2.tar.gz
|
||||
/pdns-3.3.tar.gz
|
||||
/pdns-3.3.1.tar.gz
|
||||
/pdns-3.4.0-rc1.tar.bz2
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- pdns-3.3-rc2/pdns/pdns.conf-dist.orig 2013-06-14 11:51:22.000000000 +0200
|
||||
+++ pdns-3.3-rc2/pdns/pdns.conf-dist 2013-06-28 13:45:37.307992960 +0200
|
||||
--- pdns-3.4.0-rc1/pdns/pdns.conf-dist.orig 2014-07-31 21:42:05.000000000 +0200
|
||||
+++ pdns-3.4.0-rc1/pdns/pdns.conf-dist 2014-08-01 14:02:00.238999673 +0200
|
||||
@@ -1,3 +1,6 @@
|
||||
+setuid=pdns
|
||||
+setgid=pdns
|
||||
+launch=bind
|
||||
# Autogenerated configuration file template
|
||||
#################################
|
||||
# add-superfluous-nsec3-for-old-bind Add superfluous NSEC3 record to positive wildcard response
|
||||
# allow-axfr-ips Allow zonetransfers only to these subnets
|
||||
|
@ -9,6 +9,7 @@ ExecStop=/usr/bin/pdns_control quit
|
||||
Restart=on-failure
|
||||
RestartSec=2
|
||||
PrivateTmp=true
|
||||
KillMode=none
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
|
41
pdns.spec
41
pdns.spec
@ -1,14 +1,15 @@
|
||||
%global _hardened_build 1
|
||||
%global backends %{nil}
|
||||
%global prever rc1
|
||||
|
||||
Name: pdns
|
||||
Version: 3.3.1
|
||||
Release: 3%{?dist}
|
||||
Version: 3.4.0
|
||||
Release: 0.1.%{?prever}%{?dist}
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv2
|
||||
URL: http://powerdns.com
|
||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
|
||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}-%{?prever}.tar.bz2
|
||||
Source1: pdns.service
|
||||
Patch0: pdns-default-config.patch
|
||||
|
||||
@ -119,26 +120,21 @@ BuildRequires: sqlite-devel
|
||||
This package contains the SQLite backend for %{name}
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n %{name}-%{version}-%{?prever}
|
||||
%patch0 -p1 -b .default-config-patch
|
||||
|
||||
# No inclusion of pre-built binaries or libraries
|
||||
rm -rf pdns/ext/polarssl-*
|
||||
|
||||
%build
|
||||
export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
|
||||
%configure \
|
||||
--sysconfdir=%{_sysconfdir}/%{name} \
|
||||
--libdir=%{_libdir}/%{name} \
|
||||
--disable-static \
|
||||
--with-modules='' \
|
||||
--with-system-polarssl \
|
||||
--with-system-polarssl \
|
||||
--with-lua \
|
||||
--with-dynmodules='%{backends}' \
|
||||
--enable-cryptopp \
|
||||
--enable-tools \
|
||||
--enable-remotebackend-http
|
||||
--enable-tools
|
||||
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
@ -146,9 +142,11 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
%{__rm} -f %{buildroot}%{_libdir}/%{name}/*.la
|
||||
%{__rm} -rf %{buildroot}%{_docdir}
|
||||
%{__mv} %{buildroot}%{_sysconfdir}/%{name}/pdns.conf{-dist,}
|
||||
|
||||
chmod 600 %{buildroot}%{_sysconfdir}/%{name}/pdns.conf
|
||||
@ -205,23 +203,27 @@ exit 0
|
||||
%{_bindir}/dnsreplay
|
||||
%{_bindir}/dnsscan
|
||||
%{_bindir}/dnsscope
|
||||
%{_bindir}/dnsdist
|
||||
%{_bindir}/dnstcpbench
|
||||
%{_bindir}/dnswasher
|
||||
%{_bindir}/nproxy
|
||||
%{_bindir}/nsec3dig
|
||||
%{_bindir}/saxfr
|
||||
%{_mandir}/man8/dnsreplay.8.gz
|
||||
%{_mandir}/man8/dnsscope.8.gz
|
||||
%{_mandir}/man8/dnswasher.8.gz
|
||||
%{_mandir}/man1/dnstcpbench.1.gz
|
||||
|
||||
%files backend-mysql
|
||||
%doc pdns/dnssec.schema.mysql.sql
|
||||
%doc pdns/no-dnssec.schema.mysql.sql
|
||||
%doc modules/gmysqlbackend/schema.mysql.sql
|
||||
%doc modules/gmysqlbackend/dnssec-3.x_to_3.4.0_schema.mysql.sql
|
||||
%doc modules/gmysqlbackend/nodnssec-3.x_to_3.4.0_schema.mysql.sql
|
||||
%{_libdir}/%{name}/libgmysqlbackend.so
|
||||
|
||||
%files backend-postgresql
|
||||
%doc pdns/dnssec.schema.pgsql.sql
|
||||
%doc pdns/no-dnssec.schema.pgsql.sql
|
||||
%doc modules/gpgsqlbackend/schema.pgsql.sql
|
||||
%doc modules/gpgsqlbackend/dnssec-3.x_to_3.4.0_schema.pgsql.sql
|
||||
%doc modules/gpgsqlbackend/nodnssec-3.x_to_3.4.0_schema.pgsql.sql
|
||||
%{_libdir}/%{name}/libgpgsqlbackend.so
|
||||
|
||||
%files backend-pipe
|
||||
@ -241,12 +243,15 @@ exit 0
|
||||
%{_libdir}/%{name}/libluabackend.so
|
||||
|
||||
%files backend-sqlite
|
||||
%doc pdns/dnssec.schema.sqlite3.sql
|
||||
%doc pdns/no-dnssec.schema.sqlite3.sql
|
||||
%doc pdns/bind-dnssec.schema.sqlite3.sql
|
||||
%doc modules/gsqlite3backend/schema.sqlite3.sql
|
||||
%doc modules/gsqlite3backend/dnssec-3.x_to_3.4.0_schema.sqlite3.sql
|
||||
%doc modules/gsqlite3backend/nodnssec-3.x_to_3.4.0_schema.sqlite3.sql
|
||||
%{_libdir}/%{name}/libgsqlite3backend.so
|
||||
|
||||
%changelog
|
||||
* Fri Aug 01 2014 Morten Stevens <mstevens@imt-systems.com> - 3.4.0-0.1.rc1
|
||||
- Update to 3.4.0-rc1
|
||||
|
||||
* Mon Jul 14 2014 Morten Stevens <mstevens@imt-systems.com> - 3.3.1-3
|
||||
- Rebuild for PolarSSL 1.3.8
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user