Update to 3.2
This commit is contained in:
parent
5d439e7f0a
commit
5a1e495a9b
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ pdns-2.9.22.tar.gz
|
||||
/pdns-3.0.tar.gz
|
||||
/pdns-3.0.1.tar.gz
|
||||
/pdns-3.1.tar.gz
|
||||
/pdns-3.2.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -up pdns-2.9.22-rc2/pdns/pdns.in.fixinit pdns-2.9.22-rc2/pdns/pdns.in
|
||||
--- pdns-2.9.22-rc2/pdns/pdns.in.fixinit 2008-02-03 13:14:00.000000000 +0100
|
||||
+++ pdns-2.9.22-rc2/pdns/pdns.in 2008-12-03 04:07:26.000000000 +0100
|
||||
@@ -47,6 +47,7 @@ case "$1" in
|
||||
if test "$NOTRUNNING" = "0"
|
||||
then
|
||||
doPC quit
|
||||
+ rm -f /var/lock/subsys/pdns
|
||||
echo $ret
|
||||
else
|
||||
echo "not running"
|
||||
@@ -57,6 +58,7 @@ case "$1" in
|
||||
force-stop)
|
||||
echo -n "Stopping PowerDNS authoritative nameserver: "
|
||||
killall -v -9 pdns_server
|
||||
+ rm -f /var/lock/subsys/pdns
|
||||
echo "killed"
|
||||
;;
|
||||
|
||||
@@ -69,6 +71,7 @@ case "$1" in
|
||||
$pdns_server --daemon --guardian=yes
|
||||
if test "$?" = "0"
|
||||
then
|
||||
+ touch /var/lock/subsys/pdns
|
||||
echo "started"
|
||||
fi
|
||||
fi
|
@ -1,11 +0,0 @@
|
||||
--- pdns-3.1/pdns/receiver.cc.orig 2012-05-04 12:13:23.000000000 +0200
|
||||
+++ pdns-3.1/pdns/receiver.cc 2012-09-22 01:19:23.081002321 +0200
|
||||
@@ -117,7 +117,7 @@ static void takedown(int i)
|
||||
if(cpid) {
|
||||
L<<Logger::Error<<"Guardian is killed, taking down children with us"<<endl;
|
||||
kill(cpid,SIGKILL);
|
||||
- exit(1);
|
||||
+ exit(0);
|
||||
}
|
||||
}
|
||||
|
22
pdns.spec
22
pdns.spec
@ -1,16 +1,15 @@
|
||||
%global backends %{nil}
|
||||
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
Name: pdns
|
||||
Version: 3.1
|
||||
Release: 7%{?dist}
|
||||
License: GPLv2
|
||||
Version: 3.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv2
|
||||
URL: http://powerdns.com
|
||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
|
||||
Source1: pdns.service
|
||||
Patch0: pdns-default-config.patch
|
||||
Patch1: pdns-return-exit0.patch
|
||||
|
||||
Requires(pre): shadow-utils
|
||||
Requires(post): systemd-sysv
|
||||
@ -18,7 +17,6 @@ Requires(post): systemd-units
|
||||
Requires(preun): systemd-units
|
||||
Requires(postun): systemd-units
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: systemd-units
|
||||
BuildRequires: boost-devel
|
||||
BuildRequires: lua-devel
|
||||
@ -94,7 +92,6 @@ This package contains the SQLite backend for %{name}
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .default-config-patch
|
||||
%patch1 -p1 -b .return-exit0
|
||||
|
||||
%build
|
||||
export CPPFLAGS="-DLDAP_DEPRECATED %{optflags}"
|
||||
@ -121,13 +118,6 @@ make install DESTDIR=%{buildroot}
|
||||
|
||||
chmod 600 %{buildroot}%{_sysconfdir}/%{name}/pdns.conf
|
||||
|
||||
# strip the static rpath from the binaries
|
||||
chrpath --delete %{buildroot}%{_bindir}/pdns_control
|
||||
chrpath --delete %{buildroot}%{_bindir}/zone2ldap
|
||||
chrpath --delete %{buildroot}%{_bindir}/zone2sql
|
||||
chrpath --delete %{buildroot}%{_sbindir}/pdns_server
|
||||
chrpath --delete %{buildroot}%{_libdir}/%{name}/*.so
|
||||
|
||||
# Copy systemd service file
|
||||
install -p -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/pdns.service
|
||||
|
||||
@ -165,6 +155,7 @@ exit 0
|
||||
%{_bindir}/pdnssec
|
||||
%{_bindir}/zone2ldap
|
||||
%{_bindir}/zone2sql
|
||||
%{_bindir}/zone2json
|
||||
%{_sbindir}/pdns_server
|
||||
%{_mandir}/man8/pdns_control.8.gz
|
||||
%{_mandir}/man8/pdns_server.8.gz
|
||||
@ -207,6 +198,9 @@ exit 0
|
||||
%doc pdns/bind-dnssec.schema.sqlite3.sql
|
||||
|
||||
%changelog
|
||||
* Thu Jan 17 2013 Morten Stevens <mstevens@imt-systems.com> - 3.2-1
|
||||
- Update to 3.2
|
||||
|
||||
* Mon Jan 07 2013 Morten Stevens <mstevens@imt-systems.com> - 3.1-7
|
||||
- Disable pdns guardian by default (rhbz#883852)
|
||||
- Drop backend MongoDB as it does not work (upstream commit 3017)
|
||||
|
Loading…
x
Reference in New Issue
Block a user