Update to 4.0.0
This commit is contained in:
parent
e66ad320c6
commit
3dad03f18c
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@ pdns-2.9.22.tar.gz
|
||||
/pdns-4.2.1.tar.bz2
|
||||
/pdns-4.3.0.tar.bz2
|
||||
/pdns-4.3.1.tar.bz2
|
||||
/pdns-4.4.0.tar.bz2
|
||||
|
@ -1,59 +0,0 @@
|
||||
diff --git a/pdns/ixfrdist-web.cc b/pdns/ixfrdist-web.cc
|
||||
index dababdc3fd..ebc456cedb 100644
|
||||
--- a/pdns/ixfrdist-web.cc
|
||||
+++ b/pdns/ixfrdist-web.cc
|
||||
@@ -30,7 +30,7 @@ IXFRDistWebServer::IXFRDistWebServer(const ComboAddress &listenAddress, const Ne
|
||||
{
|
||||
d_ws->setACL(acl);
|
||||
d_ws->setLogLevel(loglevel);
|
||||
- d_ws->registerWebHandler("/metrics", boost::bind(&IXFRDistWebServer::getMetrics, this, _1, _2));
|
||||
+ d_ws->registerWebHandler("/metrics", std::bind(&IXFRDistWebServer::getMetrics, this, std::placeholders::_1, std::placeholders::_2));
|
||||
d_ws->bind();
|
||||
}
|
||||
|
||||
diff --git a/pdns/webserver.cc b/pdns/webserver.cc
|
||||
index eafd3059a0..b47cc6d7e0 100644
|
||||
--- a/pdns/webserver.cc
|
||||
+++ b/pdns/webserver.cc
|
||||
@@ -107,7 +107,7 @@ static void bareHandlerWrapper(WebServer::HandlerFunction handler, YaHTTP::Reque
|
||||
|
||||
void WebServer::registerBareHandler(const string& url, HandlerFunction handler)
|
||||
{
|
||||
- YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, _1, _2);
|
||||
+ YaHTTP::THandlerFunction f = std::bind(&bareHandlerWrapper, handler, std::placeholders::_1, std::placeholders::_2);
|
||||
YaHTTP::Router::Any(url, f);
|
||||
}
|
||||
|
||||
@@ -179,7 +179,7 @@ void WebServer::apiWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
|
||||
}
|
||||
|
||||
void WebServer::registerApiHandler(const string& url, HandlerFunction handler, bool allowPassword) {
|
||||
- HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, _1, _2, allowPassword);
|
||||
+ HandlerFunction f = std::bind(&WebServer::apiWrapper, this, handler, std::placeholders::_1, std::placeholders::_2, allowPassword);
|
||||
registerBareHandler(url, f);
|
||||
}
|
||||
|
||||
@@ -196,7 +196,7 @@ void WebServer::webWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
|
||||
}
|
||||
|
||||
void WebServer::registerWebHandler(const string& url, HandlerFunction handler) {
|
||||
- HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, _1, _2);
|
||||
+ HandlerFunction f = std::bind(&WebServer::webWrapper, this, handler, std::placeholders::_1, std::placeholders::_2);
|
||||
registerBareHandler(url, f);
|
||||
}
|
||||
|
||||
diff --git a/pdns/ws-auth.cc b/pdns/ws-auth.cc
|
||||
index 22c54dae28..c3ca5c29ae 100644
|
||||
--- a/pdns/ws-auth.cc
|
||||
+++ b/pdns/ws-auth.cc
|
||||
@@ -2328,8 +2328,8 @@ void AuthWebServer::webThread()
|
||||
d_ws->registerApiHandler("/api", &apiDiscovery);
|
||||
}
|
||||
if (::arg().mustDo("webserver")) {
|
||||
- d_ws->registerWebHandler("/style.css", boost::bind(&AuthWebServer::cssfunction, this, _1, _2));
|
||||
- d_ws->registerWebHandler("/", boost::bind(&AuthWebServer::indexfunction, this, _1, _2));
|
||||
+ d_ws->registerWebHandler("/style.css", std::bind(&AuthWebServer::cssfunction, this, std::placeholders::_1, std::placeholders::_2));
|
||||
+ d_ws->registerWebHandler("/", std::bind(&AuthWebServer::indexfunction, this, std::placeholders::_1, std::placeholders::_2));
|
||||
}
|
||||
d_ws->go();
|
||||
}
|
14
pdns.spec
14
pdns.spec
@ -2,15 +2,14 @@
|
||||
%global backends %{nil}
|
||||
|
||||
Name: pdns
|
||||
Version: 4.3.1
|
||||
Release: 3%{?dist}
|
||||
Version: 4.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
License: GPLv2
|
||||
URL: http://powerdns.com
|
||||
Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
|
||||
Patch0: pdns-disable-secpoll.patch
|
||||
Patch1: pdns-boost173.patch
|
||||
Patch2: pdns-gcc11.patch
|
||||
Patch1: pdns-gcc11.patch
|
||||
|
||||
Requires(pre): shadow-utils
|
||||
Requires(post): systemd-units
|
||||
@ -188,10 +187,6 @@ getent passwd pdns >/dev/null || \
|
||||
exit 0
|
||||
|
||||
%post
|
||||
# Update file permissions to root:pdns
|
||||
chown -R root:pdns %{_sysconfdir}/%{name}
|
||||
chmod 640 %{_sysconfdir}/%{name}/%{name}.conf
|
||||
|
||||
%systemd_post pdns.service
|
||||
|
||||
%preun
|
||||
@ -315,6 +310,9 @@ chmod 640 %{_sysconfdir}/%{name}/%{name}.conf
|
||||
%{_unitdir}/ixfrdist@.service
|
||||
|
||||
%changelog
|
||||
* Mon Dec 21 2020 Morten Stevens <mstevens@fedoraproject.org> - 4.4.0-1
|
||||
- Update to 4.4.0
|
||||
|
||||
* Sat Dec 05 2020 Jeff Law <law@redhat.com> - 4.3.1-3
|
||||
- Fix missing #include for gcc-11
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pdns-4.3.1.tar.bz2) = e61e23544f1e57c1ec3a85b4edbc3ff3e8e831410237afdc8896e9f34602774c1dc8bd02eb7440e765262fcc988f98e47b6f1b7945427b1f4a59dd6b84b9437e
|
||||
SHA512 (pdns-4.4.0.tar.bz2) = e7f35539915ee7945b537cfedae72e2b83c86b39c5e44a9268b8a086f44b30a33a64e0b65aad140ba02c349cedaa12820226578dea87c9b666dc75f8bd15c1f6
|
||||
|
Loading…
x
Reference in New Issue
Block a user