Update 4.0.0 RC2
This commit is contained in:
parent
00d5351aea
commit
22d729b651
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@ pdns-2.9.22.tar.gz
|
||||
/pdns-4.0.0-alpha2.tar.bz2
|
||||
/pdns-4.0.0-alpha3.tar.bz2
|
||||
/pdns-4.0.0-beta1.tar.bz2
|
||||
/pdns-4.0.0-rc2.tar.bz2
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- pdns-4.0.0-alpha3/pdns/common_startup.cc.orig 2016-05-11 10:53:40.000000000 +0200
|
||||
+++ pdns-4.0.0-alpha3/pdns/common_startup.cc 2016-05-13 15:20:11.492746860 +0200
|
||||
@@ -182,7 +182,7 @@ void declareArguments()
|
||||
--- pdns-4.0.0-rc1/pdns/common_startup.cc.orig 2016-06-29 11:43:23.000000000 +0200
|
||||
+++ pdns-4.0.0-rc1/pdns/common_startup.cc 2016-06-29 14:50:11.915033803 +0200
|
||||
@@ -183,7 +183,7 @@ void declareArguments()
|
||||
::arg().set("max-nsec3-iterations","Limit the number of NSEC3 hash iterations")="500"; // RFC5155 10.3
|
||||
|
||||
::arg().set("include-dir","Include *.conf files from this directory");
|
||||
@ -8,4 +8,4 @@
|
||||
+ ::arg().set("security-poll-suffix","Domain name from which to query security update notifications")="";
|
||||
|
||||
::arg().setSwitch("outgoing-axfr-expand-alias", "Expand ALIAS records during outgoing AXFR")="no";
|
||||
}
|
||||
::arg().setSwitch("8bit-dns", "Allow 8bit dns queries")="no";
|
||||
|
62
pdns.spec
62
pdns.spec
@ -1,10 +1,10 @@
|
||||
%global _hardened_build 1
|
||||
%global backends %{nil}
|
||||
%global prever beta1
|
||||
%global prever rc2
|
||||
|
||||
Name: pdns
|
||||
Version: 4.0.0
|
||||
Release: 0.7.%{?prever}%{?dist}
|
||||
Release: 0.8.%{?prever}%{?dist}
|
||||
Summary: A modern, advanced and high performance authoritative-only nameserver
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv2
|
||||
@ -24,6 +24,8 @@ BuildRequires: lua-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: zeromq-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: protobuf-devel
|
||||
BuildRequires: protobuf-compiler
|
||||
Provides: powerdns = %{version}-%{release}
|
||||
%global backends %{backends} bind
|
||||
|
||||
@ -163,7 +165,6 @@ export CPPFLAGS="-DLDAP_DEPRECATED"
|
||||
--with-lua \
|
||||
--with-dynmodules='%{backends}' \
|
||||
--enable-tools \
|
||||
--without-protobuf \
|
||||
--enable-remotebackend-zeromq \
|
||||
--enable-unit-tests
|
||||
|
||||
@ -178,8 +179,8 @@ make install DESTDIR=%{buildroot}
|
||||
chmod 600 %{buildroot}%{_sysconfdir}/%{name}/pdns.conf
|
||||
|
||||
# rename zone2ldap to pdns-zone2ldap (#1193116)
|
||||
%{__mv} %{buildroot}/%{_bindir}/zone2ldap %{buildroot}/%{_bindir}/pdns-zone2ldap
|
||||
%{__mv} %{buildroot}/%{_mandir}/man1/zone2ldap.1 %{buildroot}/%{_mandir}/man1/pdns-zone2ldap.1
|
||||
%{__mv} %{buildroot}/%{_bindir}/zone2ldap %{buildroot}/%{_bindir}/pdns_zone2ldap
|
||||
%{__mv} %{buildroot}/%{_mandir}/man1/zone2ldap.1 %{buildroot}/%{_mandir}/man1/pdns_zone2ldap.1
|
||||
|
||||
# Copy systemd service file
|
||||
install -p -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/pdns.service
|
||||
@ -216,54 +217,56 @@ exit 0
|
||||
%files
|
||||
%doc COPYING README
|
||||
%{_bindir}/pdns_control
|
||||
%{_bindir}/pdns-zone2ldap
|
||||
%{_bindir}/pdnsutil
|
||||
%{_bindir}/pdns_zone2ldap
|
||||
%{_bindir}/zone2sql
|
||||
%{_bindir}/zone2json
|
||||
%{_bindir}/calidns
|
||||
%{_bindir}/dnsgram
|
||||
%{_bindir}/dumresp
|
||||
%{_bindir}/ixplore
|
||||
%{_bindir}/notify
|
||||
%{_bindir}/pdnsutil
|
||||
%{_bindir}/sdig
|
||||
%{_sbindir}/pdns_server
|
||||
%{_libdir}/%{name}/libbindbackend.so
|
||||
%{_mandir}/man1/pdns_control.1.gz
|
||||
%{_mandir}/man1/pdns_server.1.gz
|
||||
%{_mandir}/man1/zone2json.1.gz
|
||||
%{_mandir}/man1/zone2sql.1.gz
|
||||
%{_mandir}/man1/pdns-zone2ldap.1.gz
|
||||
%{_mandir}/man1/dnsbulktest.1.gz
|
||||
%{_mandir}/man1/dnsgram.1.gz
|
||||
%{_mandir}/man1/dnsscan.1.gz
|
||||
%{_mandir}/man1/ixplore.1.gz
|
||||
%{_mandir}/man1/nsec3dig.1.gz
|
||||
%{_mandir}/man1/zone2json.1.gz
|
||||
%{_mandir}/man1/pdns_zone2ldap.1.gz
|
||||
%{_mandir}/man1/pdnsutil.1.gz
|
||||
%{_mandir}/man1/saxfr.1.gz
|
||||
%{_mandir}/man1/sdig.1.gz
|
||||
%{_mandir}/man1/calidns.1.gz
|
||||
%{_mandir}/man1/dumresp.1.gz
|
||||
%{_mandir}/man1/notify.1.gz
|
||||
%{_mandir}/man1/nproxy.1.gz
|
||||
%{_unitdir}/pdns.service
|
||||
%{_libdir}/%{name}/libbindbackend.so
|
||||
%dir %{_libdir}/%{name}/
|
||||
%dir %{_sysconfdir}/%{name}/
|
||||
%config(noreplace) %{_sysconfdir}/%{name}/pdns.conf
|
||||
|
||||
%files tools
|
||||
%{_bindir}/calidns
|
||||
%{_bindir}/dnsbulktest
|
||||
%{_bindir}/dnsgram
|
||||
%{_bindir}/dnspcap2protobuf
|
||||
%{_bindir}/dnsreplay
|
||||
%{_bindir}/dnsscan
|
||||
%{_bindir}/dnsscope
|
||||
%{_bindir}/dnstcpbench
|
||||
%{_bindir}/dnswasher
|
||||
%{_bindir}/dumresp
|
||||
%{_bindir}/ixplore
|
||||
%{_bindir}/pdns_notify
|
||||
%{_bindir}/nproxy
|
||||
%{_bindir}/nsec3dig
|
||||
%{_bindir}/saxfr
|
||||
%{_bindir}/sdig
|
||||
%{_mandir}/man1/calidns.1.gz
|
||||
%{_mandir}/man1/dnsbulktest.1.gz
|
||||
%{_mandir}/man1/dnsgram.1.gz
|
||||
%{_mandir}/man1/dnspcap2protobuf.1.gz
|
||||
%{_mandir}/man1/dnsreplay.1.gz
|
||||
%{_mandir}/man1/dnsscan.1.gz
|
||||
%{_mandir}/man1/dnsscope.1.gz
|
||||
%{_mandir}/man1/dnswasher.1.gz
|
||||
%{_mandir}/man1/dnstcpbench.1.gz
|
||||
%{_mandir}/man1/dnswasher.1.gz
|
||||
%{_mandir}/man1/dumresp.1.gz
|
||||
%{_mandir}/man1/ixplore.1.gz
|
||||
%{_mandir}/man1/pdns_notify.1.gz
|
||||
%{_mandir}/man1/nproxy.1.gz
|
||||
%{_mandir}/man1/nsec3dig.1.gz
|
||||
%{_mandir}/man1/saxfr.1.gz
|
||||
%{_mandir}/man1/sdig.1.gz
|
||||
|
||||
%files backend-mysql
|
||||
%{_pkgdocdir}/schema.mysql.sql
|
||||
@ -309,6 +312,9 @@ exit 0
|
||||
%{_libdir}/%{name}/libtinydnsbackend.so
|
||||
|
||||
%changelog
|
||||
* Wed Jun 29 2016 Morten Stevens <mstevens@fedoraproject.org> - 4.0.0-0.8.rc2
|
||||
- Update to 4.0.0 RC2
|
||||
|
||||
* Fri May 27 2016 Morten Stevens <mstevens@fedoraproject.org> - 4.0.0-0.7.beta1
|
||||
- Update to 4.0.0 beta 1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user