Rebuild for poppler-21.01.0

This commit is contained in:
Marek Kasik 2021-01-19 13:38:35 +01:00
parent cfb1013e04
commit e30de2fbea
2 changed files with 86 additions and 2 deletions

View File

@ -1,11 +1,12 @@
Name: pdf2djvu
Version: 0.9.17.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: PDF to DjVu converter
License: GPLv2+
URL: http://jwilk.net/software/pdf2djvu
Source0: https://github.com/jwilk/%{name}/releases/download/%{version}/%{name}-%{version}.tar.xz
BuildRequires: make
Patch0: poppler-splash.patch
BuildRequires: make
BuildRequires: gcc-c++
BuildRequires: djvulibre-devel djvulibre
BuildRequires: libjpeg-devel
@ -48,6 +49,9 @@ install -p -m 644 -D {doc,%{buildroot}%{_mandir}/man1}/%{name}.1
%{_mandir}/ru/man1/%{name}.1*
%changelog
* Tue Jan 19 2021 Marek Kasik <mkasik@redhat.com> - 0.9.17.1-2
- Rebuild for poppler-21.01.0
* Fri Jan 1 2021 Filipe Rosset <rosset.filipe@gmail.com> - 0.9.17.1-1
- Update to 0.9.17.1 fixes rhbz#1805167

80
poppler-splash.patch Normal file
View File

@ -0,0 +1,80 @@
--- pdf2djvu-0.9.17.1/configure.ac
+++ pdf2djvu-0.9.17.1/configure.ac
@@ -73,8 +73,8 @@ do
done
AC_MSG_RESULT([ok])
-PKG_CHECK_MODULES([POPPLER], [poppler-splash >= 0.35.0])
-poppler_version=$($PKG_CONFIG --modversion poppler-splash)
+PKG_CHECK_MODULES([POPPLER], [poppler >= 0.35.0])
+poppler_version=$($PKG_CONFIG --modversion poppler)
AC_DEFINE_UNQUOTED([POPPLER_VERSION_STRING], ["$poppler_version"], [Define to the version of Poppler])
parse_poppler_version()
{
--- pdf2djvu-0.9.17.1/configure
+++ pdf2djvu-0.9.17.1/configure
@@ -4006,19 +4006,19 @@ $as_echo "ok" >&6; }
pkg_failed=no
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for poppler-splash >= 0.35.0" >&5
-$as_echo_n "checking for poppler-splash >= 0.35.0... " >&6; }
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for poppler >= 0.35.0" >&5
+$as_echo_n "checking for poppler >= 0.35.0... " >&6; }
if test -n "$POPPLER_CFLAGS"; then
pkg_cv_POPPLER_CFLAGS="$POPPLER_CFLAGS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"poppler-splash >= 0.35.0\""; } >&5
- ($PKG_CONFIG --exists --print-errors "poppler-splash >= 0.35.0") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"poppler >= 0.35.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "poppler >= 0.35.0") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_POPPLER_CFLAGS=`$PKG_CONFIG --cflags "poppler-splash >= 0.35.0" 2>/dev/null`
+ pkg_cv_POPPLER_CFLAGS=`$PKG_CONFIG --cflags "poppler >= 0.35.0" 2>/dev/null`
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
@@ -4030,12 +4030,12 @@ if test -n "$POPPLER_LIBS"; then
pkg_cv_POPPLER_LIBS="$POPPLER_LIBS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"poppler-splash >= 0.35.0\""; } >&5
- ($PKG_CONFIG --exists --print-errors "poppler-splash >= 0.35.0") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"poppler >= 0.35.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "poppler >= 0.35.0") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_POPPLER_LIBS=`$PKG_CONFIG --libs "poppler-splash >= 0.35.0" 2>/dev/null`
+ pkg_cv_POPPLER_LIBS=`$PKG_CONFIG --libs "poppler >= 0.35.0" 2>/dev/null`
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
@@ -4058,12 +4058,12 @@ fi
if test $_pkg_short_errors_supported = yes; then
POPPLER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "poppler-splash >= 0.35.0" 2>&1`
else
- POPPLER_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "poppler-splash >= 0.35.0" 2>&1`
+ POPPLER_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "poppler >= 0.35.0" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
echo "$POPPLER_PKG_ERRORS" >&5
- as_fn_error $? "Package requirements (poppler-splash >= 0.35.0) were not met:
+ as_fn_error $? "Package requirements (poppler >= 0.35.0) were not met:
$POPPLER_PKG_ERRORS
@@ -4095,7 +4095,7 @@ else
$as_echo "yes" >&6; }
fi
-poppler_version=$($PKG_CONFIG --modversion poppler-splash)
+poppler_version=$($PKG_CONFIG --modversion poppler)
cat >>confdefs.h <<_ACEOF
#define POPPLER_VERSION_STRING "$poppler_version"