Update to 1.6.2

This commit is contained in:
Kalev Lember 2010-08-04 14:58:05 +03:00
parent d29d9c761c
commit 6c6652d125
5 changed files with 9 additions and 124 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
pcsc-lite-1.6.1.tar.bz2
pcsc-lite-1.6.2.tar.bz2

View File

@ -1,98 +0,0 @@
Index: src/pcscdaemon.c
===================================================================
--- src/pcscdaemon.c (revision 5058)
+++ src/pcscdaemon.c (working copy)
@@ -523,7 +523,7 @@
}
else
{
- rv = RFStartSerialReaders(PCSCLITE_READER_CONFIG);
+ rv = RFStartSerialReaders(PCSCLITE_CONFIG_DIR);
if (rv == -1)
at_exit();
}
Index: src/pcscd.h.in
===================================================================
--- src/pcscd.h.in (revision 5058)
+++ src/pcscd.h.in (working copy)
@@ -23,12 +23,11 @@
#define SCARD_INSERTED 0x0002 /**< Card was inserted */
#define SCARD_REMOVED 0x0004 /**< Card was removed */
-#define PCSCLITE_CONFIG_DIR "@sysconfdir_exp@"
+#define PCSCLITE_CONFIG_DIR "@PCSCLITE_CONFIG_DIR@"
#define PCSCLITE_IPC_DIR USE_IPCDIR
#define PCSCLITE_RUN_PID PCSCLITE_IPC_DIR "/pcscd.pid"
-#define PCSCLITE_READER_CONFIG PCSCLITE_CONFIG_DIR "/reader.conf"
#define PCSCLITE_CSOCK_NAME PCSCLITE_IPC_DIR "/pcscd.comm"
#define PCSCLITE_SVC_IDENTITY 0x01030000 /**< Service ID */
Index: src/configfile.l
===================================================================
--- src/configfile.l (revision 5058)
+++ src/configfile.l (working copy)
@@ -238,6 +238,8 @@
/* the configuration file is a directory */
struct dirent *direntry;
+ Log2(PCSC_LOG_DEBUG, "Parsing conf directory: %s", readerconf_dir);
+
/* for each configuration file */
while ((direntry = readdir(dir)) != NULL)
{
Index: configure.in
===================================================================
--- configure.in (revision 5063)
+++ configure.in (working copy)
@@ -332,7 +332,9 @@
AS_AC_EXPAND(sbindir_exp,$sbindir)
AS_AC_EXPAND(localstatedir_exp,$localstatedir)
-PCSCLITE_FEATURES="${PCSCLITE_FEATURES} sysconfdir=${sysconfdir_exp}"
+PCSCLITE_CONFIG_DIR="${sysconfdir_exp}/reader.conf.d"
+AC_SUBST(PCSCLITE_CONFIG_DIR)
+PCSCLITE_FEATURES="${PCSCLITE_FEATURES} configdir=${PCSCLITE_CONFIG_DIR}"
AC_DEFINE_UNQUOTED([PCSCLITE_FEATURES], ["${PCSCLITE_FEATURES}"], [Enabled PC/SC lite features])
PCSCD_BINARY="${sbindir_exp}/pcscd"
AC_DEFINE_UNQUOTED([PCSCD_BINARY], ["$PCSCD_BINARY"], [pcscd filename])
@@ -343,7 +345,7 @@
Version: ${PACKAGE_VERSION}
System binaries: $(eval eval eval echo "${sbindir_exp}")
-Configuration dir: $(eval eval eval echo "${sysconfdir_exp}")
+Configuration dir: ${PCSCLITE_CONFIG_DIR}
Host: ${host}
--- configure.rpath64 2010-06-04 16:00:15.000000000 +0300
+++ configure 2010-07-04 03:46:11.000000000 +0300
@@ -743,6 +604,7 @@
ac_subst_vars='am__EXEEXT_FALSE
am__EXEEXT_TRUE
LTLIBOBJS
+PCSCLITE_CONFIG_DIR
localstatedir_exp
sbindir_exp
sysconfdir_exp
@@ -13108,7 +13237,9 @@
exec_prefix=$exec_prefix_save
-PCSCLITE_FEATURES="${PCSCLITE_FEATURES} sysconfdir=${sysconfdir_exp}"
+PCSCLITE_CONFIG_DIR="${sysconfdir_exp}/reader.conf.d"
+
+PCSCLITE_FEATURES="${PCSCLITE_FEATURES} configdir=${PCSCLITE_CONFIG_DIR}"
cat >>confdefs.h <<_ACEOF
#define PCSCLITE_FEATURES "${PCSCLITE_FEATURES}"
@@ -13127,7 +13258,7 @@
Version: ${PACKAGE_VERSION}
System binaries: $(eval eval eval echo "${sbindir_exp}")
-Configuration dir: $(eval eval eval echo "${sysconfdir_exp}")
+Configuration dir: ${PCSCLITE_CONFIG_DIR}
Host: ${host}

View File

@ -1,12 +0,0 @@
diff -up pcsc-lite-1.6.1/src/readerfactory.c.orig pcsc-lite-1.6.1/src/readerfactory.c
--- pcsc-lite-1.6.1/src/readerfactory.c.orig 2010-07-04 23:42:14.000000000 +0300
+++ pcsc-lite-1.6.1/src/readerfactory.c 2010-07-04 23:42:23.000000000 +0300
@@ -1312,7 +1312,7 @@ void RFCleanupReaders(void)
#ifdef USE_SERIAL
int RFStartSerialReaders(const char *readerconf)
{
- SerialReader *reader_list;
+ SerialReader *reader_list = NULL;
int i, rv;
/* remember the configuration filename for RFReCheckReaderConf() */

View File

@ -1,8 +1,8 @@
%global upstream_build 3298
%global upstream_build 3329
Name: pcsc-lite
Version: 1.6.1
Release: 5%{?dist}
Version: 1.6.2
Release: 1%{?dist}
Summary: PC/SC Lite smart card framework and applications
Group: System Environment/Daemons
@ -12,11 +12,6 @@ Source0: http://alioth.debian.org/download.php/%{upstream_build}/%{name}-
Source1: pcscd.init
Patch0: %{name}-1.4-docinst.patch
Patch1: %{name}-1.5.5-rpath64.patch
# http://lists.drizzle.com/pipermail/muscle/2010-July/008411.html
Patch2: %{name}-1.6.1-config_dir.patch
# http://lists.drizzle.com/pipermail/muscle/2010-July/008413.html
Patch3: %{name}-1.6.1-crash_with_no_conf.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: hal-devel
@ -67,8 +62,6 @@ Requires: %{name}-libs = %{version}-%{release}
%setup -q
%patch0 -p0 -b .docinst
%patch1 -p1 -b .rpath64
%patch2 -p0 -b .config_dir
%patch3 -p1 -b .crash_with_no_conf
# Convert to utf-8
for file in ChangeLog; do
@ -92,9 +85,6 @@ doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
install -dm 755 $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
install -Dpm 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/pcscd
# remove setuid bit
@ -153,6 +143,10 @@ fi
%changelog
* Wed Aug 04 2010 Kalev Lember <kalev@smartlink.ee> - 1.6.2-1
- Update to 1.6.2
- Dropped upstreamed patches
* Thu Jul 08 2010 Kalev Lember <kalev@smartlink.ee> - 1.6.1-5
- Include COPYING in libs subpackage as per new licensing guidelines

View File

@ -1 +1 @@
ed023be61feebfafce12e86075912695 pcsc-lite-1.6.1.tar.bz2
9e979368c2619d0a39e573530630aa95 pcsc-lite-1.6.2.tar.bz2