update to pcp-5.0.1, drop outdated patches
This commit is contained in:
parent
06a055c0b6
commit
df07c2ce3c
@ -1,68 +0,0 @@
|
|||||||
commit f2d39ef808c9a1a395821eec45be17b4f1734d04
|
|
||||||
Author: Miroslav Foltýn <miroslav.foltyn01@upol.cz>
|
|
||||||
Date: Sun Oct 20 00:54:03 2019 +0200
|
|
||||||
|
|
||||||
Removed void casts on Ragel generated variable declarations
|
|
||||||
|
|
||||||
diff --git a/src/pmdas/statsd/src/parser-ragel.rl b/src/pmdas/statsd/src/parser-ragel.rl
|
|
||||||
index 8cb8dda76..3506205c1 100644
|
|
||||||
--- a/src/pmdas/statsd/src/parser-ragel.rl
|
|
||||||
+++ b/src/pmdas/statsd/src/parser-ragel.rl
|
|
||||||
@@ -194,10 +194,6 @@ ragel_parser_parse(char* str, struct statsd_datagram** datagram) {
|
|
||||||
write exec;
|
|
||||||
|
|
||||||
}%%
|
|
||||||
- (void)statsd_en_main;
|
|
||||||
- (void)statsd_error;
|
|
||||||
- (void)statsd_first_final;
|
|
||||||
- (void)_statsd_eof_actions;
|
|
||||||
|
|
||||||
if (any_tags) {
|
|
||||||
char* json = tag_collection_to_json(tags);
|
|
||||||
|
|
||||||
commit 682b26b0b1d0040f267064bf92e0d61eb1771301
|
|
||||||
Author: Miroslav Foltýn <miroslav.foltyn01@upol.cz>
|
|
||||||
Date: Sun Oct 20 01:06:09 2019 +0200
|
|
||||||
|
|
||||||
Removed unnecessary '-C' flag when parsing pmdastatsd ragel-parser
|
|
||||||
|
|
||||||
diff --git a/src/pmdas/statsd/src/GNUmakefile b/src/pmdas/statsd/src/GNUmakefile
|
|
||||||
index 7a9741569..77508b8fc 100644
|
|
||||||
--- a/src/pmdas/statsd/src/GNUmakefile
|
|
||||||
+++ b/src/pmdas/statsd/src/GNUmakefile
|
|
||||||
@@ -81,7 +81,7 @@ install_pcp : install
|
|
||||||
$(OBJECTS): domain.h $(RFILES)
|
|
||||||
|
|
||||||
$(RFILES): $(RAGELTARGET).rl
|
|
||||||
- $(RAGEL) -C $<
|
|
||||||
+ $(RAGEL) $<
|
|
||||||
|
|
||||||
$(VERSION_SCRIPT):
|
|
||||||
$(VERSION_SCRIPT_MAKERULE)
|
|
||||||
|
|
||||||
commit 6f20094e3920c0ba6af818d838668fedd33e5a09
|
|
||||||
Author: Mark Goodwin <mgoodwin@redhat.com>
|
|
||||||
Date: Mon Oct 21 00:56:32 2019 +1100
|
|
||||||
|
|
||||||
pmdastatsd: fix compile warnings in ragel generated code
|
|
||||||
|
|
||||||
Restore the void casts for statsd_en_main, statsd_error and
|
|
||||||
statsd_first_final to fix compiler warnings on rawhide. Only
|
|
||||||
the void cast for _statsd_eof_actions needs to be removed
|
|
||||||
because that variable is no longer generated with the newer
|
|
||||||
version of ragel on rawhide.
|
|
||||||
|
|
||||||
diff --git a/src/pmdas/statsd/src/parser-ragel.rl b/src/pmdas/statsd/src/parser-ragel.rl
|
|
||||||
index 3506205c1..7d0166aa8 100644
|
|
||||||
--- a/src/pmdas/statsd/src/parser-ragel.rl
|
|
||||||
+++ b/src/pmdas/statsd/src/parser-ragel.rl
|
|
||||||
@@ -194,6 +194,9 @@ ragel_parser_parse(char* str, struct statsd_datagram** datagram) {
|
|
||||||
write exec;
|
|
||||||
|
|
||||||
}%%
|
|
||||||
+ (void)statsd_en_main;
|
|
||||||
+ (void)statsd_error;
|
|
||||||
+ (void)statsd_first_final;
|
|
||||||
|
|
||||||
if (any_tags) {
|
|
||||||
char* json = tag_collection_to_json(tags);
|
|
23
pcp.spec
23
pcp.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pcp
|
Name: pcp
|
||||||
Version: 5.0.0
|
Version: 5.0.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: System-level performance monitoring and performance management
|
Summary: System-level performance monitoring and performance management
|
||||||
License: GPLv2+ and LGPLv2+ and CC-BY
|
License: GPLv2+ and LGPLv2+ and CC-BY
|
||||||
URL: https://pcp.io
|
URL: https://pcp.io
|
||||||
@ -8,9 +8,6 @@ URL: https://pcp.io
|
|||||||
%global bintray https://bintray.com/artifact/download
|
%global bintray https://bintray.com/artifact/download
|
||||||
Source0: %{bintray}/pcp/source/pcp-%{version}.src.tar.gz
|
Source0: %{bintray}/pcp/source/pcp-%{version}.src.tar.gz
|
||||||
|
|
||||||
Patch0: pmcd-pmlogger-local-context.patch
|
|
||||||
Patch1: fix-pmdastatsd-build-error.patch
|
|
||||||
|
|
||||||
%if 0%{?fedora} >= 26 || 0%{?rhel} > 7
|
%if 0%{?fedora} >= 26 || 0%{?rhel} > 7
|
||||||
%global __python2 python2
|
%global __python2 python2
|
||||||
%else
|
%else
|
||||||
@ -448,9 +445,6 @@ Requires: pcp = %{version}-%{release}
|
|||||||
Requires: pcp-libs = %{version}-%{release}
|
Requires: pcp-libs = %{version}-%{release}
|
||||||
Requires: pcp-libs-devel = %{version}-%{release}
|
Requires: pcp-libs-devel = %{version}-%{release}
|
||||||
Requires: pcp-devel = %{version}-%{release}
|
Requires: pcp-devel = %{version}-%{release}
|
||||||
%if !%{disable_libuv}
|
|
||||||
Requires: libuv-devel >= 1.0
|
|
||||||
%endif
|
|
||||||
Obsoletes: pcp-gui-testsuite
|
Obsoletes: pcp-gui-testsuite
|
||||||
# The following are inherited from pcp-collector and pcp-monitor,
|
# The following are inherited from pcp-collector and pcp-monitor,
|
||||||
# both of which are now obsoleted by the base pcp package
|
# both of which are now obsoleted by the base pcp package
|
||||||
@ -2080,8 +2074,6 @@ updated policy package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if !%{disable_python2} && 0%{?default_python} != 3
|
%if !%{disable_python2} && 0%{?default_python} != 3
|
||||||
@ -2131,7 +2123,12 @@ rm -rf $RPM_BUILD_ROOT/usr/share/doc/pcp-gui
|
|||||||
desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/pmchart.desktop
|
desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/pmchart.desktop
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# default chkconfig off for Fedora and RHEL
|
%if 0%{?rhel} || 0%{?fedora}
|
||||||
|
# Fedora and RHEL default local only access for pmcd and pmlogger
|
||||||
|
sed -i -e '/^# .*_LOCAL=1/s/^# //' $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/{pmcd,pmlogger}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
# default chkconfig off (all RPM platforms)
|
||||||
for f in $RPM_BUILD_ROOT/%{_initddir}/{pcp,pmcd,pmlogger,pmie,pmmgr,pmproxy}; do
|
for f in $RPM_BUILD_ROOT/%{_initddir}/{pcp,pmcd,pmlogger,pmie,pmmgr,pmproxy}; do
|
||||||
test -f "$f" || continue
|
test -f "$f" || continue
|
||||||
sed -i -e '/^# chkconfig/s/:.*$/: - 95 05/' -e '/^# Default-Start:/s/:.*$/:/' $f
|
sed -i -e '/^# chkconfig/s/:.*$/: - 95 05/' -e '/^# Default-Start:/s/:.*$/:/' $f
|
||||||
@ -3186,6 +3183,10 @@ cd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 04 2019 Nathan Scott <nathans@redhat.com> - 5.0.1-1
|
||||||
|
- Resolve selinux policy issues in PCP tools (BZ 1743040)
|
||||||
|
- Update to latest PCP sources.
|
||||||
|
|
||||||
* Sun Oct 20 2019 Mark Goodwin <mgoodwin@redhat.com> - 5.0.0-2
|
* Sun Oct 20 2019 Mark Goodwin <mgoodwin@redhat.com> - 5.0.0-2
|
||||||
- various spec fixes for pmdastatsd
|
- various spec fixes for pmdastatsd
|
||||||
- add patch1 to fix pmdastatsd build on rawhide
|
- add patch1 to fix pmdastatsd build on rawhide
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/src/pmcd/pmcd.defaults b/src/pmcd/pmcd.defaults
|
|
||||||
index 83ee4d9a9..56e125553 100644
|
|
||||||
--- a/src/pmcd/pmcd.defaults
|
|
||||||
+++ b/src/pmcd/pmcd.defaults
|
|
||||||
@@ -4,7 +4,7 @@
|
|
||||||
# Behaviour regarding listening on external-facing interfaces;
|
|
||||||
# unset PMCD_LOCAL to allow connections from remote hosts.
|
|
||||||
# A value of 0 permits remote connections, 1 permits local only.
|
|
||||||
-# PMCD_LOCAL=1
|
|
||||||
+PMCD_LOCAL=1
|
|
||||||
|
|
||||||
# Max length to which the queue of pending connections may grow
|
|
||||||
# A value of 5 is the default.
|
|
||||||
diff --git a/src/pmlogger/pmlogger.defaults b/src/pmlogger/pmlogger.defaults
|
|
||||||
index 5462403ec..261a79039 100644
|
|
||||||
--- a/src/pmlogger/pmlogger.defaults
|
|
||||||
+++ b/src/pmlogger/pmlogger.defaults
|
|
||||||
@@ -4,7 +4,7 @@
|
|
||||||
# Behaviour regarding listening on external-facing interfaces;
|
|
||||||
# unset PMLOGGER_LOCAL to allow connections from remote hosts.
|
|
||||||
# A value of 0 permits remote connections, 1 permits local only.
|
|
||||||
-# PMLOGGER_LOCAL=1
|
|
||||||
+PMLOGGER_LOCAL=1
|
|
||||||
|
|
||||||
# Max length to which the queue of pending connections may grow
|
|
||||||
# A value of 5 is the default.
|
|
4
sources
4
sources
@ -1,3 +1 @@
|
|||||||
SHA512 (pcp-5.0.0.src.tar.gz) = 4a00b199343fcc33b9e4f262974e9d075892a76af92811428221ea9fbacf479a4852e2734caaff56fa6b492b0440e34db55256c91e4b89a9fe52a775645adf89
|
SHA512 (pcp-5.0.1.src.tar.gz) = 1bdbacdbed504b0e08c65cc532a3cd721c5b61a28a73407d0b9c6bbda11dafffb23185356ae09cd598735073e24408aa240d17801a275b521c3d1b41e1cb3f64
|
||||||
SHA512 (pmcd-pmlogger-local-context.patch) = 8f4b6b49494781d0a711ac27738a75b1adead72cb1baef9a78754686c48ae2d278d691108233e9cf9ad33fede5ba7b7a43f4674205b9bf448f267c844ddc1a01
|
|
||||||
SHA512 (fix-pmdastatsd-build-error.patch) = da6925df7b8bafa898870c73a7f0897b2d80941804252bb42b52554f5d1c4fbef2a60c8eef5d80b8684e53b1c316dd80da043cf3b614d5d5b8a03f7437466e75
|
|
||||||
|
Loading…
Reference in New Issue
Block a user