initial checkin
This commit is contained in:
parent
d5c347b019
commit
22de3fea41
@ -0,0 +1 @@
|
||||
pcmciautils-005.tar.bz2
|
51
pcmciautils-fedora.patch
Normal file
51
pcmciautils-fedora.patch
Normal file
@ -0,0 +1,51 @@
|
||||
--- pcmciautils-005/Makefile.foo 2005-07-08 22:03:40.000000000 -0400
|
||||
+++ pcmciautils-005/Makefile 2005-07-08 22:05:02.000000000 -0400
|
||||
@@ -96,8 +96,7 @@
|
||||
GCC_LIB := $(shell $(CC) -print-libgcc-file-name )
|
||||
|
||||
# use '-Os' optimization if available, else use -O2
|
||||
-OPTIMIZATION := ${shell if $(CC) -Os -S -o /dev/null -xc /dev/null >/dev/null 2>&1; \
|
||||
- then echo "-Os"; else echo "-O2" ; fi}
|
||||
+OPTIMIZATION := $(RPM_OPT_FLAGS)
|
||||
|
||||
# check if compiler option is supported
|
||||
cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; fi;}
|
||||
@@ -134,24 +133,12 @@
|
||||
LIB_PCI_OBJS = -lc -lpci
|
||||
#LDFLAGS =
|
||||
|
||||
-ifeq ($(strip $(V)),false)
|
||||
- QUIET=@$(PWD)/build/ccdv
|
||||
- HOST_PROGS=build/ccdv
|
||||
-else
|
||||
- QUIET=
|
||||
- HOST_PROGS=
|
||||
-endif
|
||||
+QUIET=
|
||||
+HOST_PROGS=
|
||||
|
||||
-# if DEBUG is enabled, then we do not strip or optimize
|
||||
-ifeq ($(strip $(DEBUG)),true)
|
||||
- CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
|
||||
- LDFLAGS += -Wl,-warn-common
|
||||
- STRIPCMD = /bin/true -Since_we_are_debugging
|
||||
-else
|
||||
- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
|
||||
- LDFLAGS += -s -Wl,-warn-common
|
||||
- STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
|
||||
-endif
|
||||
+CFLAGS += $(OPTIMIZATION) -D_GNU_SOURCE
|
||||
+LDFLAGS += -Wl,-warn-common
|
||||
+STRIPCMD = /bin/true
|
||||
|
||||
# if STARTUP is disabled, we can skip a few things
|
||||
ifeq ($(strip $(STARTUP)),false)
|
||||
@@ -165,7 +152,7 @@
|
||||
endif
|
||||
|
||||
|
||||
-all: ccdv $(PCCARDCTL) $(PCMCIA_CHECK_BROKEN_CIS) $(PCMCIA_SOCKET_STARTUP_BUILD)
|
||||
+all: $(PCCARDCTL) $(PCMCIA_CHECK_BROKEN_CIS) $(PCMCIA_SOCKET_STARTUP_BUILD)
|
||||
|
||||
ccdv:
|
||||
@echo "Building ccdv"
|
55
pcmciautils.spec
Normal file
55
pcmciautils.spec
Normal file
@ -0,0 +1,55 @@
|
||||
Name: pcmciautils
|
||||
Summary: PCMCIA utilities and initialization programs
|
||||
License: GPL
|
||||
Version: 005
|
||||
Release: 1
|
||||
Group: System Environment/Base
|
||||
ExclusiveArch: i386 x86_64 ia64 ppc ppc64
|
||||
Source: http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-%{version}.tar.bz2
|
||||
Source10: pcmcia.rules
|
||||
Obsoletes: pcmcia-cs
|
||||
Obsoletes: kernel-pcmcia-cs
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: sysfsutils-devel >= 1.3.0
|
||||
Patch1: pcmciautils-fedora.patch
|
||||
Patch2: pcmciautils-radeonigp.patch
|
||||
Patch3: pcmciautils-udev.patch
|
||||
|
||||
%description
|
||||
The pcmciautils package contains utilities for initializing and
|
||||
debugging PCMCIA and Cardbus sockets.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# Fix build peculiarities
|
||||
%patch1 -p1
|
||||
# Make sure RadeonIGP boards don't MCE
|
||||
%patch2 -p1
|
||||
# Make it callable as a direct udev helper
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
make
|
||||
|
||||
%install
|
||||
%{__rm} -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# Hotplug is handled by udev
|
||||
rm -rf $RPM_BUILD_ROOT/etc/hotplug
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/udev/rules.d
|
||||
install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/udev/rules.d/
|
||||
|
||||
%clean
|
||||
%{__rm} -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/pcmcia/*.opts
|
||||
/etc/udev/rules.d/*
|
||||
/sbin/*
|
||||
|
||||
%changelog
|
||||
* Fri Jul 08 2005 Bill Nottingham <notting@redhat.com> 005-1
|
||||
- initial packaging
|
Loading…
Reference in New Issue
Block a user