patat/patat.spec

234 lines
6.8 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name patat
%global pkgver %{pkg_name}-%{version}
# version bounds
%bcond_with tests
Name: %{pkg_name}
Version: 0.8.8.0
Release: 1%{?dist}
Summary: Terminal-based presentations using Pandoc
License: GPL-2.0-or-later
Url: https://hackage.haskell.org/package/%{name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-ansi-terminal-devel
BuildRequires: ghc-ansi-wl-pprint-devel
BuildRequires: ghc-async-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-base64-bytestring-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-colour-devel
BuildRequires: ghc-containers-devel
BuildRequires: ghc-directory-devel
BuildRequires: ghc-filepath-devel
BuildRequires: ghc-mtl-devel
BuildRequires: ghc-network-devel
BuildRequires: ghc-network-uri-devel
BuildRequires: ghc-optparse-applicative-devel
BuildRequires: ghc-pandoc-devel
BuildRequires: ghc-pandoc-types-devel
BuildRequires: ghc-process-devel
BuildRequires: ghc-skylighting-devel
BuildRequires: ghc-terminal-size-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-time-devel
BuildRequires: ghc-unordered-containers-devel
BuildRequires: ghc-wcwidth-devel
BuildRequires: ghc-yaml-devel
%if %{with ghc_prof}
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-ansi-terminal-prof
BuildRequires: ghc-ansi-wl-pprint-prof
BuildRequires: ghc-async-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-base64-bytestring-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-colour-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-network-prof
BuildRequires: ghc-network-uri-prof
BuildRequires: ghc-optparse-applicative-prof
BuildRequires: ghc-pandoc-prof
BuildRequires: ghc-pandoc-types-prof
BuildRequires: ghc-process-prof
BuildRequires: ghc-skylighting-prof
BuildRequires: ghc-terminal-size-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-time-prof
BuildRequires: ghc-unordered-containers-prof
BuildRequires: ghc-wcwidth-prof
BuildRequires: ghc-yaml-prof
%endif
%if %{with tests}
BuildRequires: ghc-QuickCheck-devel
BuildRequires: ghc-tasty-devel
BuildRequires: ghc-tasty-hunit-devel
BuildRequires: ghc-tasty-quickcheck-devel
%endif
# End cabal-rpm deps
%description
Terminal-based presentations using Pandoc.
%package -n ghc-%{name}
Summary: Haskell %{name} library
%description -n ghc-%{name}
This package provides the Haskell %{name} shared library.
%package -n ghc-%{name}-devel
Summary: Haskell %{name} library development files
Provides: ghc-%{name}-static = %{version}-%{release}
Provides: ghc-%{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: ghc-%{name}%{?_isa} = %{version}-%{release}
%description -n ghc-%{name}-devel
This package provides the Haskell %{name} library development files.
%if %{with haddock}
%package -n ghc-%{name}-doc
Summary: Haskell %{name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description -n ghc-%{name}-doc
This package provides the Haskell %{name} library documentation.
%endif
%if %{with ghc_prof}
%package -n ghc-%{name}-prof
Summary: Haskell %{name} profiling library
Requires: ghc-%{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (ghc-%{name}-devel and ghc-prof)
%description -n ghc-%{name}-prof
This package provides the Haskell %{name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q
# End cabal-rpm setup
cabal-tweak-dep-ver optparse-applicative '< 0.17' '< 0.18'
cabal-tweak-dep-ver time '< 1.10' '< 1.12'
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
mkdir -p %{buildroot}%{_datadir}/bash-completion/completions/
%{buildroot}%{_bindir}/%{name} --bash-completion-script %{name} | sed s/filenames/default/ > %{buildroot}%{_datadir}/bash-completion/completions/%{name}
# End cabal-rpm install
%check
%if %{with tests}
%cabal_test
%endif
%files
# Begin cabal-rpm files:
%license LICENSE
%doc CHANGELOG.md README.md
%{_bindir}/%{name}
%{_datadir}/bash-completion/completions/%{name}
# End cabal-rpm files
%files -n ghc-%{name} -f ghc-%{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files -n ghc-%{name}-devel -f ghc-%{name}-devel.files
%doc CHANGELOG.md README.md
%if %{with haddock}
%files -n ghc-%{name}-doc -f ghc-%{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files -n ghc-%{name}-prof -f ghc-%{name}-prof.files
%endif
%changelog
* Sun Jan 22 2023 Jens Petersen <petersen@redhat.com> - 0.8.8.0-1
- https://hackage.haskell.org/package/patat-0.8.8.0/changelog
- refresh to cabal-rpm-2.1.0 with SPDX migration
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.7.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jun 17 2022 Jens Petersen <petersen@redhat.com> - 0.8.7.0-4
- rebuild
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.7.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sat Jan 08 2022 Miro Hrončok <mhroncok@redhat.com> - 0.8.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Changes/LIBFFI34
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 0.8.7.0-1
- update to 0.8.7.0
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.6.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jan 29 2021 Jens Petersen <petersen@redhat.com> - 0.8.6.1-1
- update to 0.8.6.1
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.5.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Sat Sep 19 21:39:24 +08 2020 Jens Petersen <petersen@redhat.com> - 0.8.5.0-3
- rebuild for pandoc: cmark-gfm-0.2.2 fixes exponential parse (#1854329)
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jul 16 2020 Jens Petersen <petersen@redhat.com> - 0.8.5.0-1
- update to 0.8.5.0
* Fri Feb 14 2020 Jens Petersen <petersen@redhat.com> - 0.8.4.3-1
- update to 0.8.4.3
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Fri Jul 5 2019 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.8.2.3-1
- spec file generated by cabal-rpm-1.0.0