Update patch
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
6ce1b6c1a0
commit
60bc4ee6c4
@ -1,5 +1,5 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2408b54..f9da54a 100644
|
||||
index 2408b54..2e204b6 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -204,27 +204,13 @@ else()
|
||||
@ -8,7 +8,7 @@ index 2408b54..f9da54a 100644
|
||||
if(LUSOL)
|
||||
- include(CheckLanguage)
|
||||
- check_language(Fortran)
|
||||
find_package(BLAS)
|
||||
- find_package(BLAS)
|
||||
-endif()
|
||||
-if(CMAKE_Fortran_COMPILER AND BLAS_FOUND)
|
||||
- enable_language(Fortran)
|
||||
@ -24,13 +24,14 @@ index 2408b54..f9da54a 100644
|
||||
- set_property(TARGET clusol PROPERTY POSITION_INDEPENDENT_CODE ON)
|
||||
- target_include_directories(clusol PRIVATE src/papilo/external/lusol)
|
||||
- target_link_libraries(clusol ${BLAS_LIBRARIES})
|
||||
+ if(BLAS_FOUND)
|
||||
+ target_link_libraries(papilo INTERFACE ${BLAS_LIBRARIES})
|
||||
+ endif()
|
||||
target_link_libraries(papilo INTERFACE clusol)
|
||||
set(PAPILO_HAVE_LUSOL 1)
|
||||
- set(CLUSOL_TARGET clusol)
|
||||
+ set(CLUSOL_TARGET "")
|
||||
+ find_package(BLAS)
|
||||
+ if(BLAS_FOUND)
|
||||
+ target_link_libraries(papilo INTERFACE ${BLAS_LIBRARIES})
|
||||
+ endif()
|
||||
else()
|
||||
set(PAPILO_HAVE_LUSOL 0)
|
||||
set(CLUSOL_TARGET "")
|
||||
|
Loading…
x
Reference in New Issue
Block a user