Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2024-11-21 16:03:00 +02:00
commit 607504c8ab
Signed by: davidlt
GPG Key ID: 7A5F42FAF91FACC3
3 changed files with 12 additions and 98 deletions

View File

@ -1,87 +0,0 @@
--- papilo-2.2.1/test/CMakeLists.txt.orig 2024-06-07 12:08:24.748855015 -0600
+++ papilo-2.2.1/test/CMakeLists.txt 2024-06-07 12:11:45.357301793 -0600
@@ -65,8 +65,6 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Androi
endif()
set(unit_tests
- "accurate-numerical-statistics"
-
"matrix-buffer"
"vector-comparisons"
"matrix-comparisons"
@@ -94,7 +92,7 @@ set(unit_tests
"domcol-happy-path"
"domcol-parallel-columns"
"domcol-multiple-parallel-cols-generate_redundant-reductions"
- "domcol-multiple-column"
+ #"domcol-multiple-columns"
#DualFix
"dual-fix-happy-path"
@@ -130,13 +128,13 @@ set(unit_tests
"parallel-row-two-inequalities-tighten-upper-bound-first-row-dominant"
"parallel-row-two-inequalities-infeasible-first-row-dominant"
"parallel-row-two-inequalities-infeasible-second-row-dominant"
- "parallel-row-two-inequalities-tighten-upper-bound-first-row-neg"
+ "parallel-row-two-inequalities-tighten-upper-bound-first-row-negfactor-dominant"
"parallel-row-overwrite-inf-first-row-rhs-inf"
"parallel-row-overwrite-inf-first-row-lhs-inf"
"parallel-row-overwrite-inf-first-row-lhs-inf-neg-factor"
"parallel-row-mixed-infeasible-first-row-equation"
"parallel-row-best-bound-is-used-for-rhs-coeff-not-1"
- "parallel-row-best-bound-is-used-for-rhs-coeff"
+ "parallel-row-best-bound-is-used-for-rhs"
"parallel-row-mixed-second-row-equation"
"parallel-row-mixed-infeasible-second-row-equation"
"parallel-row-multiple-parallel-rows"
@@ -165,6 +163,7 @@ set(unit_tests
"happy-path-singleton-column-implied-bounds-negative-coeff-neg-bounds"
"happy-path-singleton-column-implied-bounds-positive-coeff-pos-bounds"
"happy-path-singleton-column-implied-bounds-positive-coeff-neg-bounds"
+ "happy-path-singleton-column-infinity-bounds-equation"
#Singleton Stuffing
"singleton-stuffing-make-sure-to-first-set-bounds-to-infinity"
@@ -174,32 +173,35 @@ set(unit_tests
"simple-probing-negative-binary-coeff"
"simple-probing-positive-binary-coeff"
"simple-different-int-coeff"
- "simple-different-int-coeff-pt2"
+ #"simple-different-int-coeff.pt2"
#Simple Substitution
"simple-substitution-happy-path-for-2-int"
"simple-substitution-happy-path-for-2-continuous"
"simple-substitution-happy-path-for-continuous-and-integer"
"simple-substitution-happy-path-for-int-continuous-coeff"
- "simple-substitution-should_return_infeasible_if_gcd_of_coeff_is_in_rhs"
- "simple-substitution-should_return_feasible_if_gcd_of_coeff_is_in_rhs"
- "simple-substitution-failed-path-for-2-int"
+ "simple-substitution-simple-substitution-for-2-int"
+ "example_10_1_in_constraint_integer_programming"
+ "should_return_infeasible_if_gcd_of_coeff_is_in_rhs"
+ "should_return_feasible_if_gcd_of_coeff_is_in_rhs"
"simple-substitution-2-negative-integer"
"simple-substitution-feasible-gcd"
"simple-substitution-non-coprime"
"simple-substitution-violated-gcd"
#Simplify Inequality
- "happy-path-simplify-inequalities-only-greatest-divisor"
+ #"happy-path-simplify-inequalities"
"simplify_inequ_doesnt_lock_more_rows"
"simplify_inequ_doesnt_apply_lb_and_ub_on_one_row"
#Sparsify
"happy-path-sparsify"
"happy-path-sparsify-two-equalities"
- "failed-path-sparsify"
+ "failed-path-sparsify-if-misses-one-for-integer"
+ "happy-path-sparsify-if-misses-one-for-continuous"
+ "happy-path-sparsify-if-misses-one-for-continuous_2"
+ "failed-path-sparsify-if-misses-two-for-continuous"
- "integration-test-for-flugpl"
${PAPILOLIB_TESTS}
${BOOST_REQUIRED_TESTS}
)

View File

@ -10,8 +10,10 @@
# solver support, build the solvers, then do a non-bootstrap build.
%bcond bootstrap 1
%global giturl https://github.com/scipopt/papilo/
Name: papilo
Version: 2.3.0
Version: 2.3.1
Release: %autorelease -e 0.riscv64
Summary: Parallel presolve for integer and linear optimization
@ -21,17 +23,15 @@ Summary: Parallel presolve for integer and linear optimization
# MIT: the bundled fmt project
License: LGPL-3.0-or-later AND BSL-1.0 AND Zlib AND MIT
URL: https://www.scipopt.org/
VCS: https://github.com/scipopt/papilo/
Source0: %{vcs}/archive/v%{version}/%{name}-%{version}.tar.gz
VCS: git:%{giturl}.git
Source: %{giturl}/archive/v%{version}/%{name}-%{version}.tar.gz
# Unbundle catch, LUSOL, pdqsort, and ska
Patch0: %{name}-unbundle.patch
Patch: %{name}-unbundle.patch
# Build a shared library instead of a static library
Patch1: %{name}-shared.patch
# The list of tests in CMakeLists.txt doesn't match the actual tests
Patch2: %{name}-test.patch
Patch: %{name}-shared.patch
# Avoid out-of-bounds vector access
# https://github.com/scipopt/papilo/pull/48
Patch3: %{name}-vector-bounds.patch
Patch: %{name}-vector-bounds.patch
# See https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
ExcludeArch: %{ix86}
@ -42,6 +42,7 @@ BuildRequires: cmake(catch2)
BuildRequires: cmake(tbb)
BuildRequires: gcc-c++
BuildRequires: help2man
BuildRequires: libatomic
%if %{quadmath}
BuildRequires: libquadmath-devel
%endif
@ -119,8 +120,8 @@ cd -
sed -i 's,\./\(papilo\),\1,' %{buildroot}%{_mandir}/man1/papilo.1
%check
# Temporarily skip a test that is broken in the 2.3.0 release
%ctest -E '(d|q)-solve-rgn\.mps-default\.set'
# Temporarily skip a test that is broken in the 2.3.1 release
%ctest -E 'q-solve-rgn\.mps-default\.set'
%files
%doc CHANGELOG README.md parameters.txt

View File

@ -1 +1 @@
SHA512 (papilo-2.3.0.tar.gz) = a33f325774a060a0c89e0568ced07a771f01dfd244e190d0d11fa2e0465f5acb2555f1d842288e32c0f8826e343395162cf4fa3585d1e4f2b805061851f32cfc
SHA512 (papilo-2.3.1.tar.gz) = 3b1df7fdfbac0df9e5e0c0e682dae522f9744b5f93d3a3a8d462f787e05fc86911daa33673643613d873c3611a52a8a723d6e552d6c830a2a6032ceaeb262c5a