Build the binary with soplex and scip support
This commit is contained in:
parent
1771c73069
commit
3b6ae06355
@ -268,7 +268,7 @@
|
||||
#include "papilo/core/Problem.hpp"
|
||||
|
||||
--- papilo-2.2.0/test/PapiloLib.cpp.orig 2024-02-08 04:11:10.000000000 -0700
|
||||
+++ papilo-2.2.0/test/PapiloLib.cpp 2024-02-19 15:44:49.658384691 -0700
|
||||
+++ papilo-2.2.0/test/PapiloLib.cpp 2024-02-26 10:45:46.493564658 -0700
|
||||
@@ -21,7 +21,7 @@
|
||||
/* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * */
|
||||
|
||||
@ -278,6 +278,26 @@
|
||||
#include "papilo/misc/fmt.hpp"
|
||||
|
||||
TEST_CASE( "papilolib", "[C-API]" )
|
||||
@@ -441,8 +441,8 @@ TEST_CASE( "papilolib", "[C-API]" )
|
||||
PAPILO_SOLVING_INFO* result = papilo_solver_start( solver );
|
||||
|
||||
REQUIRE( result->solve_result == PAPILO_SOLVE_RESULT_OPTIMAL );
|
||||
- REQUIRE( result->bestsol_obj == Approx( 796648.4375 ) );
|
||||
- REQUIRE( result->dualbound == Approx( 796648.4375 ) );
|
||||
+ REQUIRE( result->bestsol_obj == Catch::Approx( 796648.4375 ) );
|
||||
+ REQUIRE( result->dualbound == Catch::Approx( 796648.4375 ) );
|
||||
REQUIRE( result->bestsol_intviol >= 0.0 );
|
||||
REQUIRE( result->bestsol_boundviol >= 0.0 );
|
||||
REQUIRE( result->bestsol_consviol >= 0.0 );
|
||||
@@ -456,7 +456,7 @@ TEST_CASE( "papilolib", "[C-API]" )
|
||||
double objval = 0;
|
||||
for( int i = 0; i < nvars; ++i )
|
||||
objval += obj[i] * sol[i];
|
||||
- REQUIRE( objval == Approx( 796648.4375 ) );
|
||||
+ REQUIRE( objval == Catch::Approx( 796648.4375 ) );
|
||||
|
||||
papilo_solver_free( solver );
|
||||
}
|
||||
--- papilo-2.2.0/test/papilo/misc/VectorUtilsTest.cpp.orig 2024-02-08 04:11:10.000000000 -0700
|
||||
+++ papilo-2.2.0/test/papilo/misc/VectorUtilsTest.cpp 2024-02-19 15:44:49.659384678 -0700
|
||||
@@ -21,7 +21,7 @@
|
||||
|
11
papilo.spec
11
papilo.spec
@ -5,6 +5,11 @@
|
||||
%global quadmath 0
|
||||
%endif
|
||||
|
||||
# The papilo binary depends on several solvers that transitively depend on the
|
||||
# papilo library. In a bootstrap situation, first build the binary without
|
||||
# solver support, build the solvers, then do a non-bootstrap build.
|
||||
%bcond bootstrap 0
|
||||
|
||||
Name: papilo
|
||||
Version: 2.2.0
|
||||
Release: %autorelease
|
||||
@ -43,6 +48,12 @@ BuildRequires: lusol-devel
|
||||
BuildRequires: pdqsort-static
|
||||
BuildRequires: pkgconfig(gmp)
|
||||
|
||||
%if %{without bootstrap}
|
||||
# Solver support
|
||||
BuildRequires: cmake(scip)
|
||||
BuildRequires: cmake(soplex)
|
||||
%endif
|
||||
|
||||
Requires: libpapilo%{?_isa} = %{version}-%{release}
|
||||
|
||||
# The bundled version of fmt is incompatible with version 10 in Rawhide.
|
||||
|
Loading…
x
Reference in New Issue
Block a user