Rebase to official papi-6.0.0.
This commit is contained in:
parent
ee9819b49e
commit
dc9f280bee
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@ papi-4.1.0.tar.gz
|
|||||||
/papi-5.5.1.tar.gz
|
/papi-5.5.1.tar.gz
|
||||||
/papi-5.6.0.tar.gz
|
/papi-5.6.0.tar.gz
|
||||||
/papi-5.7.0.tar.gz
|
/papi-5.7.0.tar.gz
|
||||||
|
/papi-6.0.0.tar.gz
|
||||||
|
10
papi-python3.patch
Normal file
10
papi-python3.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
diff --git a/src/high-level/scripts/papi_hl_output_writer.py b/src/high-level/scripts/papi_hl_output_writer.py
|
||||||
|
index 123d2cd0..34bfbd73 100755
|
||||||
|
--- a/src/high-level/scripts/papi_hl_output_writer.py
|
||||||
|
+++ b/src/high-level/scripts/papi_hl_output_writer.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
from __future__ import division
|
||||||
|
from collections import OrderedDict
|
||||||
|
|
46
papi.spec
46
papi.spec
@ -5,14 +5,16 @@
|
|||||||
%else
|
%else
|
||||||
%{!?with_rdma: %global with_rdma 1}
|
%{!?with_rdma: %global with_rdma 1}
|
||||||
%endif
|
%endif
|
||||||
|
%{!?with_pcp: %global with_pcp 1}
|
||||||
Summary: Performance Application Programming Interface
|
Summary: Performance Application Programming Interface
|
||||||
Name: papi
|
Name: papi
|
||||||
Version: 5.7.0
|
Version: 6.0.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Requires: papi-libs = %{version}-%{release}
|
Requires: papi-libs = %{version}-%{release}
|
||||||
URL: http://icl.cs.utk.edu/papi/
|
URL: http://icl.cs.utk.edu/papi/
|
||||||
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
|
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
|
||||||
|
Patch1: papi-python3.patch
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
@ -31,6 +33,9 @@ BuildRequires: net-tools
|
|||||||
BuildRequires: rdma-core-devel
|
BuildRequires: rdma-core-devel
|
||||||
BuildRequires: infiniband-diags-devel
|
BuildRequires: infiniband-diags-devel
|
||||||
%endif
|
%endif
|
||||||
|
%if %{with_pcp}
|
||||||
|
BuildRequires: pcp-libs-devel
|
||||||
|
%endif
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
#Right now libpfm does not know anything about s390 and will fail
|
#Right now libpfm does not know anything about s390 and will fail
|
||||||
ExcludeArch: s390 s390x
|
ExcludeArch: s390 s390x
|
||||||
@ -72,6 +77,7 @@ the PAPI user-space libraries and interfaces.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .python3
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{without bundled_libpfm}
|
%if %{without bundled_libpfm}
|
||||||
@ -79,29 +85,30 @@ the PAPI user-space libraries and interfaces.
|
|||||||
%global libpfm_config --with-pfm-incdir=%{_includedir} --with-pfm-libdir=%{_libdir}
|
%global libpfm_config --with-pfm-incdir=%{_includedir} --with-pfm-libdir=%{_libdir}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# set up environment variable for the various components
|
||||||
|
# cuda
|
||||||
|
# host_micpower
|
||||||
|
%if %{with_rdma}
|
||||||
|
export PAPI_INFINIBAND_UMAD_ROOT=/usr
|
||||||
|
%endif
|
||||||
|
# lmsensors
|
||||||
|
export PAPI_LMSENSORS_ROOT=/usr
|
||||||
|
#pushd vmware; ./configure; popd
|
||||||
|
%if %{with_pcp}
|
||||||
|
%global pcp_enable pcp
|
||||||
|
export PAPI_PCP_ROOT=/usr
|
||||||
|
%endif
|
||||||
|
|
||||||
cd src
|
cd src
|
||||||
autoconf
|
autoconf
|
||||||
%configure --with-perf-events \
|
%configure --with-perf-events \
|
||||||
%{?libpfm_config} \
|
%{?libpfm_config} \
|
||||||
--with-static-lib=yes --with-shared-lib=yes --with-shlib --with-shlib-tools \
|
--with-static-lib=yes --with-shared-lib=yes --with-shlib --with-shlib-tools \
|
||||||
--with-components="appio coretemp example infiniband lmsensors lustre micpower mx net rapl stealtime"
|
--with-components="appio coretemp example infiniband lmsensors lustre micpower mx net %{?pcp_enable} rapl sde stealtime"
|
||||||
# implicit enabled components: perf_event perf_event_uncore
|
# implicit enabled components: perf_event perf_event_uncore
|
||||||
#components currently left out because of build configure/build issues
|
#components currently left out because of build configure/build issues
|
||||||
# --with-components="bgpm coretemp_freebsd cuda host_micpower nvml vmware"
|
# --with-components="bgpm coretemp_freebsd cuda host_micpower nvml vmware"
|
||||||
|
|
||||||
pushd components
|
|
||||||
#pushd cuda; ./configure; popd
|
|
||||||
#pushd host_micpower; ./configure; popd
|
|
||||||
%if %{with_rdma}
|
|
||||||
pushd infiniband_umad; %configure; popd
|
|
||||||
%endif
|
|
||||||
pushd lmsensors; \
|
|
||||||
%configure --with-sensors_incdir=/usr/include/sensors \
|
|
||||||
--with-sensors_libdir=%{_libdir}; \
|
|
||||||
popd
|
|
||||||
#pushd vmware; ./configure; popd
|
|
||||||
popd
|
|
||||||
|
|
||||||
#DBG workaround to make sure libpfm just uses the normal CFLAGS
|
#DBG workaround to make sure libpfm just uses the normal CFLAGS
|
||||||
DBG="" make %{?_smp_mflags}
|
DBG="" make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -123,14 +130,14 @@ chrpath --delete $RPM_BUILD_ROOT%{_libdir}/*.so*
|
|||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%dir /usr/share/papi
|
%dir /usr/share/papi
|
||||||
/usr/share/papi/papi_events.csv
|
/usr/share/papi/papi_events.csv
|
||||||
%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
|
%doc INSTALL.txt README.md LICENSE.txt RELEASENOTES.txt
|
||||||
%doc %{_mandir}/man1/*
|
%doc %{_mandir}/man1/*
|
||||||
|
|
||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
|
%doc INSTALL.txt README.md LICENSE.txt RELEASENOTES.txt
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/*.h
|
%{_includedir}/*.h
|
||||||
@ -153,6 +160,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_libdir}/*.so*
|
|||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 04 2020 William Cohen <wcohen@redhat.com> - 6.0.0-1
|
||||||
|
- Rebase to official papi-6.0.0.
|
||||||
|
|
||||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.7.0-4
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.7.0-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (papi-5.7.0.tar.gz) = 9adc1296321c4ec058bba7f3fc1f1b25058c83bba8168f6e9c1073999b12dad3041cce7ca04cf860572868c519de01d688a556024d007b22d64534dc242b9127
|
SHA512 (papi-6.0.0.tar.gz) = 2a4a245d64c3ac05ca9664194ac406cfb360fc0935afdee115ca0fc3f24b6051d1130426ed959fac2f711a2239100b37a4dfe8e0885697f4f4c049554c95258a
|
||||||
|
Loading…
Reference in New Issue
Block a user