Rebase to pam-redhat-1.1.5

Signed-off-by: Björn Esser <besser82@fedoraproject.org>
This commit is contained in:
Björn Esser 2021-09-23 11:38:21 +02:00
parent b025ee55c1
commit 75bbb9a525
No known key found for this signature in database
GPG Key ID: F52E98007594C21D
5 changed files with 12 additions and 65 deletions

17
.gitignore vendored
View File

@ -1,12 +1,5 @@
*.src.rpm
*.tar.bz2
/Linux-PAM-1.3.1.tar.xz
/Linux-PAM-1.3.1.tar.xz.asc
/Linux-PAM-1.4.0.tar.xz
/Linux-PAM-1.4.0.tar.xz.asc
/Linux-PAM-1.5.0.tar.xz
/Linux-PAM-1.5.0.tar.xz.asc
/Linux-PAM-1.5.1.tar.xz
/Linux-PAM-1.5.1.tar.xz.asc
/Linux-PAM-1.5.2.tar.xz
/Linux-PAM-1.5.2.tar.xz.asc
/*.src.rpm
/Linux-PAM-*.tar.xz
/Linux-PAM-*.tar.xz.asc
/pam-redhat-*.tar.bz2
/pam-redhat-*.tar.xz

View File

@ -1,33 +0,0 @@
Index: Linux-PAM-1.5.2/modules/pam_console/Makefile.am
===================================================================
--- Linux-PAM-1.5.2.orig/modules/pam_console/Makefile.am
+++ Linux-PAM-1.5.2/modules/pam_console/Makefile.am
@@ -44,6 +44,8 @@ secureconf_DATA = console.perms console.
FLEX_OPTS = -Cr
BISON_OPTS = -d
+BUILT_SOURCES = configfile.tab.h configfile.tab.c configfile.lex.c
+
pam_console_la_SOURCES = pam_console.c pam_console.h regerr.c handlers.c handlers.h
pam_console_apply_SOURCES = pam_console_apply.c pam_console.h chmod.c modechange.c regerr.c \
configfile.c configfile.h hashtable.c hashtable.h hashtable_private.h
@@ -51,15 +53,17 @@ pam_console_apply_SOURCES = pam_console_
pam_console_la_CFLAGS = $(AM_CFLAGS)
pam_console_apply_CFLAGS = $(AM_CFLAGS) @EXE_CFLAGS@
+configfile.tab.h: configfile.tab.c
+
configfile.tab.c: configfile.y
$(YACC) $(BISON_OPTS) -o $@ -p _pc_yy $<
sh $(srcdir)/sed-static $@
-configfile.lex.c: configfile.l configfile.tab.c
+configfile.lex.c: configfile.l configfile.tab.h
$(LEX) $(FLEX_OPTS) -o$@ -P_pc_yy $<
sh $(srcdir)/sed-static $@
-configfile.c: configfile.tab.c configfile.lex.c
+configfile.c: configfile.tab.h configfile.tab.c configfile.lex.c
install-data-local:
mkdir -p $(DESTDIR)$(secureconfdir)/console.apps

View File

@ -1,12 +0,0 @@
Index: Linux-PAM-1.5.2/modules/pam_console/handlers.c
===================================================================
--- Linux-PAM-1.5.2.orig/modules/pam_console/handlers.c
+++ Linux-PAM-1.5.2/modules/pam_console/handlers.c
@@ -28,6 +28,7 @@
#include <sys/types.h>
#include <pwd.h>
#include <syslog.h>
+#include <grp.h>
#include "handlers.h"
#include "pam_console.h"

View File

@ -1,10 +1,10 @@
%global so_ver 0
%global pam_redhat_version 1.1.4
%global pam_redhat_version 1.1.5
Summary: An extensible library which provides authentication for applications
Name: pam
Version: 1.5.2
Release: 4%{?dist}
Release: 5%{?dist}
# The library is BSD licensed with option to relicense as GPLv2+
# - this option is redundant as the BSD license allows that anyway.
# pam_timestamp, pam_loginuid, and pam_console modules are GPLv2+.
@ -12,7 +12,7 @@ License: BSD and GPLv2+
URL: http://www.linux-pam.org/
Source0: https://github.com/linux-pam/linux-pam/releases/download/v%{version}/Linux-PAM-%{version}.tar.xz
Source1: https://github.com/linux-pam/linux-pam/releases/download/v%{version}/Linux-PAM-%{version}.tar.xz.asc
Source2: https://releases.pagure.org/pam-redhat/pam-redhat-%{pam_redhat_version}.tar.bz2
Source2: https://releases.pagure.org/pam-redhat/pam-redhat-%{pam_redhat_version}.tar.xz
Source3: macros.%{name}
Source5: other.pamd
Source6: system-auth.pamd
@ -30,8 +30,6 @@ Source18: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
Patch1: pam-1.5.0-redhat-modules.patch
Patch2: pam-1.5.0-noflex.patch
Patch3: pam-1.3.0-unix-nomsg.patch
Patch4: pam-1.5.2-pam_console-fix_parallel_build.patch
Patch5: pam-1.5.2-pam_console-fix_setgroups_not_defined.patch
%{load:%{SOURCE3}}
@ -126,8 +124,6 @@ cp %{SOURCE18} .
%patch1 -p1 -b .redhat-modules
%patch2 -p1 -b .noflex
%patch3 -p1 -b .nomsg
%patch4 -p1 -b .parallel_build
%patch5 -p1 -b .setgroups_not_defined
autoreconf -i
@ -404,6 +400,9 @@ test "$FILE" != %{_sysconfdir}/authselect/fingerprint-auth && \
exit 0
%changelog
* Thu Sep 23 2021 Björn Esser <besser82@fedoraproject.org> - 1.5.2-5
- Rebase to pam-redhat-1.1.5
* Thu Sep 23 2021 Iker Pedrosa <ipedrosa@redhat.com> - 1.5.2-4
- Remove the /etc/motd.d directory to exclude its ownership from pam (#1968131)
- pam_timestamp: enable openssl hmac authentication (#1947294)

View File

@ -1,3 +1,3 @@
SHA512 (Linux-PAM-1.5.2.tar.xz) = fa16350c132d3e5fb82b60d991768fb596582639841b8ece645c684705467305ccf1302a0147ec222ab78c01b2c9114c5496dc1ca565d2b56bf315f29a815144
SHA512 (Linux-PAM-1.5.2.tar.xz.asc) = 5e4d9ac533651a9479ef26719430c1fdf31e2b70de859a4f09b17f9e14e8fb25d74a059332841dc8ed9db764971c3e4d9941d613a7bfbb6450122462810109ad
SHA512 (pam-redhat-1.1.4.tar.bz2) = ad3b53744505faf7c93b1f0c1ef4434c2567b97e292859963401b0c117e824704713c69f7a661cccd3aecd1208facb39c433703c1f3cdea1dbda2c380006bfc4
SHA512 (pam-redhat-1.1.5.tar.xz) = b93b80e9aa0dd8b38045b2a8cc36006b1b651a2724e64fcd9ed87af1fc36008acf9e62e2950097bebfccd657a064b748311f4b9c826f76d7b8c4299feb070bb8