Update patch for parallel build

Signed-off-by: Björn Esser <besser82@fedoraproject.org>
This commit is contained in:
Björn Esser 2021-09-23 09:37:39 +02:00
parent 38c8f7482a
commit 360b2d3288
No known key found for this signature in database
GPG Key ID: F52E98007594C21D
2 changed files with 25 additions and 2 deletions

View File

@ -6,8 +6,28 @@ Index: Linux-PAM-1.5.2/modules/pam_console/Makefile.am
FLEX_OPTS = -Cr
BISON_OPTS = -d
+BUILT_SOURCES = configfile.tab.c configfile.lex.c
+BUILT_SOURCES = configfile.tab.h configfile.tab.c configfile.lex.c
+
pam_console_la_SOURCES = pam_console.c pam_console.h regerr.c handlers.c handlers.h
pam_console_apply_SOURCES = pam_console_apply.c pam_console.h chmod.c modechange.c regerr.c \
configfile.c configfile.h hashtable.c hashtable.h hashtable_private.h
@@ -51,15 +53,17 @@ pam_console_apply_SOURCES = pam_console_
pam_console_la_CFLAGS = $(AM_CFLAGS)
pam_console_apply_CFLAGS = $(AM_CFLAGS) @EXE_CFLAGS@
+configfile.tab.h: configfile.tab.c
+
configfile.tab.c: configfile.y
$(YACC) $(BISON_OPTS) -o $@ -p _pc_yy $<
sh $(srcdir)/sed-static $@
-configfile.lex.c: configfile.l configfile.tab.c
+configfile.lex.c: configfile.l configfile.tab.h
$(LEX) $(FLEX_OPTS) -o$@ -P_pc_yy $<
sh $(srcdir)/sed-static $@
-configfile.c: configfile.tab.c configfile.lex.c
+configfile.c: configfile.tab.h configfile.tab.c configfile.lex.c
install-data-local:
mkdir -p $(DESTDIR)$(secureconfdir)/console.apps

View File

@ -4,7 +4,7 @@
Summary: An extensible library which provides authentication for applications
Name: pam
Version: 1.5.2
Release: 2%{?dist}
Release: 3%{?dist}
# The library is BSD licensed with option to relicense as GPLv2+
# - this option is redundant as the BSD license allows that anyway.
# pam_timestamp, pam_loginuid, and pam_console modules are GPLv2+.
@ -389,6 +389,9 @@ test "$FILE" != %{_sysconfdir}/authselect/fingerprint-auth && \
exit 0
%changelog
* Thu Sep 23 2021 Björn Esser <besser82@fedoraproject.org> - 1.5.2-3
- Update patch for parallel build
* Wed Sep 22 2021 Björn Esser <besser82@fedoraproject.org> - 1.5.2-2
- Add a patch to fix parallel builds with autgenerated sources