fix build failure in pam_unix
- add display of previous bad login attempts to postlogin.pamd - put the tmpfiles.d config to /usr/lib and rename it to pam.conf
This commit is contained in:
parent
017fb41875
commit
28a93ad826
12
pam-1.1.5-unix-build.patch
Normal file
12
pam-1.1.5-unix-build.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c.build Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c
|
||||
--- Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c.build 2012-05-09 11:48:12.000000000 +0200
|
||||
+++ Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c 2012-07-23 18:26:49.320411216 +0200
|
||||
@@ -47,6 +47,8 @@
|
||||
#include <time.h> /* for time() */
|
||||
#include <errno.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <sys/time.h>
|
||||
+#include <sys/resource.h>
|
||||
|
||||
#include <security/_pam_macros.h>
|
||||
|
13
pam.spec
13
pam.spec
@ -54,6 +54,8 @@ Patch19: pam-1.1.5-unix-crypt.patch
|
||||
Patch20: pam-1.1.5-unix-no-fallback.patch
|
||||
# Will be upstreamed
|
||||
Patch21: pam-1.1.5-install-empty.patch
|
||||
#
|
||||
Patch22: pam-1.1.5-unix-build.patch
|
||||
|
||||
%define _sbindir /sbin
|
||||
%define _moduledir /%{_lib}/security
|
||||
@ -134,6 +136,7 @@ mv pam-redhat-%{pam_redhat_version}/* modules
|
||||
%patch19 -p1 -b .crypt
|
||||
%patch20 -p1 -b .no-fallback
|
||||
%patch21 -p1 -b .empty
|
||||
%patch22 -p1 -b .build
|
||||
|
||||
libtoolize -f
|
||||
autoreconf
|
||||
@ -219,7 +222,7 @@ rm -fr $RPM_BUILD_ROOT/usr/share/doc/pam
|
||||
install -m755 -d $RPM_BUILD_ROOT/lib/security
|
||||
|
||||
# Install the file for autocreation of /var/run subdirectories on boot
|
||||
install -m644 -D %{SOURCE15} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/pamtmp.conf
|
||||
install -m644 -D %{SOURCE15} $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/pam.conf
|
||||
|
||||
%find_lang Linux-PAM
|
||||
|
||||
@ -373,7 +376,7 @@ fi
|
||||
%endif
|
||||
%ghost %verify(not md5 size mtime) /var/log/tallylog
|
||||
%dir /var/run/faillock
|
||||
%config(noreplace) %{_sysconfdir}/tmpfiles.d/pamtmp.conf
|
||||
%{_prefix}/lib/tmpfiles.d/pam.conf
|
||||
%{_mandir}/man5/*
|
||||
%{_mandir}/man8/*
|
||||
|
||||
@ -388,8 +391,10 @@ fi
|
||||
%doc doc/adg/*.txt doc/adg/html
|
||||
|
||||
%changelog
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
* Mon Jul 23 2012 Tomas Mraz <tmraz@redhat.com> - 1.1.5-8
|
||||
- fix build failure in pam_unix
|
||||
- add display of previous bad login attempts to postlogin.pamd
|
||||
- put the tmpfiles.d config to /usr/lib and rename it to pam.conf
|
||||
|
||||
* Mon May 9 2012 Tomas Mraz <tmraz@redhat.com> 1.1.5-7
|
||||
- add inactive account lock out functionality to pam_lastlog
|
||||
|
@ -1,3 +1,7 @@
|
||||
#%PAM-1.0
|
||||
# This file is auto-generated.
|
||||
# User changes will be destroyed the next time authconfig is run.
|
||||
|
||||
session [success=1 default=ignore] pam_succeed_if.so service !~ gdm* quiet
|
||||
session [default=1] pam_lastlog.so nowtmp showfailed
|
||||
session required pam_lastlog.so silent noupdate showfailed
|
||||
|
Loading…
Reference in New Issue
Block a user