pam_unix and pam_usertype: avoid determining if user exists
This commit is contained in:
parent
6fe43fb34e
commit
1478f27b55
67
pam-1.3.1-determinine-user-exists.patch
Normal file
67
pam-1.3.1-determinine-user-exists.patch
Normal file
@ -0,0 +1,67 @@
|
||||
diff -up Linux-PAM-1.3.1/modules/pam_unix/passverify.c.determinine-user-exists Linux-PAM-1.3.1/modules/pam_unix/passverify.c
|
||||
--- Linux-PAM-1.3.1/modules/pam_unix/passverify.c.determinine-user-exists 2020-06-17 15:34:08.089162532 +0200
|
||||
+++ Linux-PAM-1.3.1/modules/pam_unix/passverify.c 2020-06-17 15:36:13.233294407 +0200
|
||||
@@ -1087,6 +1087,12 @@ helper_verify_password(const char *name,
|
||||
if (pwd == NULL || salt == NULL) {
|
||||
helper_log_err(LOG_NOTICE, "check pass; user unknown");
|
||||
retval = PAM_USER_UNKNOWN;
|
||||
+ } else if (p[0] == '\0' && nullok) {
|
||||
+ if (salt[0] == '\0') {
|
||||
+ retval = PAM_SUCCESS;
|
||||
+ } else {
|
||||
+ retval = PAM_AUTH_ERR;
|
||||
+ }
|
||||
} else {
|
||||
retval = verify_pwd_hash(p, salt, nullok);
|
||||
}
|
||||
diff -up Linux-PAM-1.3.1/modules/pam_unix/support.c.determinine-user-exists Linux-PAM-1.3.1/modules/pam_unix/support.c
|
||||
--- Linux-PAM-1.3.1/modules/pam_unix/support.c.determinine-user-exists 2020-06-17 15:34:08.090162549 +0200
|
||||
+++ Linux-PAM-1.3.1/modules/pam_unix/support.c 2020-06-17 15:34:08.101162736 +0200
|
||||
@@ -672,6 +672,8 @@ _unix_blankpasswd (pam_handle_t *pamh, u
|
||||
struct passwd *pwd = NULL;
|
||||
char *salt = NULL;
|
||||
int retval;
|
||||
+ int execloop = 1;
|
||||
+ int nonexistent = 1;
|
||||
|
||||
D(("called"));
|
||||
|
||||
@@ -686,14 +688,31 @@ _unix_blankpasswd (pam_handle_t *pamh, u
|
||||
|
||||
/* UNIX passwords area */
|
||||
|
||||
- retval = get_pwd_hash(pamh, name, &pwd, &salt);
|
||||
+ /*
|
||||
+ * Execute this loop twice: one checking the password hash of an existing
|
||||
+ * user and another one for a non-existing user. This way the runtimes
|
||||
+ * are equal, making it more difficult to differentiate existing from
|
||||
+ * non-existing users.
|
||||
+ */
|
||||
+ while (execloop) {
|
||||
+ retval = get_pwd_hash(pamh, name, &pwd, &salt);
|
||||
|
||||
- if (retval == PAM_UNIX_RUN_HELPER) {
|
||||
- /* salt will not be set here so we can return immediately */
|
||||
- if (_unix_run_helper_binary(pamh, NULL, ctrl, name) == PAM_SUCCESS)
|
||||
- return 1;
|
||||
- else
|
||||
- return 0;
|
||||
+ if (retval == PAM_UNIX_RUN_HELPER) {
|
||||
+ execloop = 0;
|
||||
+ if(nonexistent) {
|
||||
+ get_pwd_hash(pamh, "pam_unix_non_existent:", &pwd, &salt);
|
||||
+ }
|
||||
+ /* salt will not be set here so we can return immediately */
|
||||
+ if (_unix_run_helper_binary(pamh, NULL, ctrl, name) == PAM_SUCCESS)
|
||||
+ return 1;
|
||||
+ else
|
||||
+ return 0;
|
||||
+ } else if (retval == PAM_USER_UNKNOWN) {
|
||||
+ name = "root";
|
||||
+ nonexistent = 0;
|
||||
+ } else {
|
||||
+ execloop = 0;
|
||||
+ }
|
||||
}
|
||||
|
||||
/* Does this user have a password? */
|
7
pam.spec
7
pam.spec
@ -3,7 +3,7 @@
|
||||
Summary: An extensible library which provides authentication for applications
|
||||
Name: pam
|
||||
Version: 1.3.1
|
||||
Release: 23%{?dist}
|
||||
Release: 24%{?dist}
|
||||
# The library is BSD licensed with option to relicense as GPLv2+
|
||||
# - this option is redundant as the BSD license allows that anyway.
|
||||
# pam_timestamp, pam_loginuid, and pam_console modules are GPLv2+.
|
||||
@ -60,6 +60,7 @@ Patch48: pam-1.3.1-unix-improve-logging.patch
|
||||
Patch49: pam-1.3.1-tty-audit-manfix.patch
|
||||
Patch50: pam-1.3.1-fds-closing.patch
|
||||
Patch51: pam-1.3.1-authtok-verify-fix.patch
|
||||
Patch52: pam-1.3.1-determinine-user-exists.patch
|
||||
|
||||
%global _pamlibdir %{_libdir}
|
||||
%global _moduledir %{_libdir}/security
|
||||
@ -150,6 +151,7 @@ cp %{SOURCE18} .
|
||||
%patch49 -p1 -b .tty-audit-manfix
|
||||
%patch50 -p1 -b .fds-closing
|
||||
%patch51 -p1 -b .authtok-verify-fix
|
||||
%patch52 -p1 -b .determinine-user-exists
|
||||
|
||||
autoreconf -i
|
||||
|
||||
@ -399,6 +401,9 @@ done
|
||||
%doc doc/specs/rfc86.0.txt
|
||||
|
||||
%changelog
|
||||
* Wed Jun 24 2020 Iker Pedrosa <ipedrosa@redhat.com> - 1.3.1-24
|
||||
- pam_unix and pam_usertype: avoid determining if user exists (#1629598)
|
||||
|
||||
* Fri Mar 13 2020 Iker Pedrosa <ipedrosa@redhat.com> - 1.3.1-23
|
||||
- revert previous change
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user