upgrade to new upstream release
This commit is contained in:
parent
1ba74b3572
commit
0c02cd5bb7
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,7 +1,2 @@
|
||||
*.src.rpm
|
||||
*.tar.bz2
|
||||
pam-redhat-0.99.10-1.tar.bz2
|
||||
Linux-PAM-1.1.1.tar.bz2
|
||||
/Linux-PAM-1.1.2.tar.bz2
|
||||
/pam-redhat-0.99.10-1.tar.bz2
|
||||
/Linux-PAM-1.1.3.tar.bz2
|
||||
|
@ -1,8 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||
Comment: See http://www.kernel.org/signature.html for info
|
||||
|
||||
iD8DBQBOBHzAyGugalF9Dw4RAvUUAJ0SfOT7ITyalk4JsmIe5tJSdIB5ygCfZ2ku
|
||||
aHp5ptRfKYgWdlnFv+3F7H4=
|
||||
=kqy6
|
||||
-----END PGP SIGNATURE-----
|
@ -1,35 +0,0 @@
|
||||
commit 61f4f06abc9b8fcb3c478fa430b52499fd2ca300
|
||||
Author: Tomas Mraz <tmraz@fedoraproject.org>
|
||||
Date: Thu Aug 25 15:48:51 2011 +0200
|
||||
|
||||
Fix the split on @ in the user field. (Red Hat Bug #732081)
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 7563098..b4f1ef8 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,8 @@
|
||||
+2011-08-25 Tomas Mraz <tm@t8m.info>
|
||||
+
|
||||
+ * modules/pam_access/pam_access.c (user_match): Fix the split
|
||||
+ on @ in the user field. (Red Hat Bug #732081)
|
||||
+
|
||||
2011-08-23 Tomas Mraz <tm@t8m.info>
|
||||
|
||||
* modules/pam_env/pam_env.c (_pam_parse): Fix missing dereference.
|
||||
diff --git a/modules/pam_access/pam_access.c b/modules/pam_access/pam_access.c
|
||||
index 0eb1e8c..472116c 100644
|
||||
--- a/modules/pam_access/pam_access.c
|
||||
+++ b/modules/pam_access/pam_access.c
|
||||
@@ -521,7 +521,10 @@ user_match (pam_handle_t *pamh, char *tok, struct login_info *item)
|
||||
* name of the user's primary group.
|
||||
*/
|
||||
|
||||
- if (tok[0] != '@' && (at = strchr(tok + 1, '@')) != 0) {
|
||||
+ /* Try to split on a pattern (@*[^@]+)(@+.*) */
|
||||
+ for (at = tok; *at == '@'; ++at);
|
||||
+
|
||||
+ if ((at = strchr(at, '@')) != NULL) {
|
||||
/* split user@host pattern */
|
||||
if (item->hostname == NULL)
|
||||
return NO;
|
@ -1,49 +0,0 @@
|
||||
commit ca6fbe92205fe5b4acf2e92e4c2bf73327b26780
|
||||
Author: Tomas Mraz <tmraz@fedoraproject.org>
|
||||
Date: Tue Aug 23 12:42:32 2011 +0200
|
||||
|
||||
Fix missing dereference.
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 07f120f..7563098 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,7 @@
|
||||
+2011-08-23 Tomas Mraz <tm@t8m.info>
|
||||
+
|
||||
+ * modules/pam_env/pam_env.c (_pam_parse): Fix missing dereference.
|
||||
+
|
||||
2011-06-22 Thorsten Kukuk <kukuk@thkukuk.de>
|
||||
|
||||
* release version 1.1.4
|
||||
diff --git a/modules/pam_env/pam_env.c b/modules/pam_env/pam_env.c
|
||||
index 865fbaf..1ec01ca 100644
|
||||
--- a/modules/pam_env/pam_env.c
|
||||
+++ b/modules/pam_env/pam_env.c
|
||||
@@ -99,7 +99,7 @@ _pam_parse (const pam_handle_t *pamh, int argc, const char **argv,
|
||||
if (!strcmp(*argv,"debug"))
|
||||
ctrl |= PAM_DEBUG_ARG;
|
||||
else if (!strncmp(*argv,"conffile=",9)) {
|
||||
- if (*argv+9 == '\0') {
|
||||
+ if ((*argv)[9] == '\0') {
|
||||
pam_syslog(pamh, LOG_ERR,
|
||||
"conffile= specification missing argument - ignored");
|
||||
} else {
|
||||
@@ -107,7 +107,7 @@ _pam_parse (const pam_handle_t *pamh, int argc, const char **argv,
|
||||
D(("new Configuration File: %s", *conffile));
|
||||
}
|
||||
} else if (!strncmp(*argv,"envfile=",8)) {
|
||||
- if (*argv+8 == '\0') {
|
||||
+ if ((*argv)[8] == '\0') {
|
||||
pam_syslog (pamh, LOG_ERR,
|
||||
"envfile= specification missing argument - ignored");
|
||||
} else {
|
||||
@@ -115,7 +115,7 @@ _pam_parse (const pam_handle_t *pamh, int argc, const char **argv,
|
||||
D(("new Env File: %s", *envfile));
|
||||
}
|
||||
} else if (!strncmp(*argv,"user_envfile=",13)) {
|
||||
- if (*argv+13 == '\0') {
|
||||
+ if ((*argv)[13] == '\0') {
|
||||
pam_syslog (pamh, LOG_ERR,
|
||||
"user_envfile= specification missing argument - ignored");
|
||||
} else {
|
19
pam.spec
19
pam.spec
@ -2,15 +2,17 @@
|
||||
|
||||
Summary: An extensible library which provides authentication for applications
|
||||
Name: pam
|
||||
Version: 1.1.4
|
||||
Release: 4%{?dist}
|
||||
Version: 1.1.5
|
||||
Release: 1%{?dist}
|
||||
# The library is BSD licensed with option to relicense as GPLv2+
|
||||
# - this option is redundant as the BSD license allows that anyway.
|
||||
# pam_timestamp, pam_loginuid, and pam_console modules are GPLv2+.
|
||||
License: BSD and GPLv2+
|
||||
Group: System Environment/Base
|
||||
Source0: http://ftp.us.kernel.org/pub/linux/libs/pam/library/Linux-PAM-%{version}.tar.bz2
|
||||
Source1: http://ftp.us.kernel.org/pub/linux/libs/pam/library/Linux-PAM-%{version}.tar.bz2.sign
|
||||
Source0: https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-%{version}.tar.bz2
|
||||
# This is the old location that might be revived in future:
|
||||
#Source0: http://ftp.us.kernel.org/pub/linux/libs/pam/library/Linux-PAM-%{version}.tar.bz2
|
||||
#Source1: http://ftp.us.kernel.org/pub/linux/libs/pam/library/Linux-PAM-%{version}.tar.bz2.sign
|
||||
Source2: https://fedorahosted.org/releases/p/a/pam-redhat/pam-redhat-%{pam_redhat_version}.tar.bz2
|
||||
Source5: other.pamd
|
||||
Source6: system-auth.pamd
|
||||
@ -35,9 +37,6 @@ Patch9: pam-1.1.2-noflex.patch
|
||||
Patch10: pam-1.1.3-nouserenv.patch
|
||||
Patch11: pam-1.1.3-console-abstract.patch
|
||||
Patch12: pam-1.1.3-faillock-screensaver.patch
|
||||
# Upstreamed patches
|
||||
Patch30: pam-1.1.4-env-deref.patch
|
||||
Patch31: pam-1.1.4-access-split.patch
|
||||
|
||||
%define _sbindir /sbin
|
||||
%define _moduledir /%{_lib}/security
|
||||
@ -109,9 +108,6 @@ mv pam-redhat-%{pam_redhat_version}/* modules
|
||||
%patch11 -p1 -b .abstract
|
||||
%patch12 -p1 -b .screensaver
|
||||
|
||||
%patch30 -p1 -b .deref
|
||||
%patch31 -p1 -b .split
|
||||
|
||||
libtoolize -f
|
||||
autoreconf
|
||||
|
||||
@ -365,6 +361,9 @@ fi
|
||||
%doc doc/adg/*.txt doc/adg/html
|
||||
|
||||
%changelog
|
||||
* Thu Nov 24 2011 Tomas Mraz <tmraz@redhat.com> 1.1.5-1
|
||||
- upgrade to new upstream release
|
||||
|
||||
* Thu Aug 25 2011 Tomas Mraz <tmraz@redhat.com> 1.1.4-4
|
||||
- fix dereference in pam_env
|
||||
- fix wrong parse of user@host pattern in pam_access (#732081)
|
||||
|
Loading…
Reference in New Issue
Block a user