pam_unix: do not fail with bad ld.so.preload
This commit is contained in:
parent
bc16a79c57
commit
01ca858789
@ -1,7 +1,15 @@
|
||||
diff -up Linux-PAM-1.1.6/modules/pam_mkhomedir/pam_mkhomedir.c.std-noclose Linux-PAM-1.1.6/modules/pam_mkhomedir/pam_mkhomedir.c
|
||||
--- Linux-PAM-1.1.6/modules/pam_mkhomedir/pam_mkhomedir.c.std-noclose 2012-08-15 13:08:43.000000000 +0200
|
||||
+++ Linux-PAM-1.1.6/modules/pam_mkhomedir/pam_mkhomedir.c 2013-04-23 17:07:46.565362820 +0200
|
||||
@@ -133,13 +133,21 @@ create_homedir (pam_handle_t *pamh, opti
|
||||
+++ Linux-PAM-1.1.6/modules/pam_mkhomedir/pam_mkhomedir.c 2013-04-24 13:11:14.768817086 +0200
|
||||
@@ -35,6 +35,7 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/resource.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
#include <pwd.h>
|
||||
#include <errno.h>
|
||||
@@ -133,13 +134,21 @@ create_homedir (pam_handle_t *pamh, opti
|
||||
if (child == 0) {
|
||||
int i;
|
||||
struct rlimit rlim;
|
||||
@ -26,8 +34,16 @@ diff -up Linux-PAM-1.1.6/modules/pam_mkhomedir/pam_mkhomedir.c.std-noclose Linux
|
||||
}
|
||||
diff -up Linux-PAM-1.1.6/modules/pam_unix/pam_unix_acct.c.std-noclose Linux-PAM-1.1.6/modules/pam_unix/pam_unix_acct.c
|
||||
--- Linux-PAM-1.1.6/modules/pam_unix/pam_unix_acct.c.std-noclose 2012-08-15 13:08:43.000000000 +0200
|
||||
+++ Linux-PAM-1.1.6/modules/pam_unix/pam_unix_acct.c 2013-04-23 17:10:28.928870251 +0200
|
||||
@@ -100,21 +100,26 @@ int _unix_run_verify_binary(pam_handle_t
|
||||
+++ Linux-PAM-1.1.6/modules/pam_unix/pam_unix_acct.c 2013-04-24 13:12:17.105990961 +0200
|
||||
@@ -39,6 +39,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
+#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/resource.h>
|
||||
@@ -100,21 +101,26 @@ int _unix_run_verify_binary(pam_handle_t
|
||||
if (child == 0) {
|
||||
int i=0;
|
||||
struct rlimit rlim;
|
||||
@ -91,8 +107,16 @@ diff -up Linux-PAM-1.1.6/modules/pam_unix/pam_unix_passwd.c.std-noclose Linux-PA
|
||||
}
|
||||
diff -up Linux-PAM-1.1.6/modules/pam_unix/support.c.std-noclose Linux-PAM-1.1.6/modules/pam_unix/support.c
|
||||
--- Linux-PAM-1.1.6/modules/pam_unix/support.c.std-noclose 2012-08-15 13:08:43.000000000 +0200
|
||||
+++ Linux-PAM-1.1.6/modules/pam_unix/support.c 2013-04-23 17:16:47.505061373 +0200
|
||||
@@ -462,6 +462,7 @@ static int _unix_run_helper_binary(pam_h
|
||||
+++ Linux-PAM-1.1.6/modules/pam_unix/support.c 2013-04-24 13:12:42.893064361 +0200
|
||||
@@ -5,6 +5,7 @@
|
||||
#include "config.h"
|
||||
|
||||
#include <stdlib.h>
|
||||
+#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
#include <stdarg.h>
|
||||
#include <stdio.h>
|
||||
@@ -462,6 +463,7 @@ static int _unix_run_helper_binary(pam_h
|
||||
if (child == 0) {
|
||||
int i=0;
|
||||
struct rlimit rlim;
|
||||
@ -100,7 +124,7 @@ diff -up Linux-PAM-1.1.6/modules/pam_unix/support.c.std-noclose Linux-PAM-1.1.6/
|
||||
static char *envp[] = { NULL };
|
||||
char *args[] = { NULL, NULL, NULL, NULL };
|
||||
|
||||
@@ -470,11 +471,17 @@ static int _unix_run_helper_binary(pam_h
|
||||
@@ -470,11 +472,17 @@ static int _unix_run_helper_binary(pam_h
|
||||
/* reopen stdin as pipe */
|
||||
dup2(fds[0], STDIN_FILENO);
|
||||
|
||||
|
2
pam.spec
2
pam.spec
@ -389,7 +389,7 @@ fi
|
||||
%doc doc/adg/*.txt doc/adg/html
|
||||
|
||||
%changelog
|
||||
* Tue Apr 23 2013 Tomáš Mráz <tmraz@redhat.com> 1.1.6-10
|
||||
* Wed Apr 24 2013 Tomáš Mráz <tmraz@redhat.com> 1.1.6-10
|
||||
- pam_unix: do not fail with bad ld.so.preload
|
||||
|
||||
* Fri Mar 22 2013 Tomáš Mráz <tmraz@redhat.com> 1.1.6-9
|
||||
|
Loading…
Reference in New Issue
Block a user