Update to Oz 0.12.0
Signed-off-by: Chris Lalancette <clalancette@gmail.com>
This commit is contained in:
parent
c69a4da98d
commit
7e8fb4e393
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/oz-0.9.0.tar.gz
|
||||
/oz-0.10.0.tar.gz
|
||||
/oz-0.11.0.tar.gz
|
||||
/oz-0.12.0.tar.gz
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 82541ec78cab9194eadb26ca93a9a7da28318d22 Mon Sep 17 00:00:00 2001
|
||||
From: Ian Mcleod <imcleod@localhost.localdomain>
|
||||
Date: Thu, 8 Aug 2013 14:45:46 -0500
|
||||
Subject: [PATCH oz] preseve original order of package list used for ICICLE
|
||||
generation
|
||||
|
||||
Sorting the default format package list destroys the 1:1 match between it
|
||||
and any optional extra list, at least for RPM based operating systems.
|
||||
This also has the unintended side effect of producing a blank <extra> tag for
|
||||
the final package in the list.
|
||||
As the sorting is purely cosmetic, and can easily be done on the receiving end
|
||||
for clients that desire it, just remove it here to address both issues.
|
||||
---
|
||||
oz/Guest.py | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/oz/Guest.py b/oz/Guest.py
|
||||
index 3b02601..32fd68d 100644
|
||||
--- a/oz/Guest.py
|
||||
+++ b/oz/Guest.py
|
||||
@@ -1291,7 +1291,6 @@ class Guest(object):
|
||||
description = icicle.newChild(None, "description", description)
|
||||
packages = icicle.newChild(None, "packages", None)
|
||||
|
||||
- lines.sort()
|
||||
for index,line in enumerate(lines):
|
||||
if line == "":
|
||||
continue
|
||||
--
|
||||
1.8.1.4
|
||||
|
22
oz.spec
22
oz.spec
@ -1,16 +1,15 @@
|
||||
Summary: Library and utilities for automated guest OS installs
|
||||
Name: oz
|
||||
Version: 0.11.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.12.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2
|
||||
Group: Development/Libraries
|
||||
URL: http://aeolusproject.org/oz.html
|
||||
Source0: http://repos.fedorapeople.org/repos/aeolus/oz/%{version}/tarball/%{name}-%{version}.tar.gz
|
||||
Patch0: 0001-preseve-original-order-of-package-list-used-for-ICIC.patch
|
||||
URL: http://github.com/clalancette/oz
|
||||
Source0: http://github.com/clalancette/%{name}/archive/%{name}-%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
Requires: python >= 2.5
|
||||
Requires: python-libguestfs >= 1.18
|
||||
Requires: libxml2-python
|
||||
Requires: python-lxml
|
||||
Requires: libvirt-python >= 0.9.7
|
||||
# in theory, oz doesn't really require libvirtd to be local to operate
|
||||
# properly. However, because of the libguestfs manipulations, in practice
|
||||
@ -34,7 +33,6 @@ installations, with minimal input from the user.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
python setup.py build
|
||||
@ -61,7 +59,7 @@ if [ ! -f %{_sysconfdir}/oz/id_rsa-icicle-gen ]; then
|
||||
fi
|
||||
|
||||
%files
|
||||
%doc README COPYING examples docs
|
||||
%doc README COPYING examples
|
||||
%dir %attr(0755, root, root) %{_sysconfdir}/oz/
|
||||
%config(noreplace) %{_sysconfdir}/oz/oz.cfg
|
||||
%dir %attr(0755, root, root) %{_localstatedir}/lib/oz/
|
||||
@ -81,8 +79,10 @@ fi
|
||||
%{python_sitelib}/oz-*.egg-info
|
||||
%{_mandir}/man1/*
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 3 2014 Chris Lalancette <clalancette@gmail.com> - 0.12.0-1
|
||||
- Update to release 0.12.0
|
||||
|
||||
* Thu Aug 8 2013 Chris Lalancette <clalancette@gmail.com> - 0.11.0-2
|
||||
- Add in the upstream patch that fixes ICICLE generation with extra elements
|
||||
|
||||
@ -122,7 +122,7 @@ fi
|
||||
* Wed Jun 29 2011 Chris Lalancette <clalance@redhat.com> - 0.5.0-1
|
||||
- Release 0.5.0
|
||||
|
||||
* Wed Jun 20 2011 Pádraig Brady <P@draigBrady.com> - 0.4.0-4
|
||||
* Mon Jun 20 2011 Pádraig Brady <P@draigBrady.com> - 0.4.0-4
|
||||
- Include examples/.
|
||||
|
||||
* Wed Jun 15 2011 Pádraig Brady <P@draigBrady.com> - 0.4.0-3
|
||||
@ -140,7 +140,7 @@ fi
|
||||
* Wed Mar 16 2011 Chris Lalancette <clalance@redhat.com> - 0.2.0-1
|
||||
- Release 0.2.0.
|
||||
|
||||
* Fri Feb 3 2011 Chris Lalancette <clalance@redhat.com> - 0.1.0-1
|
||||
* Thu Feb 3 2011 Chris Lalancette <clalance@redhat.com> - 0.1.0-1
|
||||
- Initial public release of Oz.
|
||||
|
||||
* Wed Nov 3 2010 Chris Lalancette <clalance@redhat.com> - 0.0.4-1
|
||||
|
Loading…
Reference in New Issue
Block a user